7.0.2.009 build for S905/S905X


  • I was 99.99% that was your chip. Now i am 100% sure. Thanks for confirming.


    From now on issues with the Nexbox A95X should have the chip S905 or S905X confirmed when posting.
    This is so important as it can cause wrongful instructions for fixes or comparison in behaviour. ;)


    So Android powers on and off with remote but LibreElec doesn't on S905. So this is in fact a LibreElec bug?


  • So this is in fact a LibreElec bug?


    No, it's not. I said that many times before: these boxes don't have wakeup from remote implemented properly in u-boot - probably wrong IR code. It's up to box vendor to fix it. Everybody else implements this properly, why don't they?

  • On Minix U1 it works, whichever version of LE i put, i can always power it ON with remote.


    Sent from my LG-D802

  • S905 k1plus user. The 26 build is not good for me on the live TV streaming side. The last 25 was better even if I had to restart the channels some time.

  • Is there a way to disable CEC? I've searched through settings and don't see anything. I have checked for peripherals under input devices and it's not there.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • Not wishing to incur the wrath of the Mods, but I have upgraded to the latest dev build on my Nexbox A95X S905X 1/8 and when I go into the very well known Lambda addon and search 'Movies' and then 'Most Popular' the little wheel in the bottom right hand corner says 'working' but then freezes and power cord has to be pulled and put back in to reboot. Have gone back to previous build and it is back to normal and working again.


  • Is there a way to disable CEC? I've searched through settings and don't see anything. I have checked for peripherals under input devices and it's not there.


    Go to System, System, Input devices, Peripherals, CEC. Disable the first option. Click ok. Done.

  • MX Plus TV Box Android 5.1.1
    64Bit 4K Internet Set-top Boxes Amlogic S905 Quad Core 1G 8G 2.4GHz WiFi HDMI 2.0 Connectivity


    First boot from sd works fine,but after a reboot the kodi Library is corrupted.
    Tried usb stick same result...


  • First boot from sd works fine,but after a reboot the kodi Library is corrupted.
    Tried usb stick same result...


    Try a good quality SD if you're not already. My boxes are very finicky about which cards I use. Cheap no-name "Class 10" cards were giving me all kinds of corruption issues. I only use Sandisk Extreme Plus and Samsung Evo cards now and no more issues.

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME

  • Very happy with your time and effort so I can enjoy my fast LibreElec kodi!
    Running on a x96 works till now flawless
    Ip TV, media playback just perfect


    Only hdmi cec TV turn on and TV turn of not working.
    I noticed that the add-on "Sleepy Watchdog" can turn off my tv.

  • Does S905X have support for 7.1 AAC?
    I'm playing 2016p 10bit H265 mkv over SPDIF to DTS decoder and sound is a bit distored like playing in the big hall....

    Edited once, last by Sine64 ().


  • I never had problem with 'TV Shows' and 'Movies' database. I guess your tricks (uploaded the advancedsettings file) just doesn't work on LibreELEC. There might be some changes in the SQL database version (at least it's totally different on Krypton). Did you try scanning your library again?
    [hr]


    Does S905X have support for 7.1 AAC?
    I'm playing 2016p 10bit H265 mkv over SPDIF to DTS decoder and sound is a bit distored like playing in the big hall....


    7.1 AAC was supported by LibreELEC, therefore it doesn't matter whether it is S905 or S905X.


    SPDIF was designed decades ago and only supports 5.1.


    Don't know what your DTS decoder means, guess it's your AV Receiver. LibreELEC or Kodi won't convert 7.1 AAC to DTS for your AVR to decode. Not sure what audio format the box will output through the SPDIF but I had no problem in playback of 2160p 10bit HEVC HE-AAC 7.1 mkv right from the very beginning, at least for audio.

    Edited once, last by wkchick ().

  • I'm currently not near my box, but there are options to downmix and encode to Dolby digital for optical output... The theory needs testing...


    Sent from my GM 5 Plus d using Tapatalk

    Edited once, last by mytbyte ().


  • I applied this update (like most of the test builds before) and ended up with the Google logo stuck in the upper left corner of the screen. LE did not start up. I put the build .img.gz only into the update folder and rebooted per normal.
    Ended up imaging back to the original 009 release. A bit gun shy now, as I'm not sure what will happen if I image a test build. Will wait for 010.
    [hr]


    Go to System, System, Input devices, Peripherals, CEC. Disable the first option. Click ok. Done.


    Thanks for the help. The kodi build I was using for some reason hid the peripherals selection. Changed builds and there it was.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

    Edited once, last by doggyofone ().

  • I never had problem with 'TV Shows' and 'Movies' database. I guess your tricks (uploaded the advancedsettings file) just doesn't work on LibreELEC. There might be some changes in the SQL database version (at least it's totally different on Krypton). Did you try scanning your library again?


    Thank you for your response! The version of Kodi that LE is running (16.1 "Jarvis") is the same as all of my other clients, so there should not be any issues with SQL db incompatibility.


    I am hesitant to start my db from scratch just for the purposes of testing LE, especially when the problem could be with the box and not LE. Could anyone chime in on what steps they took to get a LE box working with an existing SQL db?

    Edited once, last by twf85 ().