[8.0.2e] LibreELEC 8.0 for S905/S905X


  • For people who for some reason want to try 64bit 8.0.1a : LE – Google Drive
    LibreELEC-S905.aarch64-8.0-devel-20170324005706-r25765-ga2aa2b7.img.gz


    Hello Nofan,


    Can that version be just installed over the normal 32bits? Can a 32bits be installed afterwards as well?


    I remember when we went from 64 to 32 we needed to enter some compatibility command.


    Regards

  • Channel switching is super speedy now for me with these images. UK DVB-T2 channels and French/German/Spanish HD satellite channels via an external TVH server install.


    AV sync with the patched AC-3/E-AC3 passthrough is working really nicely too.


    Will Wetek Play 2 internal tuners be supported at some point with your images?

    Edited once, last by mrwish ().

  • hi,


    Is there any possibility that the codec Amlogic HW decoder bug will be ok.
    I've experimented with Odroid C2, S905, S912, all the same error, MPEG-4 HD
    frame jumps.
    I hope that comes out of some sort of correction.


  • Will Wetek Play 2 internal tuners be supported at some point with your images?


    No, because I don't have WP2. With the latest build my images should not be any different than official/Raybuntu's in channel switching speed.


  • Please provide a debug log and files to reproduce the frame skips.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test


  • I apologize for having to admit I never ran 32 so I have no experience with transitioning from one way to another.

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • Thanks for the great work. Just had a question regarding upgrading. I only just started with libreelec on version 8.0e. I was trying to upgrade through Kodi/Libreelec screen but the update channel section is blank. Have a missed a step or do I need to manually download and copy to the update folder.

  • There isn't an automatic update for these releases. You have to manually copy the file to /storage/.update

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • With 8.0.1a on Mini M8S II, I have an issue with non-bitstream output, that is, normal Kodi click sounds (activate by remote control movement) and (stereo) music files. (Bitstreaming, including DTS-MA/TrueHD works fine.) The setup is M8S II, to Yamaha AVR, to Sony FHD TV.


    The only way I can hear normal Kodi click and stereo sound is if either:
    1. Settings -> System -> Audio -> Output Configuration is "Fixed";
    OR
    2. Settings -> System -> Audio -> Output Configuration is not "Fixed" AND Stereo Upmix is enabled AND Number of Channels is not "2.0".


    Using Option 1 prevents bitstreaming, so, no good; option 2 means upmixing for my music, which I don't want. (Note: Audio output device is always "ALSA, AML-M8AUDIO, HDMI".)


    Have I misconfigured something, found a bug, or found incompatibility?

    M8SII (S905X/2G/16G/LE8.0.1a) - RX-V777 - KDL-70W850B

    Edited once, last by AlexF ().


  • Same problem for me!


    One of my box is connected to Samsung TV and I have noise when I play stereo music file. I must set Output configuration to "fixed" to solve the problem.


    My tronsmart Vegas S95 Telos box is connected directly to Samsung TV with HDMI cable.

    Edited once, last by mrtr32 ().


  • thx for answer. Is it possible also to be fault of cpu? What scraper do, that hardware have problems with library scan. I read on kodi forum that someone have the same problem with Rpi3, here.


    The question is, if its fault of memory, why i can move on menu after freeze of library scan, but after some time it totally freeze? Is it possible to change frequency of cpu or memory to check is it fault of them?


    If nobody can help me to investigate the problem i will send back it to seller.

  • Same problem for me!


    One of my box is connected to Samsung TV and I have noise when I play stereo music file. I must set Output configuration to "fixed" to solve the problem.


    My tronsmart Vegas S95 Telos box is connected directly to Samsung TV with HDMI cable.


    Try updating with the dtb

  • I have problem with all VC1 23.97 coded mkv.
    It's look like sometimes little bit stuttering the video when played.
    This problem affected by every version of Libreelec for Amlogic. Raspberry Pi play this files perfectly.
    When needed I can upload samples.
    Can we hope to fix this error?


    here is kodi sample file:
    VC-1_23.976_sample.mkv - Google Drive


    :R

    Edited once, last by envagyok ().

  • so I just tried to install libreELEC on to my ms9 p212 s905x but when I use the toothpick method and boot until libreelec logo shows up but gives me no option to install and it boots right to kodi. now when I take the usb out and restart box it boots in to android. I don't want this I just want libreelec what did I do wron if anyone can help I also used rufus

    Edited once, last by beeasy79 ().


  • Ok i think I like this way too does it work the same as it would as a standalone


    Providing you're happy with the performance, running LE from USB/SD simply gives you the best of both worlds.
    Boot to Android if you ever need to, otherwise it will boot to LE and behave exactly the same as if it were installed internally.


    If you do choose to install to internal, just remember to keep a copy of the dtb.img from the Android firmware along with your preferred recovery.img as you will need those present on an SD card, should you ever need to use the recovery partition

  • ok I have been reading trying to understand how to install and I have seen ssh way is there no way to just flash it like you do when installing the android firmware. I got so lost on the ssh process. and yes I have usb tools but none of the firmware I have will work. now the usb drive has firmware that works can I not create a img with that. idk I feel so lost installing this on internal memory

    Edited once, last by beeasy79 ().