[8.0.2e] LibreELEC 8.0 for S905/S905X


  • Yes, I also see a massive difference in speed when switching iptv channels. In 7.0.3.012j it takes about 1.5 seconds to switch to the next channel. 8.0-8.0.0e takes about 9 seconds. I think that is a problem of the new version of Kodi and not Libreelec as the effect is the same for Kodi Kryption on Android.


    then kodi 17 is not ready yet for iptv users, some people are saying its much better in milhouse build but yea some1 needs to build it for amlogic we need to wait till then and use jarvis :/ thx for your answer


  • How can we make the GPU speed setting permanent after boot?


    put the command into autostart.sh (in configfiles) followed by a semicolon. E.g.


    echo 5 > /sys/class/mpgpu/cur_freq;

    cheers,
    azido
    System: Bqueel T95-Max TV Box | 2 GB Ram | 32 GB eMMC | Amlogic S905 Cortex A53 Qcore CPU 2Ghz | GPU Mali-450 5-Core | WLAN 2,4 & 5 Ghz | LAN 1000/100 Mbit
    OS: Android 5.1.1 on Nand |LibreELEC 8.90.4 Build on SD

  • then kodi 17 is not ready yet for iptv users, some people are saying its much better in milhouse build but yea some1 needs to build it for amlogic we need to wait till then and use jarvis :/ thx for your answer


    I do not have any problems in combination with media portal tv server. Switching between iptv channels takes approximately 500ms - 1500ms.

  • Hi guys,
    I have upgraded from 7.0 on the S905X 2gb ram to 8.0 via samba shares as per thread-5556.html


    However, when booting, I get a:
    -----------------------------------------
    *** Error in mount_flash: mount_common: Could not mount LABEL = Libreelec***
    ### Starting debugging shell... type exit to quit ###
    sh: can't access tty; job control turned off


    -----------------------
    7.0 was originally installed on a microSD card which has been working well.


    Any suggestions?


    Thanks in advance for your help.


  • You should rename Your partitionlabels to LIBREELEC and LIBREELEC_DISK. that's all it takes.
    regards!

    Raspberry Pi2 LibreELEC Milhouse nightly builds

    Q-Box 2G/8G and Q-Box 2G/16G LibreELEC 8.2 kszaq 's
    NexBox A95x balbes150 Armbian_5.32_S9xxx_Debian_jessie_3.14.29_server_20170907 with tvheadend and OScam.
    Digibit R1 Sat>IP server. (80 cm. dish with disecq 4/2 (28.2E, 23.5E, 13.0E, 19.2E) and fixed 90 cm. dish at 30.0W)

    4 x TP-LINK TL-PA411

  • I have only just tried out LibreELEC 8 with my new sample Enybox X1 1gb/8GB which was runnign from internal LibreELEC 7.0.3.012j with a full suite of add-ons etc. Originally I tried just the update path putting the V8 file in the .update folder in the usual way and indeed put the latest gxl 1GB device tree file in there too, and then rebooted. Yes it did the update BUT would not run up at all.


    So I tried a clean install of LibreELEC 8 build (version d) with a new SD card and this worked fine and booted into the convoluted not so nice KODI 17 homescreen. Thsi was fine until I restored, using the LibreELEC restore feature, my KODI 16.1 earlier backup of all my add-ons and settings, then same result it would not boot up into KODI adn after tgeh LibreELEC boot up screen was left with a balnk black screen. So had to assume that it is not possible to restore your settings and add-ons from an old KODI 16.1 LibreELEC 7 setup ???


    Tried it again with fresh made up SD card with LE8 but this time I painstakingly manually reinstalled my respositories and add-ons and it now works fine. Flashed to NAND with installtointernal command too and with no problems. Sorry if this has been mentioned before but lookign through over 100 pages in this thread is going to take way too long to find, so can anyone help here or point me to any relevant posting(s) here.


    I would love simply to be able to update with all the add-ons and settings a LibreELEC 7.0.3.012x box to LibreELEC 8 if this is possible. Anyone ?


    Have to say so far I am NOT a lover of the new KODI 17 default skin at all. Need to play around with it and remove all those Library links that I do not use to make it less cluttered and long winded to navigate. Much prefer the old Confluence skin (can that be installed on KODI 17?), but then again it is early days and the old problem of familiarity with Confluence and not with the new skin (Estuary ??) of course. Sure I will persevere with KODI 17 and climb the much needed new learning curve. :s


    Cheers
    RayW

    Cheers
    RayW


    Tanix TX9 Pro 3/32GB S912

    Tanix TX7 2/32GB S905X

    Beelink MINI MXIII II 2/16GB S905X
    MXQ M12CX 1/8GB S905X
    MXQ M12 1/8GB S805
    Denon X500 AVR System

    LG 55SJ850T Super UHD TV

    Edited once, last by RayW ().


  • Hy,


    how can I read CPU temperature over SSH?


    type cputemp

    Code
    1. Krypton-Box:~ # cputemp
    2. 45 C


    write a script
    vi my-temp.sh

    Shell-Script
    1. #!/bin/bash
    2. # Script: my-temp.sh
    3. # -------------------------------------------------------
    4. FILE=/sys/class/thermal/thermal_zone0/temp
    5. CPU=`head -n 1 $FILE`
    6. echo "CPU Temperature: $((CPU/1000))'C"


    chmod +x my-temp.sh

    Code
    1. Krypton-Box:~ # ./my-temp.sh
    2. CPU Temperature: 46'C

    Edited once, last by Tim_Taylor ().

  • I do not know, what happened, but from one day to another
    all my movies/series were not shown anymore in Kodi.


    So, I tried to update/scan again all the files, but it says, there
    is nothing new.


    Then I read about deleting the database files, which I did, but
    even after a reboot I cannot update/scan the files with success.


    Anyone else having an issue like that or knowing a solution?


    Thank you in advance.



    PS The NAS is working fine, I could even play a movie on Kodi with
    using the stream plugin (Yatse). So, it has no access limitations and
    it was working the last twelve months, too.

    Edited once, last by sYCO ().


  • I know it's a pain, change sources to none, let it clean up the library then reset source to movies & scan again.


    Failing that, browse storage\.kodi somethere is the videos.db delete that, it might be myvideos.db

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

    Edited once, last by bubblegum57 ().


  • I know it's a pain, change sources to none, let it clean up the library then reset source to movies & scan again.


    Failing that, browse storage\.kodi somethere is the videos.db delete that, it might be myvideos.db


    I did the second, already. I deleted the myvideos.db files in kodi/userdata and restarted the box.

  • Hello.Why automatically start Wifi at boot LE? I have to put in the settings - connect.... Beelink MXIII II boot LE 8.0e from a USB.... :huh:

    Edited once, last by otava5 ().

  • You should rename Your partitionlabels to LIBREELEC and LIBREELEC_DISK. that's all it takes.
    regards!


    Thanks - but which partitions?
    I have:
    /dev/mmcblk1p2 "DISK"
    /dev/mmcblk1p1 "BOOT"
    /dev/data (no label, just a UUID)
    /dev/system "System"
    /dev/cache (no label, just a UUID)


    I would partly assume disk = libreelec_disk, and boot = libreelec
    but save screwing things up, can you confirm?


    Thanks


  • I would partly assume disk = libreelec_disk, and boot = libreelec


    Yep
    [hr]


    Thsi was fine until I restored, using the LibreELEC restore feature, my KODI 16.1 earlier backup of all my add-ons and settings, then same result it would not boot up into KODI adn after tgeh LibreELEC boot up screen was left with a balnk black screen. So had to assume that it is not possible to restore your settings and add-ons from an old KODI 16.1 LibreELEC 7 setup ???


    Bingo!


    I would love simply to be able to update with all the add-ons and settings a LibreELEC 7.0.3.012x box to LibreELEC 8 if this is possible. Anyone ?


    Do a clean install of your old KODI 16.1 LibreELEC 7 version and restore your backup. Then update to the latest version using the .update folder


    Much prefer the old Confluence skin (can that be installed on KODI 17?)


    Yes it can ;)

    Edited once, last by Poida ().


  • Yep


    Sil


    Great thanks
    One thing, I tried renaming with e2label, but its not found, so I need to install it, but the system isn't operational (sudo apt-get not found, apt-get not found etc)
    Is there a lower level way to rename the partitions?


    Thanks


  • Is there a lower level way to rename the partitions?


    I'm a Windows user (so a bit baffled with the Linux stuff). If nobody else can help, and you have a previous backup, you could install that build to your SD and restore, then try again with the upgrade. It happened to me a while ago and I think I did a clean install of LE 8 and then manually copied the .kodi folders from a backup. Then I updated each add-on.