[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Hi,


    did something change in last builds for SD contents? SD videos suddenly look AWFUL (did not in previous LE 8.x builds) and they are also very very choppy. I did not notice earlier since I don't watch SD often. I tried a couple of them and it seems the same problem with all of them.


  • Hi,


    did something change in last builds for SD contents? SD videos suddenly look AWFUL (did not in previous LE 8.x builds) and they are also very very choppy. I did not notice earlier since I don't watch SD often. I tried a couple of them and it seems the same problem with all of them.


    I agree, I am watching with my kids old The Cosby Show episodes (all in SD) and they buffer a lot and are choppy on my Beelink MX III II. It doesn't happen on my other Beelink MX III II with LE 7.0.3.012j. Maybe it's just coincidental...

    Edited once, last by frem ().

  • Hello. Which of the S905x boxes would you recommend? Nexbox A95X / Beelink MINI MXIII II / Mini M8S II / X96 / other? Just LE a couple of plugins a installed to NAND.... Thnx :shy:

    Edited once, last by otava5 ().

  • Are there any issues with installing an older build over the current one?
    [hr]


    kszaq
    On 8.0.0d, It seems commit 8ab0f5 on the Kernel broke ALSA audio on S905, its weird because audio works inside Kodi, but if you run other programs (like Retroarch) sound is missing, if I revert this commit (or use commit 84ad67 which is one before) and compile from source sound works again, any idea why this might be ?


    And also not as important and it might not be relevant to you, but might be worth a mention. At least for me the new peripheral joystick add-on doesn't work anymore (it worked out of the box for 8.0.0c) :( I use an Xbox 360 controller (and a Logitech F310) and I can move around with the analog stick, but the buttons don't work at all (A,B,X,Y,L,R,etc) not even if I try to set it up under input settings.


    Thanks again for all the awesome work you are doing for these SOCs :)



    Having the same problem inside Kodi. On occasion, I have to restart the content so the audio kicks in.

    Edited once, last by Vinylity ().

  • Hello kszaq


    first of all thanx for wonderful work, a95 box runs perfect


    having issues with beelik M18 2g/16 when i update to 8.0.0d it updates but boots back with black screen


    LibreELEC-S905.aarch64-7.0.2.003 is the only version seems to be working on that can you please into it,, or maybe guide me


    thanx


  • Hello. Which of the S905x boxes would you recommend? Nexbox A95X / Beelink MINI MXIII II / Mini M8S II / X96 / other? Just LE a couple of plugins a installed to NAND.... Thnx :shy:


    Keep in mind that each box / model has different versions with varying hardware.


    I have the Nexbox A95X-B7N in 2GB/16GB configuration and it works great. The wifi is also strong and supports 5Ghz. The version with 1GB ram however doesn't support 5Ghz wifi.


  • Anyone else having a problem with videos freezing in the last 3 sec of the video. Audio continues to play with frozen video. Its not crashing the box, and not a big deal, just curious if im the only one.
    This didnt happen on any of the 7.0.3.012 builds.
    Tronsmart S95x box.


    This problem described as above - 'picture freezes and audio continues in the last seconds' is still a current issue on the 8.0 builds.
    Its only happening with 10-15 seconds short video's.


    Changing latency/delay value's in advancedsettings does not have any effect whatsoever.


    Is there a fix for this Kzsaq?

    MXQ-Pro 905 Blue board rev 0.2

    Edited once, last by happysat ().

  • kszaq - on my box the current value for /sys/class/mpgpu/cur_freq is 500, not a single digit. Should I still change it to just 5 if I want to try the higher frequency?


    For info, the contents of every file in /sys/class/mpgpu/ are


    Any information about this post plz? I encounter the same problem.


    Where do we have to input "echo 5" to overclock the gpu?


    Thanks


  • Any information about this post plz? I encounter the same problem.


    Where do we have to input "echo 5" to overclock the gpu?


    Thanks


    Is it that hard to read the quoted post? post-38536.html#pid38536
    [hr]


    This problem described as above - 'picture freezes and audio continues in the last seconds' is still a current issue on the 8.0 builds.
    Its only happening with 10-15 seconds short video's.


    Changing latency/delay value's in advancedsettings does not have any effect whatsoever.


    Is there a fix for this Kzsaq?


    Nobody has ever posted a log as requested many times = issue is ignored. I would really like to resolve issues but I can't ask for logs every single time. I created single sticky post to be clearly visible. I ask to read it in OP. And yet everyone ignores it.

    Edited once, last by kszaq ().

  • Hi, I use this serie of builds and now specially the 8.0d one on my Nexbox A95X S905X (2G + 16G) box. Not Nand installed so it runs from SD. I don't no if it's an issue, but the bluetooth interface is always disable with these builds and I cannot find a way to enable it if possible. Can someone helps or clarifies on that.


    TIA


  • Hi, I use this serie of builds and now specially the 8.0d one on my Nexbox A95X S905X (2G + 16G) box. Not Nand installed so it runs from SD. I don't no if it's an issue, but the bluetooth interface is always disable with these builds and I cannot find a way to enable it if possible. Can someone helps or clarifies on that.


    TIA


    Have you tried; Programs/LibreELEC Configuration, Menu >"Services" and at the bottom of the list "Enable Blutooth"?


    -2re

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • kszaq - after my problem with my S905x box not supporting audio rates higher than 96kHz, I have sourced a cheap Tronsmart S95 Pro. This is an S905 box with 1GB RAM, 8GB flash and 1GB ethernet. I've used the appropriate device tree gxbb_p200_1G_1Gbit.dtb and everything is working fine from SD card - wireless, BT, ethernet, remote etc.


    However, I have a continuing issue with high-def sound which is in excess of 96kHz sampling rate. I have several stereo flac files ripped at 192kHz from my DVD-Audio disks which are detected by Kodi as 192kHz 2.0 and it seems to initialise the sink correctly but no sound is output to my AV amp. With the s905X box it was downsampled to 96kHz but with this box - no output. I can force the sample rate to 192kHz in the Kodi System/Audio menu and then the sound is output correctly on the L & R channels at 192kHz but the sink is initialised as 8 channels depending on the speaker configuration (7.1). I'm not sure if it's a bug in Kodi or something I can tweak in the settings. Ideally I would set "best match" in the Kodi settings and then let Kodi output to the AV amp at the relevant sample rate and number of channels contained in the source file. I noticed that in the "Fixed" sampling rate settings in Kodi I can use 44.1, 88.2, 96 and 192kHz but not 176.4kHz. Is this an omission as I have several high-bitrate SACD files at 176.4kHz.


    snip of the Kodi log showing the setting of fixed bit rate of 192kHz which allows playback of stereo through my AV amp:


    snip of the log showing automatic setting of sample rate to two-channel 192kHz which results in silence through my AV amp:


    The only difference I can see is that the initialisation is "surround51:CARD=AMLM8AUDIO,DEV=0" in the working example and "front:CARD=AMLM8AUDIO,DEV=0" in the example where no audio is output.


    Full log here - log-2017-03-08-11.16.43.zip

    Edited once, last by fat-tony ().

  • Is it that hard to read the quoted post? post-38536.html#pid3853


    Sorry kszaq but the quoted post do not answer the relevant question asked by renzz :


    " kszaq - on my box the current value for /sys/class/mpgpu/cur_freq is 500, not a single digit. Should I still change it to just 5 if I want to try the higher frequency?"

    Edited once, last by Frisk ().

  • Sorry kszaq but the quoted post do not answer the relevant question asked by renzz :


    " kszaq - on my box the current value for /sys/class/mpgpu/cur_freq is 500, not a single digit. Should I still change it to just 5 if I want to try the higher frequency?"


    I use the folowing;


    echo 5 > /sys/class/mpgpu/max_freq
    echo 5 > /sys/class/mpgpu/min_freq
    echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor


    Full sped all the time;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Hey folks,


    I just want to report a problem that I have with my s905 with 8.0.0c and d-version.
    Sometimes my beelink mini mx iii is going to suspend and it won't turn on with cec-communcaction. The box turns off after the tv is off for some hours or minutes, so I guess it's something with energy saving or deep standby.
    Maybe someone has the same problems or can tell me where I can find those options to turn it off.


    Thanks!