[8.0.2e] LibreELEC 8.0 for S905/S905X

  • Only one minor problem on .10. I had to modify Hyperiond.start script to wait few seconds before deamon could start. Without this startup effect (rainbow swirl) got stuck after 1 second. In one of the first bulids it was unnecessary.

  • Hello kszaq,


    Thank for your great work, very promising. I'm testing the last alpha build with Kriptoon on my nexbox A95X S905X 2g/16g (stamped on 2016-12-04) through SD-card. It starts well on my box but I can not install any local addon because the "installation from a zip" button does not work. Is this due to the alpha build stage ? I used to do that without any problem in your 7.02 serie's builds.


  • Hello kszaq,


    Thank for your great work, very promising. I'm testing the last alpha build with Kriptoon on my nexbox A95X S905X 2g/16g (stamped on 2016-12-04) through SD-card. It starts well on my box but I can not install any local addon because the "installation from a zip" button does not work. Is this due to the alpha build stage ? I used to do that without any problem in your 7.02 serie's builds.


    It ('Installation from Zip' button not working) doesn't only happen on kszaq's Krypton build, but also on RPi2. Hence it might be a bug in 17.0 beta 6. To circumvent that, just go to 'Add-on browser' and click on 'Install from zip' there.

  • It ('Installation from Zip' button not working) doesn't only happen on kszaq's Krypton build, but also on RPi2. Hence it might be a bug in 17.0 beta 6. To circumvent that, just go to 'Add-on browser' and click on 'Install from zip' there.


    Thank a lot wkchick, I'll try to follow your advice later.

  • Hi, new here. Apologies if this has been asked, but when can 23.976 support be expected in Krypton builds? I was told at Kodi forum that it's presently only supported in Jarvis w/LibreELEC for AML S905/905X? Thanks.

    Kodi with full 3D & HD audio home theater enthusiast


  • Hi, new here. Apologies if this has been asked, but when can 23.976 support be expected in Krypton builds? I was told at Kodi forum that it's presently only supported in Jarvis w/LibreELEC for AML S905/905X? Thanks.


    I just saw that FRA patch by codesnake was included in latest libreelec alpha release by raybuntu for wetek play2 #15 .
    So it shouldn't be long, right kszaq ?


    Thank you so much everyone for your contributions!

    Nexbox A95x (S905X) running kszaq's LE 8.1.10 build

  • I was casually searching for a linux based system for my neo U1 (I use to have openelect on my defunct amlogic s802 machine, bought a minix neo u1 months ago and never had time to hack it), and I ended up here, cool. I always wanted to try the new default UI in Krypton, so I ignored the "stable" libreelect 7.0 that seems to work on the Minix Neo U1, and tried directly the latest 8.0-devel alpha build.


    So, my machine is a Minix NEO U1.
    firmware used: LibreELEC-S905.arm-8.0-devel-20161204210449-r24821-g9f57b18.img
    device-tree : gxbb_p200_1Gbit.dtb (from 7.0.2.007 here)


    Got a random 2Gb USB, flashed librelec img, replaced the dtb.img, arrived home from the office, insert the usb in a random port: libreelect booted up, totally unexpected, super cool!


    Out of the box:
    Screen resolution is set to 3840×2160, fits perfectly.
    WiFi works, I was expecting not to, yay!
    can connect and control with the kore android app, can add remote sources, can downloads add-ons, can stream music and videos.. it just works
    HDMI-CEC is perfect (samsung 4k "curved" TV)
    3rd party remote with a "pointer" mouse and keyboard on the back works, pointer works, keyboard works. (I forgot to test the remote bundled with the box)


    Problems:
    Audio doesn't work
    the option is greyed out in the system settings and the only choice is Bluetooth/pulseaudio.


    I can't find any option that would enable HDMI passthrough, I think I could try to connect a bluetooth speaker to the box but it would be simplier to just wait for a fix.


    Untested is:
    Bluetooth, I just enable it, but forgot to test further... (I may gibe it a try with the speaker, next time I boot up)
    Ethernet, I can test it eventually, just to report, if needed.
    Live TV, I have an old AverTV A800 DVB, which I may try to connect to test dvb... but I'm not sure it is going to work ever, I don't even have an antenna...


    As a first test I'm very impressed!
    Is there a quick fix for the audio problem (eg some blob I need to place somewhere)?


    Good job and thanks!


  • Problems:
    Audio doesn't work
    the option is greyed out in the system settings and the only choice is Bluetooth/pulseaudio.


    I can't find any option that would enable HDMI passthrough, I think I could try to connect a bluetooth speaker to the box but it would be simplier to just wait for a fix.


    Audio option field 'Greyed' and show only 'Bluetooth/pulseaudio' was caused by applying the wrong device trees. Based on the OP, you should pick the same device but from 7.0.2.009 here instead of 7.0.2.007.

  • 79bass : I can also confirm that device tree from 009 build works OK and audio works on Minix U1 - there are audio/sync issues though sadly for now.


  • I just saw that FRA patch by codesnake was included in latest libreelec alpha release by raybuntu for wetek play2 #15 .
    So it shouldn't be long, right kszaq ?


    A patch from Codesnake is included in my development kernel (on my hard drive :P) so it will be also included in my next build. One more think that I want to include for S905 are media_build DVB drivers. Christmas is coming so I'm a bit busy with more important stuff but you should expect a new build soon.


  • 79bass : I can also confirm that device tree from 009 build works OK and audio works on Minix U1 - there are audio/sync issues though sadly for now.


    Thanks! but in 009 the gxbb_p200_1Gbit.dtb is gone. So I guess I should use the gxbb_p200_2G_1Gbit.dtb instead.


    There is also a device tree in the .010, :P.


    Hopefully the audio sync will be fixed once the playback framework is sorted out completely in the following builds... it's still alpha after all.

  • A patch from Codesnake is included in my development kernel (on my hard drive :P) so it will be also included in my next build. One more think that I want to include for S905 are media_build DVB drivers. Christmas is coming so I'm a bit busy with more important stuff but you should expect a new build soon.


    Really appreciate all your work kszaq :).

    Kodi with full 3D & HD audio home theater enthusiast


  • I can also confirm that device tree from 009 build works OK and audio works on Minix U1 - there are audio/sync issues though sadly for now.


    I just got a MINIX Neo U1 and I would like to get perfect playback.


    Which build should I install?
    I have sync issues with the latest devel and the 010 ones

    Will it be possible to use HQ scalers (Lanczos3/Spline36)?


    Thanks!

    Edited once, last by foozoor ().

  • Hi kszaq,


    I've noticed that you are using your own libreelec repository, could you please add to it script.moonlight? There is no such package in repository, but in aarch64 build/repo it was.

  • Hi kszaq,
    thanks for your work so far.


    I have issues with a 2160p HDR 10bit video played with an S905X box running the 7.90 alpha on a 4k HDR tv.
    Black is displayed as grey (including the top and bottom borders), other 2160p HDR 10bit videos work fine though.
    I've tested the video on my pc (without h265 hw support) and many players (mpc-hc, vlc) have issues with the video (weird colors), only mpv-player plays the file flawlessly.


    Here's the media info output:
    ID : 1
    Format : HEVC
    Format/Info : High Efficiency Video Coding
    Format profile : Main [email protected]@High
    Codec ID : V_MPEGH/ISO/HEVC


    Bit rate : 60.7 Mb/s
    Width : 3 840 pixels
    Height : 2 160 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 23.976 (24000/1001) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 10 bits
    Bits/(Pixel*Frame) : 0.305
    Stream size : 51.9 GiB (88%)
    Writing library : x265 2.0+18-b0ec268aef60:[Windows][GCC 6.1.0][64 bit] 10bit
    Encoding settings : wpp / ctu=64 / min-cu-size=8 / max-tu-size=32 / tu-intra-depth=1 / tu-inter-depth=1 / me=1 / subme=2 / merange=57 / no-rect / no-amp / max-merge=2 / temporal-mvp / no-early-skip / rskip / rdpenalty=0 / no-tskip / no-tskip-fast / strong-intra-smoothing / no-lossless / no-cu-lossless / no-constrained-intra / no-fast-intra / open-gop / no-temporal-layers / interlace=0 / keyint=250 / min-keyint=23 / scenecut=40 / rc-lookahead=20 / lookahead-slices=8 / bframes=4 / bframe-bias=0 / b-adapt=2 / ref=3 / limit-refs=3 / no-limit-modes / weightp / no-weightb / aq-mode=1 / qg-size=32 / aq-strength=1.00 / cbqpoffs=0 / crqpoffs=0 / rd=3 / psy-rd=2.00 / rdoq-level=0 / psy-rdoq=0.00 / log2-max-poc-lsb=8 / no-rd-refine / signhide / deblock=0:0 / sao / no-sao-non-deblock / b-pyramid / cutree / no-intra-refresh / rc=abr / bitrate=61000 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv-maxrate=160000 / vbv-bufsize=160000 / ipratio=1.40 / pbratio=1.30
    Default : Yes
    Forced : No
    Color range : Limited
    Color primaries : BT.2020
    Transfer characteristics : SMPTE ST 2084
    Matrix coefficients : BT.2020 non-constant
    Mastering display color primaries : R: x=0.680000 y=0.320000, G: x=0.265000 y=0.690000, B: x=0.150000 y=0.060000, White point: x=0.312700 y=0.329000
    Mastering display luminance : min: 0.0001 cd/m2, max: 1000.0000 cd/m2
    Maximum Content Light Level : 1000 cd/m2
    Maximum Frame-Average Light Level : 500 cd/m2


    All the other working videos have
    Format profile : Main [email protected]@Main or (Main [email protected]@Main)
    Color primaries : BT.709
    Transfer characteristics : BT.709
    Matrix coefficients : BT.601


    instead, so I guess there might be an error with the color primariers (?).


    Thanks in advance!

  • BT.709 is the regular colorspace. BT.2020 is the extended colorspace.


    All HDR formats use BT.2020 (to my knowledge, see also Rec. 2020 - Wikipedia)


    -> your working videos are most likely not HDR

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test


  • Hi kszaq,


    I've noticed that you are using your own libreelec repository, could you please add to it script.moonlight? There is no such package in repository, but in aarch64 build/repo it was.


    Moonlight was broken at the time of building addons. It's been fixed since then and I will build it for the next addon repo update.