7.0.2.007 build for S905


  • umark62 and RowanDDR did you also install new device tree?

    Code
    1. dd if=path_to_new_device_tree of=/dev/dtb bs=256k


    I copied the working device tree (dtb.img) for my unit to the root of the SD card before I did the toothpick install. This is the same device tree used in v007 which is working fine. Is there a different procedure for the devel builds??

    Edited once, last by ukmark62 ().

  • device_trees has newer devicetrees as you can see, so if your dtb is from before 22 Sep. then you need to update it on your sd card and also on nand, according to kszaq

    Quote


    Can you re-download a device tree from 7.0.2.007 build and try the devel build again? Amlogic introduced a new timer (BC_TIMER) that may be needed for audio to work correctly.

    Edited once, last by cHarOn ().


  • device_trees has newer devicetrees as you can see, so if your dtb is from before 22 Sep. then you need to update it on your sd card and also on nand, according to kszaq


    Thanks for your help!


    I downloaded the newer version of the device tree (in my case 'gxbb p200 2G 1Gbit OTG Port.dtb', renamed it to dtb.img and placed it on the root of the sd card - rebooted and all working now! Thanks again :D


  • device_trees has newer devicetrees as you can see, so if your dtb is from before 22 Sep. then you need to update it on your sd card and also on nand, according to kszaq


    The instructions for updating from a 006+ build in the OP don't mention anything about device trees... I quote again:

    Quote


    Updating from 7.0.2.006 or later (devel builds):
    https://wiki.libreelec.tv/index.php?titl..._LibreELEC


    To update device tree (this is not needed if everything worked for you at 7.0.2.006):

  • What issue do you have with WiFi? Any details for "the fix"?

    Unfortunately I can not explain, I can only quote the "Hello everyone.


    I figured out why T95 wifi slow and does not work with the remote switch. Wifi is slow because it is a bad Chinese cut off IRQ for sdio in meson1.dtb file. patch for it below


    --- Meson1.dts.old 2016-05-05 15: 54: 10.000000000 -0400
    +++ T95.dts 2016-05-05 16: 19: 08.428008400 -0400
    @@ @@ -1173.7 1173.7
    dev_name = "aml_newsd.0";
    status = "okay";
    reg = <0x0 0xd0070000 0x0 0x2000>;
    - Interrupts = <0x0 0xd8 0x1>;
    + Interrupts = <0x0 0xd8 0x4>;
    pinctrl-names = "sdio_clk_cmd_pins", "sdio_all_pins";
    pinctrl-0 = <0x2d>;
    pinctrl-1 = <0x2e>;
    @@ @@ -1182.7 1182.7
    status = "okay";
    pinname = "sdio";
    ocr_avail = <0x200080>;
    - Caps = "MMC_CAP_4_BIT_DATA", "MMC_CAP_MMC_HIGHSPEED", "MMC_CAP_SD_HIGHSPEED", "MMC_CAP_NONREMOVABLE", "MMC_CAP_UHS_SDR12", "MMC_CAP_UHS_SDR25", "MMC_CAP_UHS_SDR50", "MMC_CAP_UHS_SDR104", "MMC_PM_KEEP_POWER";
    + Caps = "MMC_CAP_4_BIT_DATA", "MMC_CAP_MMC_HIGHSPEED", "MMC_CAP_SD_HIGHSPEED", "MMC_CAP_NONREMOVABLE", "MMC_CAP_UHS_SDR12", "MMC_CAP_UHS_SDR25", "MMC_CAP_UHS_SDR50", "MMC_CAP_UHS_SDR104", "MMC_PM_KEEP_POWER", "MMC_CAP_SDIO_IRQ";
    f_min = <0x61a80>;
    f_max = <0xbebc200>;
    max_req_size = <0x20000>;. "Attached is my revised dtb

    Files

    • dtb.zip

      (9.37 kB, downloaded 77 times, last: )
  • RowanDDR Don't you understand that instructions in OP are for 7.0.2.007 release build? If you want to use development builds, you have to follow instructions that are posted later. If you don't want to follow later instructions, don't use development builds.


    KeNt606 This is already included in device trees for 7.0.2.007.

  • I have an MXQ Pro+ box 2G 16GB, 1gb. The firmware was so bad when I got it that I flashed a Russian rom that was compiled from the Tronsmart Meta rom. This stabilized the box, but Android/KODI was not smooth running and WiFi did not work. I ran OE 6.95.3 via balbes150's aml_autoscript off an SD card for some time and it worked great, but still no WiFi. I have tried to install several LE 7.0 roms/sd boot methods since then, but could get nothing to run off of SD but 6.95.3.
    I tried earlier versions of kszaq's 7.0 script, tried several dtb images and tried numerous ways to boot the box (no reset switch). Finally I tried 7.0.2.007 with the Sept 22 gxbb_p200_2G_1gbit.dtb image. I extracted 7.0.2.007 img to sd, renamed the gxbb img to dtb.img and pasted it to the sd card, overwriting the dtb.img from the extraction, started the box in Android, inserted the sd card into the box, opened update&backup and then I opened "select", selected the first zip from the list and then hit the "update" button. These steps haven't worked with other roms for me, but this time it did and LE loaded up.
    I haven't seen any issues so far and the box is now stable and runs fast.
    Hopefully someone else who has one of these boxes and has problems and/or wants to run LE comes across this note. The box is great, but getting it to run LE has been a challenge.
    Thanks kszaq. Great ROM, coffee money on the way.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • @Kszaq....just wanted to say that I have the latest version running on both my Mini MXiii and it is running absolutely smoothly and no probs at all....many thanks.

  • I can't get this to boot on my MXQPlus via usb. The toothpick method just stalls at the Amlogic logo. When I reboot to recovery it just reboots to the normal android recovery menu.


    edit: just tried with an SD card. Same result.


    edit 2:
    So this is odd... I burned the image using both Rufus and HDDRawCopy and both failed. But when I look at this drive this is all that comes up:


    mmcblk1 179:64 0 7.2G 0 disk
    ├─mmcblk1p1 179:65 0 512M 0 part
    └─mmcblk1p2 179:66 0 32M 0 part


    So there is something missing.... I'll check out the images again and see what I can figure out.


  • The toothpick method just stalls at the Amlogic logo.


    This generally happens when you have used an incompatible device tree for your box.
    Can you detail what tree you have used and what version of LE you are trying to flash.
    Also supply your specs for the box MXQ Plus ? EG: 1 or 2gb of ram, 8 or 16gb storage and
    ethernet 100 or 1000 mb.
    Then we may be able to guide you.


  • I extracted the dtb myself, and I've used it for months launching Armbian, so I know it is correct.




    So there is something missing.... I'll check out the images again and see what I can figure out.


    S905 only: Download a device tree, rename it to dtb.img and copy it to main folder of SD card/USB drive - replace the one that's already there.


    You missed all of the above. That is why i asked you for all the details of your box previously.


    Get it working properly with correct device tree on SD Card LE version first before installing on Nand.


  • I extracted the dtb myself, and I've used it for months launching Armbian, so I know it is correct.


    You know it is correct for Armbian. In my builds >= .006 I am using an updated kernel that needs many modifications of previous device trees. That's why I dropped aml_autoscript magic and require users to choose a tree from provided ones.

  • Many thanks. I am now the proud owner of a Beelink MiniMX booting to build 007 of LibreElec


    First of these I've done but have done many Satellite boxes with Enigma2, Openvix etc so was aware of the potential of bricking (which I did on the Mini MX).


    Solution was to:


    (1) Create a USB stick and the LibreElec SD/ISB burning software
    (2) Toothpick install


    voila


    A few pitfalls


    (1) I now don't have any recovery option (but not that bothered to be honest)
    (2) Had to trial and error which USB stick worked (I tested several and found an SD card in a USB adaptor to be the only one that worked)
    (3) Trial and error which USB port works (this was noted on the first thread).
    (4) Keyboard didn't work so thank you to the poster who posted the3 remote.conf. Works fine now.


    And over all thank you to kszaq. It is much appreciated.


    p.s. I did try to push my luck and do an upgrade to Kodi 17. Bricked it again lol. Is there a working copy of 17 available for this sS905 device?

    Edited once, last by archercj ().


  • (1) I now don't have any recovery option (but not that bothered to be honest)


    Your original device tree and recovery image copied to an SD Card will get you into recovery if you ever need to.

  • Kodi 17 build is not yet available. I don't have enough free time to work on both Kodi 16 and 17. :(


    My plan is to start work on PRing S805 and S905 support to master LibreELEC branch after I release 7.0.2.008.


  • Kodi 17 build is not yet available. I don't have enough free time to work on both Kodi 16 and 17. :(


    My plan is to start work on PRing S805 and S905 support to master LibreELEC branch after I release 7.0.2.008.


    I dont understand many people, why want to upgrade to next kodi (what is still alfa/beta)...
    For what i use it (playing video, listen music,tv), the old kodi 14,15,16 perfect. All of them play perfectly video, no important news about it.
    More important is: good kernel to amlogic devices, and bugfixes.