Video stutter 25Hz Videoplayback with Hardwaredecoding Libreelec 9.0

  • Just apply the workaround in this thread and the stuttering is gone: Video stutter 25Hz Videoplayback with Hardwaredecoding Libreelec 9.0


    And it is not a Kodi issue, it is a Kernel issure afaik. And to be honest i would not switch to Kodi 19, its okay for testing but far away from a "daily driver" system.


    Already applied that. GPU frequency is 750 MHz during playback (just checked again to make sure) but 25fps videos are still stuttering very much...

  • I joined to also post that none of these fixes worked on braswell

    have rolled back to 8.2.5

    No Problem Here ASRock n3700m with 9.23 ,build it for a friend years ago as AIO HTPC with dual TV Tuners 240 SSD and 4TB HD. First with a nv gt730 since KODi 18 with onboard GPU.

    Only two Things...

    1. i had to use DVI to HDMI cable instead of the HDMI port to get the Audio working.


    2. The onboard GPU Had Problems with mcdi and Lanczos3.


    But yes Video was somewhat smoother in 8.25 and didn't stutter running in Background while browsing in the library.


    Regards

    Nicolas

  • I managed to get an old Dell 9020m with an i5-4590T and HD Graphics 4600. I need to use an DP -> HDMI adapter but I will give it another try with the latest LE. I pretty much gave up on this issue with my NUC. As mentioned before everything is running fine on Kodi 17.6 / LE 8.2.5, totally smooth.

  • daghy


    Did you try a fresh/clean Install?

    Maybe you have some "leftovers" in your old Setup/Backup/restore... Had this on 2 installations from 8 to 9...


    Is only 25hz playback the Problem?


    Is the system Volume okay?

    A faulty USB Stick or SD Card can cause Strange behavior.


    Regards

    Nicolas

  • Yes, I did several fresh installs on SD Card, USB sticks and internal SSD. There are no leftovers whatsoever. I still believe there are issues with the specific NUC hardware and the kernel.

  • I created 4 partition sets for 4 LibreELEC testing environments. That should be enough for now... :cool:


    With the latest Milhouse build, all things seem a bit more fluent on my Intel box.

    I haven't viewed any true 25fps videos, but that will be the next step.

  • I think there are just not enough NUC users at all to make this issue relevant.


    maybe you try another TvHeadend - if you are using TvH at all and see your bug only on TV material.


    see:

    Kodi crashes watching Sat-TV · Issue #17531 · xbmc/xbmc · GitHub

    and there comment from 20 Jun..


    I currently don't know if I got this bugs on 25fps material or on all.

    - btw: reporter sixpack58 is me (too) -


    I've tried all workaround mentioned here and elsewhere, but with no effort.


    Only TvH 4.3 fixed it. Seems curious, but artefacts are mostly and crashes are completely gone.


    - I hope we get an more current kernel with the next LE release, cause there went a lot of fixes for i915 in -


    see: drm-intel - Linux driver for Intel graphics


    P.S.

    I didn't read the complete thread, but 2 questions:

    Do you see stuttering with movies from TV (SAT, ...) only or from local movies or both.


    Why do I ask ?

    I saw artefacts only on TV material (SAT-TV), not on local movies.

    what indicates to me that the GPU (HW and all the involved software) isn't the culprit (alone).


    What's also curious:

    the boxed needed to play constant ~20 minutes to show the first artefacts and then the subsequent crash...


    Do you see such an behavior too ?

    DigiBit R1, NUC8i3BE

    Edited 4 times, last by JoeAverage ().