Video stutter 25Hz Videoplayback with Hardwaredecoding Libreelec 9.0

  • Yes, everything is removed from the Whitelist. When I enable the video's native resolution in the Whitelist (720x480p) the problem goes away and video is smooth, but then I don't get any upscaling. Like I said, I've tried practically every combination of video and display settings in Kodi, but nothing works. It's obviously something that's gotten broken or changed in Leia

    GUI refresh rate is 60

  • Well, I guess we can conclude you have another issue!

    I had the same behaviour pretty much, (basically that 24p was ok, everything else stuttery) - but in my case the GPU thing solved it completely. The trick with that it to test the is actually scaling up to 750 during the playback (to make sure the fix is actually kicking in), but I presume you did that. Sorry I couldn't help fix it for you!

  • So, I decided to play around with settings a bit more. It turns out that the problem was in the individual media video settings. The problem setting was the Video Scaling Method. It was set at "Spline36," and when I changed it to auto, everything went back to smooth, smooth, smooth. Problem solved with a simple fix.

  • Thanks for sharing. Recently bought a Gemini Lake ITX board so this is helpful.

  • Ok, more experimenting...and I think I have beaten it (or more to the point Ross Nicholson has it cracked, here: 111032 – Need to set gt_min_freq_mhz to max value to avoid sync issues on Gemini Lake N5000/J5005)

    It seems this is (still) the problem. The GPU clock speed is not scaling up as it should under load.

    With a NUC 2820, I added this `` script:


    Just registered to say thanks for this fix! Finally got my 25fps video's running smooth on the Intel NUC 2820. Seems my tv doesn't support 25fps but it does support 50 so LibreElec picks 50 for 25fps material.

  • This fixed it for my NUC. My TV refresh rate displays 25fps now and not 50fps for 25fps media and the stutter has gone

  • Just want to say that the problem seem to exist till today. I also was searching for months for the solution of the 25FPS stutter problem, played around with each and every Kodi Setting. In another Kodi based Forum this thread was mentioned and brought me to the solution/workaround.

    Are there any plans when this will be fixed? I could imagine as this is such a general problem many users are affected by it.

  • I also want to say that the problem exists to this day. I am using a NUC6CAYH with the newest LE version. I tried everything from whitelisting to the trick but nothing helps. I just try to avoid 25fps content because it is unwatchable. A couple of weeks ago I installed an old LE version with Kodi 17.6. It has absolutely no problems at all playing 25fps content stutter free which blows my mind...

    I think there are just not enough NUC users at all to make this issue relevant.

  • Hello daghy

    Could it be your 25fps content ist interlaced?

    Do you have Set a deinterlacer?

    Also Viewing 25hz at 60hz Resolution will stutter.

    I use VAAPI MCDI (MotionCompensation)

    As HQ scaler for SD Lanczos3

    As non HQ scaler next neighbor

    HD 500+ GPU is also able to do Lanczos3 in HD.

    And Set KODi refresh rate to 50hz for Europe or 60hz for US. It should Work.

    No more troubles since this hint!

    Running multiple n37xx j34xx j/n4xxx and 5xxx Mainboards and NUCs.



  • Thank you for all your help.

    Klojum As far as I know only Intel NUCs are suffering from this issue. And yea, it's kinda like "What has been seen cannot be unseen". Especially when I install Kodi 17.6 and run a 25fps video it's so smooth without tinkering around with all these different settings...It's so strange to me.

    Nicolas These are my settings as well, right on the spot. :)

    smp Milhouse is on Kodi 19 as far as I know but it's worth the shot I believe. Would there be any issues with older (official) addons from the Kodi repository?