Video stutter 25Hz Videoplayback with Hardwaredecoding Libreelec 9.0

  • druu

    Are you sure, the stutter is gone? If I add 1920x1080@25Hz to the whitelist, 25fps videos do not stutter all the time anymore, but still stutter from time to time (like 50fps videos with 1920x1080@50Hz).

    So, this does not solve the problem for me. There is something wrong since LE 9/Kodi 18 that needs to be fixed. But it looks as if nobody is able to fix this, so I will go back to LE 8 soon :(

  • druu

    that didn't change anything for me and we have the same machine.

    What whitelist entries do you have? I don't have an entry for 25Hz or 30Hz.

    You are not using an interlaced mode?


    how did you add 25Hz to the whitelist?

  • I checked the workaround from druu on asrock socket 1150 motherboard (igp onboard is used) and the stutter is still their, nothing changed.

    My tv doesn't have 25hz modes so can't test that.

    I'm wondering if it is related to the used codec rather than framerate?

    I have a mkv made from a pal dvd and converted it to h264. If i play that file, to my eyes, there is no stutter while the video is still 25hz?

    If i play a mkv made from a pal dvd as is (mpeg2 25hz), it stutters randomly

    Can anyone test/confirm that?

  • evil77

    I have 25Hz in the list of entries to choose from. I think it depends on the hardware (display) which modes are available for the whitelist. Maybe your TV doesn't support 25Hz and 30Hz.


    I have the stuttering with h264 and h265 videos. I have not yet tried mpeg2 videos. But I don't have any problems with live TV (via tvheadend), and as HD channels are h264 encoded, I don't think it is related to the video codec.

  • I just watched a 50fps video, and it has micro stutter, not nearly es bad es with 25fps videos, but it is there.

    So i does not have anything to do with frame doubling.

    I'm going to install liebreelec 8.2 / Kodi 17.6

  • Hi there! I have the same problem here. I think I was the only one, but it looks a bug from kodi leia. I found that if I change the resolution to the same resolution as the video file the playback is fine. For example, if you are playing a video in 720*338 (or something like that) you can try to configure a 720*480 output.

    But what a mess changing resolution everytime I play a video! so i downgraded to kodi krypton. Everything works fine there.

    I'll pay attention to this thread so can update to Leia soon!

  • I'm assuming it is not a Kodi-problem, i think it is a problem with the libreelec-part (linux).

    Maybe some driver changed or is broken for our platform.

    Somewhere after Kodi is finished, and bevor the picture get's to the screen, the timing for the frames is messed up...

  • hey, just registered here to say I think I have the same issue reported here.

    im totally new to libreelec,

    I have an intel NUC which has been running open elec 8.x for years, has been really stable and no issues with performance however having seen its no longer updated and has potential security issues I thought it best to update and found libreelec..

    so first i tried the upgrade but found performance issues as soon as im playing videos, its like a pc with the wrong graphics driver installed, stuttery and slightly slow...

    so i wiped the nuc and did a fresh install with the latest libreelec, but once again, really stuttery and not enjoyable video playback, im probably going to look at going back to an older build until this is fixed, but just thought id add a +1 to this post and would love to see if there is any solution.

  • I have NUC and have the exact same issue. I tried some of the fixes mentioned earlier in this thread and it seemed to have worked on original video I was doing tests on. Tried a few other video files and noticed that it is still a bit hot and miss. Reverted back to 8.2.5 using LE backup and no stutter. Even in shots where there is a huge pan. That's usually when you notice clear stutter. No stutter in 8.2.5 with panning shots that I can notice.

    Probably just one of those things that gets ironed out with later releases.

  • Just a further report of 'me too'.

    No changes to settings solve it (I have spent hours trying every possible combination and have 10 years of quite in depth Kodi & home theatre I'm pretty sure on this)..issue is present to a lesser or greater degree with all 25/50 materials, regardless of codec (h264 of mpeg2 etc)

    Motion is smooth if one uses the whitelist and plays at e.g. 720 by 480 rather than letting Kodi upscale...but then the Kodi interface is awful, so that's not a proper solution.

    I have some vague hope this might have something to do with it - has anyone tried a libreelec 9 with this incoprorated?

  • Kodi 18.2 was released on Monday and they have fixed the microstutter problem on Intel platforms with interlaced content.. Specifically they call out "VAAPI on Intel has gained some corrections for interlaced content that toggled interlaced flags during playback, and therefore caused stutter by reconfiguring the decoder." I am looking forward to the next release of LibreElec with this fix.

  • Because it still stutters with LE 9.0.2 I did some more tests:

    1) I wrote the LE 9.0.2 image (Generic x86) to a USB stick and booted from it, entering "live" at the boot prompt. I did not change any settings, except the display frame rate (changed to 50 Hz). So I had a clean system where no addons or wrong settings could cause any problems. I started playback of the 25fps and 50fps test videos (mentioned earlier in this thread) and both stuttered.

    2) I did the same as before but with the LE 8.2.5 image. Result: No stuttering.

    3) I created a Linux live USB stick (openSUSE Leap 15.0 KDE), installed Kodi (18.2), started Kodi (in fullscreen mode), changed the display frame rate to 50 Hz and started playback of the two test videos. Result: No stuttering!

    So, because there is no stuttering with Kodi 18.2 and openSUSE, it looks like the problem is somewhere in LibreELEC.

  • Arrived here after finding my 50fps content skipping with a fresh install of Libreelec 9.0.2

    Common denominators with some other folks is that I'm also using an Intel NUC (NUC7i3BNK).

    I had previously had skipping in Ubuntu 18.02 with Kodi so I'm now beginning to wonder if it's somehow intel driver related.