Early community images for H3, H6 and A64

  • i might just go with opipc internal ir, i think it can put on work, but it involves getting whole distribution recompiled to get proper libs installed..

    Why do you think so? I tested IR few days back and button presses were recognized correctly.

  • oh okey :) i dident tested it because i know i can have it work one way another :D

    So any ideas about EDID thing? it is biggest issue now.

  • No, not really. Which board you said you have? I just tested my OrangePi Plus2e on Panasonic plasma TV (1080p) and it works as expected.

  • I didn't dive into kernel config yet. If there is some USB driver which you would like to be enabled, just say so (but it must be included in kernel already).

    That is easy, one line fix which will be included in next update, but since I don't have that board, you'll have to confirm if it works.

    I got two DVB-T Sticks and have a DVB-T2/C one on order

    The Modules of the two existing ones are called:



    The link to the corresponding pages of the three sticks are here:




    I hope you don't mind me pasting just like this...

    Testing and confirmation will be done for sure :)

    Quote from jernej

    That's true. Be aware that Allwinner never officially supported HDMI CEC on H3. I noticed that CEC on same kernel worked with one board but not another during tests. Possible explanation could be that because there was no official support for it, HW designers couldn't test it and it may not work. Even worse, CEC pin could be unconnected or connected to GPIO for software simulation of CEC protocol.

    Looking at build/beelinkx2.fex at master · armbian/build · GitHub I would say that board has CEC pin connected to GPIO port. Bad news is that CEC won't work for you for now. Good news is that kernel contains code for simulating CEC over GPIO, but I have no idea how to use that in universal way (not to break other images).

    Hmm strange decision for a TV-Box SOC...

    would be great if that could maybe be made dependant of the DTB or similar weather its HW or GPIO.

    I doubt the H3 gives any chance to hack on the HW to a normally equipped hobbyist, without BGA rework station and esoteric skills ;-)

    Quote from jernej

    Take a look at this tutorial: Infrared Remotes [LibreELEC.wiki]

    That I will do straight away... lets see if i can get the remote going till maybe once in the future the CEC will come alive...

    Thanks again for this wonderful LE Image and the great support, really appreciating it

  • I guess I'm just too simple for this remote control stuff...

    I dug out an Asus PC-39, which is RC5 and compatible with the sunxi receiver and part of the standard remotes...

    no luck, well not completely, see what happens:

    1. LibreELEC:~ # ir-keytable -c -w /usr/lib/udev/rc_keymaps/asus_pc39
    2. Read asus_pc39 table
    3. Old keytable cleared
    4. Wrote 39 keycode(s) to driver
    5. Protocols changed to rc-5

    when I'm pressing a button nothing seems to happen on the big screen, but at least the button presses seem to arrive properly:

    I guess I should call it a day and try again tomorrow, or maybe im firing up the raspi with some suitable RX, lets see...

    OK giving up for today, found a second rc_maps.cfg in /etc , didn't manage making this editable, but keeping it another task for tomorrow, trying to add this line to the end:

    1. sunxi-ir * asus_pc39

    neither irw nor LibreELEC:~ # irw /run/lirc/lircd produce any output, strange...

    Edited 2 times, last by lumpi: added another paragraph at the end :) ().

  • Hi all,

    i have orangepi lite and i'm using image from first post. i'm struggling to make ir to work, but for now i have an annoying problem which needs to be solvedfirst , some configs are not saved at reboot especially the manual ip address.

    i tried both from kodi settings, in connection and from the command line with ssh but still no success. i'm i missing something?

  • Jernej said, that his build is oversized for 512 MB boards. You need more RAM.

    Checking utilisations statistics shows that Jernej image has a very small footprint, only 1/2 ram is used and cpu is running at 10-20% and coldest that when used with other distros.

    i don't think that saving static ip config is related to ram. probably a bug?

  • lumpi you can store custom maps and configs in /storage/.config folder, here is a guide for Amlogic devices, but it is similar for Allwinner:

    LE9.0 remote configs ir-keytable Amlogic devices

    I make my remote works with Kodi by disabling eventlircd as well:

    1. : > /storage/.config/udev.rules.d/98-eventlircd.rules

    Taken from here:

    LE9.0 remote configs ir-keytable Amlogic devices

  • jernej is there any way i can help you on this, what logfiles need etc, how i debug it?

    on older release(kodi16) it works, so there is something about this now.

    tried xrandr but well realize it works on top of framebuffer instead xorg.?. not sure about this.. things are changing on linux world fast i cant keep up lol..

    Also tried couple boot options but it seems they have no meaning using them at boot prompt. i was looking a way to force resolution and disable edid source used setenv: Display - linux-sunxi.org

    Here is dmesg:
    working resolution:

    failover resolution:

    i remind when it goes "failover" resolution, the cec will not even start to try and audio wont work at all.

  • jernej is there any way i can help you on this, what logfiles need etc, how i debug it?

    on older release(kodi16) it works, so there is something about this now.

    Big difference with old OpenELEC port and this one is kernel. Here is mainline kernel which reads EDID and adjust resolution accordingly. If it can't read it, 1024x768 is used as safe fallback (that is hardcoded in kernel). Old BSP kernel (3.4) didn't use EDID at all, it used predefined resolution from fex file. But that caused more issues than it solved. Not all people have board connected to 1080p display.

    I really don't want to go with old path and predefined resolutions because current solution works 99% of the time. However, I can give you instructions how to tell kernel to use 1080p no matter what EDID indicates.

    BTW, OrangePi PC doesn't have ESD protection on HDMI port. Is there a possibility that electrostatic discharge happened on HDMI connector? I saw destroyed HDMI port on OrangePi Plus that way before.

  • it still works certain tv, i can later try other opi board. but i doubt it is issue.. actually we need more ppl with opi pc to test this out. :D

    if you can yes, i can change kernel if needed but i need the atm using one, and point to some guide how to compile it for libreelec i can try it out and mess with code :D

  • if you can yes, i can change kernel if needed but i need the atm using one, and point to some guide how to compile it for libreelec i can try it out and mess with code

    To force fixed resolution, you just have to edit one text file, nothing more:

    1. Insert your LibreELEC SD card into PC and open FAT32 partition

    2. open extlinux/extlinux.conf file for editing

    3. Append "drm.edid_firmware=edid/1920x1080.bin" to the line which starts with "APPEND"

    4. save the file

  • Code
    1. LABEL LibreELEC
    3. FDT /sun8i-h3-orangepi-pc.dtb
    4. APPEND boot=UUID=2012-1219 disk=UUID=b7a86744-01a7-4821-9069-923159da8c2c quiet console=ttyS0,115200 console=tty1 drm.edid_firmware=edid/1920x1080.bin

    that was easy :). but well it dident worked. same thing, going to fallback reso. it does right away after boot text when logo comes, like before.

  • Ok, that is very strange. Can you burn clean image and do this before first boot? Just to rule out any issues with saved settings.