@balbes150 LE images with Kodi-19 for S9xxx

  • Anyone did manage to get 5.x working with Beelink GT1 Ultimate (S912, 3GB, 1G Lan)? LibreELEC-S912.arm-9.0-devel-20181218091149-83ec702 does work, but 5.x img get stuck on LE boot img. Attached a boot with 2019.05.21. 0526 doesn#t provide that error but still stuck at boot screen.


    I get the same error message: Failed to start Setup User cache dir


    In my case with a H96 Mini (S905W). I'm just trying LibreELEC because CoreELEC support for PS3 gamepads has a bug. It stops working as soon as we boot to Android and go back to CoreELEC.

  • Just completed a fresh SD card install of "LibreELEC-AMLG12.arm-9.1-devel-20190531135031-a41fdf1-box" on X96max (4g/32g) used the x96 dtb that was included in the image. Wired network works fine , as does HDMI sound, and video up to 1080p plays, stock remote works. Observation I have come across is that box will not turn off either with remote or via SSH, it starts to shutdown but returns to "Libreelec" splash screen. Big thanks to all for the work being done to support these new s905x2 devices.

  • Did an update using

    LibreELEC-AMLG12.aarch64-9.1-devel-20190531134548-a41fdf1-box.img.gz


    2g/16G X96 Max 100Mb/s NIC


    The DTB directory was re-named but no replacement directory was written.

    So of course the .dtb file could not be found when it rebooted.


    Having corrected this it booted well.

    Wired NIC connects during boot.

    Sound is working from the Default Analog setting, delivered over HDMI.


    I have problems with live TV, both DVB-T and DVB-S.

    Some DVB-S channels work while others do not.

    None of my DVB-T channels work - I get sound but no video.


    There is no means to install drivers that I have found.


    I hope to not only try a fresh install of this but also a fresh install of the ARM image.


    Great progress being made.


    EDIT:

    Did a fresh install using the ARM image.

    On this fresh install most of the DVB-S channels seem to show the video while all I checked give audio.

    None of the DVB-T channels show video.

    I seems to me this needs relatively little to make it usable for 'ordinary' use.

    Edited 2 times, last by JohnBoyz: extra info ().

  • X96 Max test with new g12 build.


    - Vontar X96 Max

    - S905X2/u211 SOC

    - G12A chipset

    - 10/100mbit NIC

    - No bluetooth module

    - 2gb/16gb version

    - 2,4ghz wifi b/g


    Image: LibreELEC-AMLG12.arm-9.1-devel-20190531135031-a41fdf1-box.img.gz


    DTB: meson-g12a-x96-max-rmii.dtb (the one posted by balbes150 which now resides at the root of the "kernel_5.x" folder of the yandex disk)


    Results:

    Boots just fine

    Ethernet working, gets IP through DHCP

    Stock remote works

    2 channel analog outputs through HDMI, but no multichannel or HDMI option selectable (default X96 Max dtb gives HDMI option, but no LAN)

    No WiFi

    Doesn't wake from power off or suspended mode from remote press


    Great progress so far!

  • I tested the file "LibreELEC-AMLG12.aarch64-9.1-devel-20190531134548-a41fdf1-box.img.gz" with "meson-g12a-x96-max.dtb" on the X96 max (4/32).


    Installation ok

    Sound over HDMI ok, but a bit too quiet

    Network ok, 100 or 1000 i don't know?

    Factory Remote ok

    Files x264 works good, ok

    Files x265 crashes directly, booted new

    Files UHD x264, Runs, then crashes, booted new

    Files UHD x265, crashes directly, booted new

    Sound AC3, DTS ok

    When switching off the X96 restarts and gets stuck at the boot screen.

    Fast forward the file hangs.


    Good work and many thanks!


    br

    CT

    X96 max S905X2 (4/32), X96 S905X (2/16) :)

  • X96 Max test with new g12 build.


    - Vontar X96 Max

    - S905X2/u211 SOC

    - G12A chipset

    - 10/100mbit NIC

    - No bluetooth module

    - 2gb/16gb version

    - 2,4ghz wifi b/g/n


    Image: LibreELEC-AMLG12.arm-9.1-devel-20190601211914-a41fdf1-box.img.gz


    DTB: meson-g12a-x96-max-rmii.dtb (the stock one, already present in the dtb folder)


    Results:

    Boots just fine

    Ethernet working, gets IP through DHCP

    Stock remote works

    HDMI audio output present / working 5.1 through spdif passthrough / No mutichannel PCM

    No WiFi

    Doesn't wake from power off or suspended mode from remote press


    Keep knockin' 'em down!

    Edited once, last by TheNoor: I was mistaken about HDMI multichannel output ().

  • X96 Max

    2G/16G

    100Mb/s NIC


    Fresh install of

    LibreELEC-AMLG12.aarch64-9.1-devel-20190601212344-a41fdf1-box.img.gz

    The dtb directory had the required .dtb file included (rmii)


    Notable difference when running is the extra Audio option to use HDMI audio.

    The volume level is low requiring the amplification in the audio set up to be set to +10 or greater.


    DVB-S continues to work and DVB-T gives no video, as previous image, with the strange exception of one channel which is provided by a HDMI>DVB-T converter.


    It is great to see progress being made.

    Thanks for the effort being put into this.

  • X96 max (4/32) S905X2


    Testfile "LibreELEC-AMLG12.aarch64-9.1-devel-20190601212344-a41fdf1-box.img.gz" with "meson-g12a-x96-max.dtb"


    Installation ok

    Sound over HDMI ok, I think it's louder.

    Network ok, 100 or 1000 i don't know?

    Factory Remote ok

    Files x264 works good, ok

    Files UHD x264 works good, ok

    Files x265 crashes directly, booted new

    Files UHD x265, crashes directly, booted new

    Sound AC3, DTS ok

    Fast forward ok

    When I turn off the x96, it goes off, but not remotely.


    Great work being done here!


    br

    CT

    X96 max S905X2 (4/32), X96 S905X (2/16) :)

  • you got AC3 and DTS, did they work for surround audio? Or did it still only give 2.0 channel?


    *Update*

    Answered my own question. Tested LibreELEC-AMLG12.aarch64-9.1-devel-20190601212344-a41fdf1-box.img with meson-g12a-x96-max.dtb on T95Q S905x2 I get 5.1 audio passthrough For AC3 and DTS. However, after ~45 seconds of playing the audio just goes to static. Also, wifi and ethernet work.


    dtb tests:

    u200 no boot

    sei510 boots - Audio ouput "Default Bluetooth Audio (PULSEAUDIO) - no audio

    x96-max-rmii boots - Audio working - no ethernet

    khadas-vim3 boots - Audio working no 5.1 channel out and goes to static after ~45 seconds - ethernet working

    odroid-n2 boots - Audio working WITH 5.1 channel out and goes to static after ~45 seconds - ethernet working

    Edited 2 times, last by stranula ().

  • LibreELEC-AMLGX.arm-9.1-devel-20190530122156-a41fdf1-box.img

    meson-gxbb-wetek-play2.dtb

    WP2 install ok

    remote ok

    WP2 wifi 2.4 - 5 ghz and lan ok

    vp9 1920x1080p video play ok

    Tvh and Pvr ok

    Tuner ok

    Channel scan no

    Live Tv no

    audio 44100 fsb no

    audio 48000 fsb ok

    Live Tv recording TRT 4K-TRT 4K2019-06-0222-53.ts no video play

    Edited once, last by crazyturk ().

  • /storage$ dmesg | grep dvb

    [ 10.170534] dvb_meson c1108c40.dvb: Found i2c-0 adapter: Meson I2C adapter

    [ 10.170544] dvb_meson c1108c40.dvb: ts0: parallel

    [ 10.170715] dvb_meson c1108c40.dvb: ts0_control: 0x0

    [ 10.170870] dvb_meson c1108c40.dvb: dev_name=wetek-dvb

    [ 11.411241] dvb_meson c1108c40.dvb: DVB demod detection for i2c-0 (Meson I2C adapter)...

    [ 12.637920] dvb_meson c1108c40.dvb: Checking for AVL6211 DVB-S/S2 demod ...

    [ 12.638316] dvb_meson c1108c40.dvb: Total DVB modules found: 0

    [ 12.654721] dvbdev: DVB: registering new adapter (dvb_meson)

    [ 12.658149] dvb_meson c1108c40.dvb: DVB: registering adapter 0 frontend 0 (Availink AVL6211+AV2011 DVB-S/S2)...

    [ 43.394808] i2c i2c-0: Direct firmware load for dvb-fe-avl6211.fw failed with error -2

    [ 43.394862] dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval: tuner: 0...0, frontend: 950000000...2150000000

    [ 43.394871] dvb_meson c1108c40.dvb: DVB: adapter 0 frontend 0 frequency 0 out of range (950000..2150000)

    [ 43.394880] dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval: tuner: 0...0, frontend: 950000000...2150000000

    [ 43.511791] i2c i2c-0: Direct firmware load for dvb-fe-avl6211.fw failed with error -2


    modprobe

    /storage$ modprobe wetekdvb

    /storage$ dmesg | grep dvb

    [ 10.170534] dvb_meson c1108c40.dvb: Found i2c-0 adapter: Meson I2C adapter

    [ 10.170544] dvb_meson c1108c40.dvb: ts0: parallel

    [ 10.170715] dvb_meson c1108c40.dvb: ts0_control: 0x0

    [ 10.170870] dvb_meson c1108c40.dvb: dev_name=wetek-dvb

    [ 11.411241] dvb_meson c1108c40.dvb: DVB demod detection for i2c-0 (Meson I2C adapter)...

    [ 12.637920] dvb_meson c1108c40.dvb: Checking for AVL6211 DVB-S/S2 demod ...

    [ 12.638316] dvb_meson c1108c40.dvb: Total DVB modules found: 0

    [ 12.654721] dvbdev: DVB: registering new adapter (dvb_meson)

    [ 12.658149] dvb_meson c1108c40.dvb: DVB: registering adapter 0 frontend 0 (Availink AVL6211+AV2011 DVB-S/S2)...

    [ 43.394808] i2c i2c-0: Direct firmware load for dvb-fe-avl6211.fw failed with error -2

    [ 43.394862] dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval: tuner: 0...0, frontend: 950000000...2150000000

    [ 43.394871] dvb_meson c1108c40.dvb: DVB: adapter 0 frontend 0 frequency 0 out of range (950000..2150000)

    [ 43.394880] dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval: tuner: 0...0, frontend: 950000000...2150000000

    [ 43.511791] i2c i2c-0: Direct firmware load for dvb-fe-avl6211.fw failed with error -2

    [ 2343.803806] dvbdev: DVB: registering new adapter (dvb_meson)

    [ 2343.805159] dvb_meson c1108c40.dvb: DVB: registering adapter 1 frontend 0 (Availink AVL6211+AV2011 DVB-S/S2)...

    [ 2344.013048] i2c i2c-0: Direct firmware load for dvb-fe-avl6211.fw failed with error -2

    [ 2344.013099] dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval: tuner: 0...0, frontend: 950000000...2150000000

    [ 2344.013106] dvb_meson c1108c40.dvb: DVB: adapter 1 frontend 0 frequency 0 out of range (950000..2150000)

    [ 2344.013116] dvb_frontend: dvb_frontend_get_frequency_limits: frequency interval: tuner: 0...0, frontend: 950000000...2150000000

    [ 2409.019148] i2c i2c-0: Direct firmware load for dvb-fe-avl6211.fw failed with error -2

    Edited once, last by crazyturk ().

  • N5 MAX S905X2 4/32

    01/06/19 LibreELEC-AMLG12.aarch64-9.1-devel-20190601212344-a41fdf1-box.img

    Allways fresh install with any dtb´s


    DTB: meson-g12a-x96-max.dtb

    Wifi OK, connect, but don´t work, reboot and then OK, work 2.4GHz and 5Ghz

    Wired KO

    Sound OK

    Remote OK

    Bluetooth OK


    DTB: meson-g12a-x96-max-rmii.dtb

    Wifi OK, connect, but don´t work, reboot and then OK, work 2.4GHz and 5Ghz

    Wired KO

    Sound OK

    Remote OK

    Bluetooth OK


    DTB: meson-g12b-odroid-n2.dtb

    Wifi KO

    Wired OK

    Sound OK

    Remote KO

    Bluetooh KO


    DTB: meson-g12a-u200.dtb

    Wifi KO

    Wired KO

    Sound OK

    Remote KO

    Bluetooh KO


    DTB: meson-g12a-sei510.dtb

    Wifi OK, connect, but don´t work, reboot and then OK, work 2.4GHz and 5Ghz

    Wired KO

    Sound KO

    Remote KO

    Bluetooh OK


    DTB: meson-g12b-khadas-vim3.dtb

    Wifi KO

    Wired OK

    Sound OK

    Remote KO

    Bluetooh KO


    PD: Attached photos of the magicsee N5 max motherboard: MEGA


    Ethernet: Pulse H5007NL

    Wifi: Ap6255

  • In other news .. we have multi-channel LPCM working on GX hardware. Amlogic's older audio hardware technically supports only 2.0 and 7.1 (2-ch/8-ch) output so the next step will be to fake other output configurations like 2.1/4.0/5.1. No pass-through yet either, but it's a step in the right direction. I also need to test the same changes on G12 hardware - maybe in the next couple of days if I have time. Once current patches are cleaned up a little they will appear in testing images.

  • Anyone know the git


    PROJECT=Amlogic ARCH=arm DEVICE=AMLG12 UBOOT_SYSTEM=box make image


    what UBOOT_SYSTEM should I use for the x96 MAX box (2g)?

  • balbes150

    The trial versions of the date 20190603

    for S905_S905X_S912

    They do not have arm images, only aarch64./shrug

    It is therefore impossible to test live TV.

    :thumbup: