• Big kudos to olehenrikj !! Tried your Chrome with LE and it works like a charm on my x86 system. You solved a ton of issues for me and Thanks for sharing. I was using Chromium some time ago then an update to LE fouled it up but Chrome works just fine for my needs.

    RD :):)

    You're welcome. I updated the stuff and I will add a new post under this.

  • Chrome version: 60.0.3112.101-1

    - includes Adobe Flash plugin (and of course widevine).

    - regular Chrome binaries, found an easier and better way to disable pulseaudio under LibreElec when Chrome is running (It still doesn't work with for some reason, but normal youtube and other sides work as normal).

    - added a switch in settings for stopping pulseaudio, enabled by default (PA will restart when browser closes).

    I do not guarantee maintaining of the package, but at least it works stable and don't crash the entire browser entering some random flash content.

    Check for updates here:

    Feel free to go through the code, it's mainly a fork from LibreElec but includes libraries needed for Chrome and Chrome itself incl. Adobe Flash plugin. So note that you'll be accepting all licenses and stuff by installing this package automatically. Also you install this on your own risk.

    Edited once, last by lrusak ().

  • The URL doesn't seem to be accepted by the moderators for whatever reason. But the Chromium addon for sure needs more attention and love if it should be usable.

    You can follow the url from the previous post though, you'll find it there (if this post stays)

  • will give this a try tonight, because chromium crashes every time on amazon prime with a snap error message.

    Lets see how chrome behaves

  • Anyone having issues with Chromium on LibreELEC 8.1.2?

    Min keeps chrashing over and over again - And with the 8.1.2 update Netflix = dead!

    It seems that widevine is no longer installed!?


  • Anyone compiled this for ArmHF / Arm64?

    Its hard to find a sub $30 SoC that isn't capable of running chromium just like the specs of old X86 running LibreElec.
    I am actually not bothered about netflix just that occasional need to use a browser in a reverse 20/80 means without libreelec is broken for me and forced to use Android.

    I actually love LibreElec with Chromium find it broken without.
    Are any of the dev's getting onboard with Chromium web browser - EsMaSol

    AlwinEsch (Alwin Esch) · GitHub

    Esch Media Solutions · GitHub

  • Netflix verified working here on x86 with olehenrik version 59 of Chromium found here:


    1) Remove official version 55 of Chromium - It is no longer working!

    2) Install OleHenrik's unofficial version 59 of Chromium

    If the installaiton fails - Please ensure you run the zip from local drive - I had issues installing directly from my NAS.

    Somebody please officially fix Chromium in LibreELEC 8!.


  • Hi olehenrikj

    Thanks for your Addon.

    I have moved yesterday from Ubuntu16 with Kodi to LE9 and used your chrome Version, but I dont get any sound

    For Kodi i use a USB DAC. I noticed i cant specify in chrome a sound source (freetext), in which annotation is this used?

    Something like hw:0,1 ?

  • Hello.

    Is it possible to make a resolution of 4k larger font. When I type Google it's from the subway I see what I write but with 3 meters nothing can be seen. I do not mean font in chrome, only about chrome window size.


    Is there any possibility to upload polish language for chromium? Like in the settings I turn on and get the Polish language, but it is still English in the interface.

  • It's the chrome parameter "--alsa-output-device=".

    This can be e.g. the ALSA device alias.

    You can identify your alias with aplay -L

    In my case (Intel NUC, HDMI Output):

    my desired setting must be hdmi:CARD=PCH

    Edited once, last by cabal2k ().

  • The new version 60 of Chrome does not launch at all for me on generic libreelec.

    Version 59 launches and work but often leave me with a blank black screen.

  • That version launches fine but there is no mouse cursor

    Actually the mouse cursor doesn't show on tigervnc, but shows when viewing normally...

    Thanks you, I'll do more testing now.

  • Everything seems to work pretty well minus the audio, I get nothing... I even manually typed the audio device name in the settings. There is only the HDMI audio out, one choice.

    However ultimately I do not need audio for my usage so it doesn't really matter to me. I do notice this version seems way faster.

    Is there any way to have the back button exit the app?