[8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices

  • 10bit RGB does not work in my case - still got the wrong colors.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • I installed this after having issues with LE 7.x and a file with DDP 5.1 (E-AC3) audio (my HDMI receiver is too old to decode it).


    After setting the audio quality to "high" in the settings I was able to play this file with good audio (decoded by my box). Looks good to me!

    Scishion V88 Pro S905X 1G/8G, 100MBit/s LAN w/ LE 9.0 (adamg-1.0.4.1), Onkyo TX-NR609 AV receiver, Mitsubishi HC5500 projector

  • I get lots of stuttering using PVR Simple and Tvheadend with none hls streams.

    Frame drops/skips until buffer fills up to 20% and above.

  • Are you guys running 9.0 Libreelec thru microSD?

    I always have "filesystem corruption" warning after the first reboot...even with the latest release!!!

    I'm going crazy with this...never had a problem with 8.x releases... :-(

  • GDPR-2

    When playing SD content hw accelerated after some random time passed, movie and audio become out of sync. Are you sure you have all kszaq patches merged?

  • hi.adamg.

    when I plug my tbs 5520 se in tvbox,Libreelec recognize it,but there is an error ,here is dmesg

    I copy the file dvb-usb-tbsqbox-id5521.fw to /lib/firmware,Libreelec success load the driver,but once I reboot Libreelec,the firmware is disappear.What should I do?

  • I gave this quick test last night (We have only on TV at home and I can't appropriate it or SWMBO will not be happy.), but this seems to work well. Got Netflix playing 720p only once, but this may be because my internet connection was under heavy use. TVheadend (backend/frontend) with MyGica 230 USB stick was working well.


    I installed Retroarch and emulation station, but I was unable to get them working. This may well be from lack on knowledge/time. I just installed them from the repo and tried to launch them, but they sit on the splash screen for some time and then go back to KODI. I would imagine that there are some log files somewhere, where I can dig this deeper when I have the time.


    For now this seems very promising. I will do further tests when I have more time, hopefully in the end of the week. I will report any issues and successes.

    Big thanks to GDPR-2 , kszaq and anyone else who made this possible.


    Oh! I forgot to mention. I ran this with my "bad patch" Mecool M8S Pro+ from SD-card.

  • this is the only version of retroarch that i found that just works out of the box

    [LibreELEC] Run RetroArch on your S905/S905X device! - FreakTab.com


    if anyone has anything better and maybe how to get reicast and emulationstation on here would be great, basically if anyone can make an rx05re with this leia build

  • I have. No problems.

    Unfortunately I still have filesystem issue. I've tested 9.0 releases in 3 different microSD cards, always on my S905X TX5 PRO and i always got this issue.


    With 8.x releases never had a problem.

  • The last try did the trick: i took an old 2gb microSD and used Rufus to out the latest 9.x release. It worked!


    I Just don't understand why the others 16gb microSD work with 8.x Libreelec while don't with 9.x.

  • Question about netflix on s905.


    I have Gendo 1-10-2017 build, inputstream.adaptive 2.1.4.6 and also have widevine library installed.


    When I play, eg, Star Trek: Discovery, (or in fact anything, but that is my "test") I get awful playback, lagging, video/audio way out of sync, jumpiness, press pause and it continues to play badly for about 30s before it actually pauses.


    "O" tells me it is decoded by inputstream.adaptive.decoder (SW), 4 CPUS are maxed out (although jump about bit). Res is 1920x1080. Bitrate 3700 kb/s (+/-).


    I am wondering why I don't get hardware decoding, which I am guessing is the problem.


    Machine is a mecool pro+


    What am I missing?

  • You're not missing something.

    Kodi is missing the ability to decode Netflix or other encrypted streams using hardware acceleration.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • you are missing the fact you cant play anything above 720p on netflix

    Edited once, last by grimyhr ().

  • On S9xx AMLogic devices with LE and Kodi, to be precise. ;)

    Because, on PC with Win/Lin & Kodi (same inputstream+widevine algorythm and plugins) - Amazon/Netflix 1080p is playing fine, excluding the fact, that some of the content from Amazon cannot start the audio track (either DRM issue, or plugin needs fix)...