Cannot access Libreelec Nuc via Windows 10

  • Updated to 8.1 beta.

    my Nuc machine with libreelec is 192.168.1.12


    in the Windows explorer i was typing \\192.168.1.12 and i was able to access the machine.

    after the update when i try to access it it asks for username and password - even though i have disabled the option to ask for password.

    i tried to set Maximum SMB version to 3, 2, 1 but still cannot access it..


    Any ideas?

    Thank you :)

  • even though i have disabled the option to ask for password

    I'm sure you have heard of the WannaCry problems with computers running Samba worldwide.

    You still think it's a good thing to work without passwords?

  • Well, I'm not a Windows guru, so someone else will have to step in. Using Linux here, and that simply works.

  • Same here...went back to 8.0.2 for now..Cannot access Libreelec from Windows 10 and Windows 10 from Libreelec..

    CEC still broken in 8.1.0..no wakeup from screensaver or on TV turn on..


    Watching...

  • If you're using a customised /storage/.config/samba.conf then you'll need to delete it (using ssh before/after upgrade, or Samba prior to upgrading) and use the new /storage/.config/samba.conf.sample as the basis of your custom samba.conf, then reapplying your custom changes.


    8.2.0 includes Samba 4 which is very different from the Samba 3 in 8.0.2, and any customised samba.conf will not be compatible. Customised configuration files are the responsibility of the user and will not be migrated during the upgrade. Most users should not need a customised samba.conf.


    This is all explained in the blog announcement.

  • and Windows 10 from Libreelec..

    If your using anonymous access (ie. no username/ppasswor and "Everyone" granted access to the Windows share) then this is no longer working as Microsoft have disabled anonymous remote access for SMB shares. You'll now need to create a user with password on the Windows machine, assign the user to the share, then access the share in Kodi via Video > Files which should prompt you for a username/password - enter the username and password of the Windows user, tick the "Remember" box (to save the username/password in passwords.xml) and you should now be able to access the share.

  • If your using anonymous access (ie. no username/ppasswor and "Everyone" granted access to the Windows share) then this is no longer working as Microsoft have disabled anonymous remote access for SMB shares. You'll now need to create a user with password on the Windows machine, assign the user to the share, then access the share in Kodi via Video > Files which should prompt you for a username/password - enter the username and password of the Windows user, tick the "Remember" box (to save the username/password in passwords.xml) and you should now be able to access the share.

    That is exactly what I'm using...so this setting in local policies is no more valid in windows 10 connecting to libreelec "Network access: Let Everyone permissions apply to anonymous users"

    Ok got it...clear enough ...and no I don't use a password to log in my Pc...so adding user and password protect should do the trick and leave main account with no password...


    Now I still don't understand how to access Libreelec from windows 10..

    I do have a customized samba.config..just added few lines to access Storage without having to login Winscp samba.conf.txt

    Do you think that's the culprit?Is the samba.config enabled in 8.1.0 or sample?

    Now I can't look cause I m back on 8.0.2 cause I cant use 8.1 anyway as Cec is still the same for me...but should be trying it soon hopefully someone will compile and share a rpi2 version with working CEC...

  • Quote

    8.2.0 includes Samba 4 which is very different from the Samba 3 in 8.0.2, and ANY customised samba.conf will not be compatible.

  • Just rename samba.conf to samba.disabled before rebooting, then it's easier to compare and make changes to the new samba4 template

  • Just rename samba.conf to samba.disabled before rebooting, then it's easier to compare and make changes to the new samba4 template

    Yeah that works fine without the old samba.conf I can access Libreelec again as usual..


    Now waiting for the long awaited Cec fix


    thanks

  • sorry for my dumb question,

    since i cannot access libreelec from my windows pc how can i delete samba.conf in libre? and where it is located ? thank you :)

  • solamnic : Use ssh to login and rename/delete "/storage/.config/samba.conf". Or downgrade to 8.0.2, rename (or delete) samba.conf via the "Configfiles" Samba share, and then upgrade to 8.1.0.

  • You can delete it from File manager or better off just rename it..It is located in /storage/.config

    You might need to enable show hidden files in Kodi

  • Thank you for the answers , i deleted the samba.conf rebooted an now i was able to access libreelec via pc..

    BUT

    i cannot access addon folder

    i added in samba.conf those lines

    [Addons]

    path = /storage/.kodi/addons

    available = yes

    browsable = yes

    public = yes

    writable = yes

    root preexec = mkdir -p /storage/.kodi/addons


    but every time i reboot, the samba.conf i edited is replaced with one created with libre (not including the addons addition i made)


    Any ideas ??


    Thanks again :)