[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • How do you activate the auto-update feature? I just could not find it.


    Or is that automatically included/activated and has only to do with the dtb file?

  • Hi!

    One question, I would have an idea:

    Noise reduction is enabled in Libreelec. That's a bit worse for picture quality. Would not it be worth disabling it?


    /sys/module/di/parameters/nr2_en


    The current value is 1 (on), 0 is off.


    This function is called a smoke/ghost effect and the android is switched off several times. Image sharper and clearer a bit.

    I also tested and seen the difference sometimes.

    Sorry for my bad English.

  • I've got a new ABOX 1 Max, 2G/16G S905X box. The remote works with Android but not in LE 8.2.1.1. I search the box via winscp and Droidssh, but cannot find a remote.conf but again the remote works in Android. I've searched LE on 3 different boxes 8.2.1.1 vis ssh and find no remote.conf. Kinda frustrated with this. How do I find remote.conf in 8.2.1.1? I can't find an answer using search on the site.

    Snip of search is shown. All I get is shown.

    Appreciate any help.

  • There is a repository of remote.conf files, working in LibreElec. Read this a couple of posts down and try the linked remote.conf. If that doesn't work, look for boxes with the same remote, they are usually interoperable.

  • There is a repository of remote.conf files, working in LibreElec. Read this a couple of posts down and try the linked remote.conf. If that doesn't work, look for boxes with the same remote, they are usually interoperable.

    Thanks for that. I will give it a try. The bigger issue is why the remote works with no remote.conf found on the box.

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • Thanks for that. I will give it a try. The bigger issue is why the remote works with no remote.conf found on the box.

    Maybe your search string should have been remote* or *remote*. On my box the remote.conf is found in /etc, like Tim_Taylor said. But even that is no guarantee that this original android remote.conf will work in LibreElec.

  • Hello kszaq . So I have tried the 4K in 444,10bit mode. It seems to work correctly, but I have found an issue wth 3D movies. If the video output is set to 4k, also the HD movies are played in 4k (upscaled), including the 3D. I am not sure what Libreelec output then but I don't get any image from my projector.

    There is some video info on the HDMI, in fact there is no "No Input" alert which comes when you have a wrong format (or problem with the cable).

    The video format is detected as 4k (3960x2160) 59.94Hz (which is my GUI setting, strange for a video playback) but the screen is blue, but the blue comes from the projector no video color (in fact it follows the color for the no video background I set), so it is like there is no valid video data but a valid video info. The audio is present also, so the playback is active in Libreelec. And Libreelec is full functional, because I can stop the playback with the remote (knowing the button combination) and I come back to the GUI, correctly displayed, and I can start another playback, of another file, with no issue

    Sorry if I cannot give you more informations, but I can help to provide everything you may require.

    Unfortunately I don't have other 4k Libreelec compatible device, to check if the problem is in Libreelec or the amlogic part

    Bye

  • Menion I suggest switching GUI to 1920x1080, LibreELEC will automatically switch to 4K for 4K clips and should work better with 3D content.

  • Dose it work if you select "Adjust display refresh rate" in Player settings?

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • There is someone of deactivating the hdmi-cec in the uboot? Since I turned on the TV alone, when I turn it off.

    My tv box is H96 Pro+, with the mini mx and mk808b plus, that does not happen to me. So that's why I suppose it's the uboot.

  • 8.2.1.2 available to download. Please once again note that automatic update won't update to 8.2.1.2 due to a bug in previous builds. In 8.2.1.2 the bug is fixed and this it will automatically update to future versions unless you turn the feature off.

  • 8.2.1.2 available to download. Please once again note that automatic update won't update to 8.2.1.2 due to a bug in previous builds. In 8.2.1.2 the bug is fixed and this it will automatically update to future versions unless you turn the feature off.

    Thank you very much for this :thumbup::cool:. As the changelog does not mention it directly: did you keep the patch you had for the dvb01 test build? And also: you re-added a feature to force RGB mode, but the known issues still say that RGB mode does not work ...


    UPDATE: I updated three boxes and the one with the 9082xs Wifi-chip works (tethering). Also, all three boxes allow me to use a Sundtek-stick for DVB-C when I replace the standard TvHeadend-Addon with GDPR-1 's. So, all boxes now on the same page, no more testbuilds - great stuff and enjoy your coffee, kszaq !

    Cheers,


    chessplayer



    Formerly: Intel Atom, Dockstar/Pogoplug (headless PVR Server)

    Production: Wetek Play, RPi3, Cubietruck (headless PVR Server), Nvidia Shield client, XBOX ONE Tuner, Sundtek Media TV Sticks

    Experimental: Various AMLogic S905X (W) devices

    Edited once, last by chessplayer ().

  • Dose it work if you select "Adjust display refresh rate" in Player settings?

    No, "Adjust display refresh rate" is already and always enabled in my boxes.

    For example, my PS4 Pro, upscale to 4k the 2D HD bluray, but it turn to 1080p output for the 3D HD bluray.

    Edited once, last by Menion ().

  • Thanks kszaq , Wi-Fi now works on my S8 mini pro boxes (t95x). I primarily work cabled, but one works on Wi-Fi. This could remove the need for the external adapter. How do I test the RGB mode? Add rgb,8bit to /sys/class/amhdmitx/amhdmitx0/attr?

    If it ain't broken: break it, fix it, repeat

  • As before, put


    Code
    1. echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb


    in the .config/autostart.sh file

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • Thanks. Probably a stupid question on my part, but what should it do? I've got three boxes on three different TV's, but I can't see any difference.


    I was expecting a change like from limited RGB to full RGB , but colors and black levels stay the same.

    If it ain't broken: break it, fix it, repeat