[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • hi kszaq ,


    my device is s905 ..

    i get success with install LibeEelec but i can't find the tuner !!

    my device name is mega plus gold

  • You need to provide details of the tuner device (chipset) in the box, not the make/model name of the box.

  • I have 2 4k hdr tv, Samsung KS9000 and LG UH6100.

    Thanks. Perhaps the Samsung behaves differently.

    You LG doesn't have WCG, so it's possible that you don't see a difference whether it's in BT2020 color mode or not. Not sure if it's possible in WebOS 3.0:

    Press up on the remote, select the HDMI input and press OK. For me it shows the resolution, audio output format, and BT2020 when I'm in 10 bit mode.

  • With a 4K TV, I wold recommend setting the Kodi resolution to 2160p and 444 10 bits. ;)

    If I set it to 444,10bit then no picture (or green picture with LE7).

    LG 2017 model 60SJ810V (4k, HDR)

    It was the same with the previous Philips 2014 4k tv.

    If I play a HDR file like this from an USB drive with the tv itself, then it shows BT.2020 and HDR.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • Thanks. Perhaps the Samsung behaves differently.

    You LG doesn't have WCG, so it's possible that you don't see a difference whether it's in BT2020 color mode or not. Not sure if it's possible in WebOS 3.0:

    Press up on the remote, select the HDMI input and press OK. For me it shows the resolution, audio output format, and BT2020 when I'm in 10 bit mode.

    When I press the "Info" button on the remote of my UH6100 it indicate BT.2020 on my HDR content and nothing on my SDR content. So I presume if it is not specified BT.2020, it's BT.709.


    If I put the "echo 444,10bit ..." command in the autostart, 4k SDR and HDR contents is BT.2020. Personnally I don't like BT.2020 colorspace on non BT.2020 contents, color is too saturate... I test it a lot of time.

    Libreelec : Raspberry 4, Orange pi lite2, Orange pi PC(and +), Pine H64, Rock64, RockPro64, soon Orange Pi 3 and PC2

    Divers : NVidia Shield Pro, NVidia Shield Tube, N2 and C4

  • hello i am a new member, reading the forum i installed i thinhk correctly on a 8gb sd this version of librelec LibreELEC-S905.arm-8.2-8.2.1.1.img.gz to my m8s II 2g/16 with s905x amlogic, it boots normal, i can open kodi and play files, but when i press to refresh library in my long library of tv series it works for a little than stops and the library is missing as i have no series,why? every times it saves some one or two or three series than stops,i made some errors? i dont change the tree i used the one insert in the sd.may be it?? sorry for my bad english.thanks alot:-/

  • sorry i forgot a thing , i use nfs shares for my series because the samba shares are not found...is normal or i can see them.??thanks

  • If I set it to 444,10bit then no picture (or green picture with LE7).

    LG 2017 model 60SJ810V (4k, HDR)

    It was the same with the previous Philips 2014 4k tv.

    If I play a HDR file like this from an USB drive with the tv itself, then it shows BT.2020 and HDR.

    Have you tried a better HDMI cable?

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • When I press the "Info" button on the remote of my UH6100 it indicate BT.2020 on my HDR content and nothing on my SDR content. So I presume if it is not specified BT.2020, it's BT.709.


    If I put the "echo 444,10bit ..." command in the autostart, 4k SDR and HDR contents is BT.2020. Personnally I don't like BT.2020 colorspace on non BT.2020 contents, color is too saturate... I test it a lot of time.

    By running Kodi in 2160p and 444 10bit, I have the same picture settings on my TV for HDR and SDR, accept for the color saturation, this is about 10 clicks higher on HDR. And if your TV is adjusted right, you'l see that HDR is overrated;)


    But if i set Kodi to 1080p, there is no way I can get the same picture as with 2160p on 1080p content, But this might have something to do with the way my TV handles UHD and HD.


    And since my TV has different profiles for HDR and SDR, the settings are applied automatic when changing source between HDR and SDR:)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Have you tried a better HDMI cable?

    I've found the source of my problems. It was not the cable but my AVR.

    It can passthrough the 4k HDMI signal, but 10 bit and/or HDR is too much for it (only HDMI 2.0 inputs and output).

    If I directly connect the box to the tv then the tv reports HDR and BT2020 correctly.

    Unfortunately the tv cannot handle HD audio, so I have to think how can I solve this.

    I tried a HDMI splitter but that works with fullhd signal only. :(

    It seems I have to change my AVR.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

    Edited once, last by Pelican ().

  • Is wakeonlan supposed to work in these builds? I have 3 s8 mini pros, but none of them respond to wakeonlan in the Kore app for Android. I had an Intel NUC before this, WOL worked on the generic libreelec I was running on that rig.

    I use WOL on my Windows Server.
    Every time i power on my box "she" wake up my server.
    I use this addon from official kodi repo

    Add-on:Advanced Wake On Lan - Official Kodi Wiki

    - Box Android Mini M8S II (Amlogic S905X, 2GB RAM, 8GB ROM)
    - Ugreen USB Ethernet Adapter Usb 3.0 2.0 [ASIX AX88179 Chipset]
    - LibreELEC 8.2 (Nougat Kernel) builds aimed at devices based on Amlogic S905/S905X SoC.

  • Have you tried ARC? Your TV can send the incommoding audio out through another HDMI port to your AVR.;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • I've got the solution for you :)


    Same problem as you and I bought this splitter that works with 4K HDR content:


    VOXLINK UHD HDMI 2.0 Splitter 1x2 1 Entrée 2 Sortie Répéteur Switch Box Hub 1080 p 4 k x 2 k Pour Blu ray PS3/4 DVD dans Sous-vêtements de Mère Et Enfants sur AliExpress.com | Alibaba Group


    Nicolas

    Panasonic 50DX750F / HK 161 / Beelink MiniMXII S905X

  • Have you tried ARC? Your TV can send the incommoding audio out through another HDMI port to your AVR.;)

    ARC cannot transfer uncompressed audio.

    Thanks. I wonder how it works because they stated as HDMI 2.0 not HDMI 2.0a. But definitely more cheaper than a 4k HDR capable AVR...

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

    Edited 2 times, last by Pelican ().

  • Hello, how to remove green bottom bar on video playback in Kodi? I set sync video playback ON, adjust switch refresh rate auto and it didn't help. After I play that movie, I have information on source HDMI CHANNEL from my TV Samsung ES6800, 1920x1080, 50p whereas libreelec works on 1920x1080 60HZ. When I run other movie, I have information 1920x1080, 24p and in those conditions there is no bottom green bar on the screen. Have you got any ideas to get rid of that fault?

  • Hello, how to remove green bottom bar on video playback in Kodi? I set sync video playback ON, adjust switch refresh rate auto and it didn't help. After I play that movie, I have information on source HDMI CHANNEL from my TV Samsung ES6800, 1920x1080, 50p whereas libreelec works on 1920x1080 60HZ. When I run other movie, I have information 1920x1080, 24p and in those conditions there is no bottom green bar on the screen. Have you got any ideas to get rid of that fault?

    It's your tv's problem. Nothing to do with LE.
    You have to set up your tv for every resolution and fps. Your LE GUI is 1080p60 but if you play a movie it will change the video signal according to the movie's resolution and fps. So start the movie and play with your tv's aspect ratio settings.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu