[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Just joined to post as I am having exactly the same issues and pretty sure same box too. Beelink Mini MXIII II 2GB/16GB rom (Running from SD card though).


    I'm still on 8.0.2e as 8.1.5 just isn't usable over 5Ghz or 2.4Ghz wifi. Getting pretty much the same speeds of around 300KB/s. Ethernet is fine however.


    Edit: just wanted to add thanks for the hard work and effort to bring this to the masses!

    Are you using Realtek DTB on Beelink Mini MXIII II 2GB/16GB ?

    Odroid C2 (LE 8.1.0), Beelink Minix 2G/16G (LE 8.0.2a)

  • I'm confused with the version numbers.


    The last version is 8.1.5 but OS_VERSION and ADDON_VERSION are 8.2


    That's the desired behaviour?


    I have searched in the thread but I haven't find any reference to this values.

  • I'm open for solutions how to make LED, suspend and shutdown work for all boxes.

    No no, the box has allready working lights, i mean kan you make the box real shut down instead of sleepmode.

    As said the shutdown in kodimenu result in a sleep (suspend, whatever) its not really shutting down.


    I found a similar but its a old one OpenELEC Mediacenter - OpenELEC Forum - FEATURE for KODI | CEC command instead poweroff (1/1)

    I would not know where to begin as i am not that technical to code..

    Minix U1 - LE 8.2.2.1

    Yamaha rx677

    Philips 37pfl6606

    Edited once, last by copyer ().


  • As said the shutdown in kodimenu result in a sleep (suspend, whatever) its not really shutting down.

    The shutdown menu is configured in the skin.

    You edit .xml file to change/configure

  • Use a piece of tape... :)

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • No no, the box has allready working lights, i mean kan you make the box real shut down instead of sleepmode.

    As said the shutdown in kodimenu result in a sleep (suspend, whatever) its not really shutting down.

    Actually I think that a selectable sleep mode would be of great interest if it keeps CEC active (you can resume the box from the TV remote) and to improve the turn on time. I am available to test the different power consumption :)

  • Hello;)


    On my KIplus-Box with the newest LibreELEC from kszaq (8.1.5), the context menu has disapieard since two days, now. All attempts to restore it failed. I installed a backup of the "keyboard.xml" in "storage/.kodi/userdata/keymaps" and a backup of the "remote.conf" in "storage/.config".All without any success. The problem always extists, even if I use an Ir-remote or a 2,4 Ghz wireless remote



    The rest of LibreELEC and the remote buttons are working fine on the box and the context menu worked without any problems for serveral month sice the day before yesterday.


    Has anybody an idea, how I can make the context menu working again?


    Thanks in advance!


    Mark

  • Fixed..


    I did once again take a peek in the cec adapter and change some stuf and now the box is behaving like it supose to do..

    So happy camper here..

    Thnx for the help anyway


    Greetings, copyer


    edit.. change: connected hdmi app from tv to avr did the trick..

    Minix U1 - LE 8.2.2.1

    Yamaha rx677

    Philips 37pfl6606

  • No no, the box has allready working lights, i mean kan you make the box real shut down instead of sleepmode.

    As said the shutdown in kodimenu result in a sleep (suspend, whatever) its not really shutting down.


    I found a similar but its a old one OpenELEC Mediacenter - OpenELEC Forum - FEATURE for KODI | CEC command instead poweroff (1/1)

    I would not know where to begin as i am not that technical to code..

    Not true. Choosing "shutdown" in Kodi makes the box shutdown (in kernel) , suspend does not work. Minix has probably some custom code in kernel to extend what you get in Amlogic kernel but we don't have code for this. That's why I said that I'm open for suggestions, i.e. code, not information that it works in closed source Android.

  • Hi Guys,


    I have a Samsung ks8090 and the bqeel m9c max a S905x device with 8.1.5, everything depends on a Yamaha RX-V681. Looking to the TV I use a VU + Solo 2.


    When I look at the Solo 2 TV, all ok! Now I go in the Samsung on the YoutubeApp and start a video, video plays but without sound! Or sometimes starts the video with sound, but if I leave the app again, and wants to look TV over the Solo 2, then I have no sound.


    And now the curious!


    If I remove the HDMI plug from the bqeel, then I have again sound and everything works fine, I can switch between the YoutubeApp and the satellite receiver, or I leave the bqeel on, then works everything well. Only when the bqeel is off, I have the strange behavior with the sound. It all worked fine a while ago. It also plays no role whether I have in the bqeel CEC on or off, but I guess it has something to do with it.


    If I find some time I try to flash older versions, and look at when it came to the error.


    kszaq do you have any idea?


    Sorry for Google translator.

    S905x and S912 Box

  • How to find the error? I use gxbb_p200_2G_1Gbit_OTG_Port.

    decompile dtb to dts format

    #dtc -I dtb -O dts -o gxbb_p200_1G_1Gbit.dts gxbb_p200_1G_1Gbit.bin



    change in dts source the led setting ( in bold )


    sysled {

    compatible = "amlogic, sysled";

    dev_name = "sysled";

    status = "okay";

    led_gpio = <0x76 0xd 0x1>;

    led_active_low = <0x0>;

    };



    recompile dts to dtb

    #dtc -I dts -O dtb -o minimx.dtb gxbb_p200_1G_1Gbit.dts


    update the box with new dtb


    to install dtc on linux search on google

  • And now the curious!


    If I remove the HDMI plug from the bqeel, then I have again sound and everything works fine, I can switch between the YoutubeApp and the satellite receiver, or I leave the bqeel on, then works everything well. Only when the bqeel is off, I have the strange behavior with the sound. It all worked fine a while ago. It also plays no role whether I have in the bqeel CEC on or off, but I guess it has something to do with it.


    If I find some time I try to flash older versions, and look at when it came to the error.


    kszaq do you have any idea?

    Please do not waste your time trying different versions of LibreELEC.


    Box behaviour when it is off has nothing to do with LibreELEC. It is defined in bootloader, i.e. it is dependent on Android you have or had installed in internal memory. I'm not sure whether this has been fixed in Amlogic's 6.0 or 7.1 release. The only device that has this fixed is Odroid-C2 thanks to its open-source bootloader and a fix developed by Kwiboo.


    My suggestion is that you keep your Amlogic box ON, the power consumption is quite low!

  • Hello all,

    I have an MiniMX S905 2GB/16GB ROM. yesterday i updated it from 8.0.2e to 8.1.5 and i have immediately lost the use of Ethernet.

    Now i get an IP address but its not correct and i do not get any internet access.

    however Wifi 2.4 and 5 work perfectly fine.

    Any ideas?


    thanks.