[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Version 8.1.5 is working perfectly on X96 2GB. Now I am going to try installation on internal. I have to find out how SSH works. I will let you know if it all works.


    On SD it works great. The standard remote control is also working great with this version. And shuttdown is working good too. TV is changing mode to earlier HD port. It is even possible to change language to the same language as TV. Great job.

  • I tried to install to internal with SSH. Now X96 works without SDcard.

    But when I try to go back to Android it is not possible anymore. I have used a toothpick for the resetbutton in AV port. X96 Boot logo appears. But TWRP recovery does not start and Internal recovey do not start. It only hangs in Boot logo. I tried via SSH command reboot recovery. Again X96 logo appears but hangs in it. Is there another possibility to install Android again?

  • I tried to install to internal with SSH. Now X96 works without SDcard.

    But when I try to go back to Android it is not possible anymore. I have used a toothpick for the resetbutton in AV port. X96 Boot logo appears. But TWRP recovery does not start and Internal recovey do not start. It only hangs in Boot logo. I tried via SSH command reboot recovery. Again X96 logo appears but hangs in it. Is there another possibility to install Android again?

    when you installed to internal, you overwrote android, you need to get the correct android firmware & install that, possibly using the burning tool.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • Hi Bubblegum57


    I have the firmware as update.zip, With TWRP recovery. But TWRP is not visible. I allso tried to connect with usb to PC with usb burning tool. USB burning tool is not connecting with X96.

  • I tried to install to internal with SSH. Now X96 works without SDcard.

    But when I try to go back to Android it is not possible anymore. I have used a toothpick for the resetbutton in AV port. X96 Boot logo appears. But TWRP recovery does not start and Internal recovey do not start. It only hangs in Boot logo. I tried via SSH command reboot recovery. Again X96 logo appears but hangs in it. Is there another possibility to install Android again?

    Why did you install to internal if you need android?

    You can put back android with USB burning tool and the firmware image for your box.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • Hi Kajoe,


    Do you see a difference in the performance of the box compared to libreelec on the microsd card? I also have this x96 box and I am curious to the difference between the microsd card and internal.

  • I tried to install to internal with SSH. Now X96 works without SDcard.

    But when I try to go back to Android it is not possible anymore. I have used a toothpick for the resetbutton in AV port. X96 Boot logo appears. But TWRP recovery does not start and Internal recovey do not start. It only hangs in Boot logo. I tried via SSH command reboot recovery. Again X96 logo appears but hangs in it. Is there another possibility to install Android again?

    Please read the FAQ, everything is explained there.

  • I have the firmware as update.zip, With TWRP recovery. But TWRP is not visible

    You do not have TWRP recovery (or any for that matter), installed to internal

    You cannot install TWRP if you install to internal.

    Provided that the box is able to boot from SD you can use TWRP by placing the correct TWRP image (renamed to recovery.img) and the native Android dtb image on an SD card and then reboot, using toothpick method or issuing reboot recovery command via SSH.

    Extract dtb.img from the Android update.zip and do the above. The above information was given just a few pages back :rolleyes:

  • Hi zmokkie


    I see now difference. It is just as fast as on SDcard. So I think SDcard installation works perfect on X96. And when you want to use Android again, you only have to use boot from android in power menu. I would not advice to install to internal, because it is not faster.


    So I have tried it, but now it is not possible anymore to recover to Android again. Not with TWRP and not with USB burning tool. I only stuck in X96 bootlogo when entering reset button. And when usb image is not visible anymore, it is not possible to write the factory image back.

  • It's been reported that it does not work. Try this: echo "rgb,8bit" > /sys/class/amhdmitx/amhdmitx0/attr

    Sadly this doesn't work for me in 8.1.5

    I verified that the values are written to the file through autostart.sh.

  • Hi Kajoe,


    Do you see a difference in the performance of the box compared to libreelec on the microsd card? I also have this x96 box and I am curious to the difference between the microsd card and internal.

    Please read this post (again, a couple of pages back) :S

  • Hi Poida;


    That did it.

    I had put following parts to SDcard

    update.zip

    (TWRP) recovery.img

    (extracted official)dtb.img


    Now it is possible to enter recovery menu again. Thank you very much for advice.

  • Now it is possible to enter recovery menu again.

    If you replace the Android OS and run LE from SD / USB then you can replace your stock recovery with TWRP :thumbup:

  • Hi Poida. Yes I know. It worked. Thanks mate. You have given me the solution. Fantastic. Now everything is working. Libreelec is working perfectly on X96. I did not had any issues.

  • Hello


    I upgrade LE 8.1.3 to 8.1.5. I tired Passengers.2016.1080p.3D.BluRay.Half-OU.x264.MKV film, but NO SIGNAL. (8.1.3 never tired 3d films.)

    I read topic, and in the first post changelog 8.1.5 Kodi: fix "no signal" during 3D autoswtich. What can I do? I try older builds?

  • please check if your update to 8.1.5 was really successful.

    Check Options/Systeminfo, do the update again, check logs.

    3D-switching works on my side with Odroid-C2 and Beelink MiniMXIII II.



    Box: Beelink Mini MXIII II (S905X/2GB/32GB SD)

    running: LE 8.2.3.1 (thanks kszaq ) and CE 8.90.0 (thanks adamg + afl1 )