[] LibreELEC 8.2 for S905/S905X

  • How I would know it about a desktop computer concerned to reach the storage apart from a portfolio usr/config portfolio.

    rootolni the libreleec is needed system?

  • Ooops, sorry for any offense, google said it was Hungarian.

    Out of interest, what language is it?

    No problem, there are Hungarian words but it looks like a Google translated text, not a real one.

    my problem it tv remote config code edenwood ED4900UHD

    távirányító ir kód kellene ami a ki-be kapcsolást csinálja. Azt szeretném az x96 s905x config ba beleírtni,hogy a tv távirányítóval tudjam egyszerre ki-be kapcsolni a tv és boxot egyszerre.

    Sorry for the OFF.

    Van magyar fórum, légyszíves ott kérdezz, ez angol nyelvű fórum.

    Amlogic S905, S912 processzoros készülékek - PROHARDVER! Hozzászólások

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V

  • I am on Libreelec, update is set to auto, notification is enabled, but I don't get any popup or whatever of the availability of

    This on 4 different A95X box, all of them upgraded through several version, but all got DTB updated on 28/10.

  • OK took me an hour to install on 905X box because I missed this instruction.. hiding in plain sight!:

    "You can leave a tree that is already present on SD card (fresh install only)"

    Yes, I had been needlessly replacing that file ... wasn't until I used the default one that is flashed with the image in Rufus that it cured the "hang at boot".

    Edited 6 times, last by RowanDDR ().

  • sorry chorme browse its automatic hungary...

    remote control ir a code would be needed that the ki-be connection do it. I would like it it x96 s905x config ba beleírtni,that the TV let me know it to one with remote control ki-be to get it the TV and boxot simultaneously.

  • kszaq Will whatever changes you made in the test build you made for me make their way into your mainstream builds, or is my box a one off?

    I will include the change in I'll also upload it tonight to my GitHub so that GDPR-2 can include the change in his Leia builds.

  • Auto update is working since

    Providing you have disabled intro video or you will not get the update notification unless you go to LE configuration and click on the auto-update setting which will then force a re-check for updates (sort of manual auto-update) :/

  • Hi.

    I'am a happy MXQ 805 LE user, however some file playback was stuttering and had a CPU usage of 100%.

    So I upgraded to a new box: M8S PRO+-userdebug 7.1.1 NHG47L 20170919.150557.V0619

    As this thing did not have a reset button I did:

    - Download lates build kszaq and installed to SD

    - Downloaded the tree file for my 2GB/16GB box and added that to the SD card.

    - Booted the system

    - Installed a terminal emulator Application

    - Issued the following commands

    $ su

    $ reboot update

    - The device rebooted directly into LibreElec ;-)
    - Installed plugin BACKUP to restore all settings from my 805 box including the advancedsettings.xml.

    Now If I playback a Movie or TV Series for some reason it takes almost 2 minutes to start. When it starts it playsback very nice..:

    Logfile: Mecool.zip

    Other movies or series play directly.(have to check if they use a different codec or so).

    I don't have this issue with the MXW 805 box.

    As I am struggeling for several hours now and don't see the issue on the forum. I don't know what to do :P.

    15:20 update: I've hadded 2 sources: 1 DS_SAMBA and 1 DS_NFS. It seems LE is struggeling with producing the network list of my NFS servers (i've multiple). After a long wait

    15:15:32.662 T:3437310880 ERROR: Unable to lookup host: ''

    15:19:20.246 T:3471831968 ERROR: Previous line repeats 1 times.

    Both servers show up and I am able to complete the source information. Now if i browse to the movie (via files). It plays directly. Both SAMBA and NFS. However if I try access via library I have the described 2 minute wait for most movies.


    • Mecool.zip

      (53.21 kB, downloaded 145 times, last: )

    Edited 2 times, last by sincze: additional information added ().

  • Providing you have disabled intro video or you will not get the update notification unless you go to LE configuration and click on the auto-update setting which will then force a re-check for updates (sort of manual auto-update) :/

    What is "intro video"? On my 4 systems, autoupdate does not work. Nothing happens at the startup, but if go in Libreelec settings, and I check for update, I get the notification popup, but again, no update start or even asked for start :/

  • Hi! I have "Ki Pro". On the SD card libreelec, and in the internal memory Android 7.1. How to make BOOT MENU

    1. Libreelec

    2. Android

    method System.ExecWait("/usr/sbin/rebootfromnand") does not work correctly

    Edited once, last by viteq ().

  • What is "intro video"?

    You would be aware of a start-up intro video playing at Kodi start-up if it were enabled, so I'd presume that's not your problem.

    . . . if go in Libreelec settings, and I check for update, I get the notification popup . . .

    When automatic updates in LE settings is set to auto, there is no option to check for updates available.

    Are you sure yours is not set to manual ?

    It seems that more work is needed for auto-update to function for all users

  • Providing you have disabled intro video

    I think this may be skin related. I've had no issues with Updates but don't use intro videos.

    I have had some issues with App TV skin not correctly activating Enable/Disable addon updates.

    I have to use Estuary to disable Auto Updates for individual addons.

    Also Buffering wheel never appears unless i pause stream. It appears momentarily and disappears.

    There's been a lot of changes in how skins work in Krypton and maybe the skin is the cause of notifications not appearing.

    Why the update doesn't automatically happen for you is maybe the INTRO VIDEO is interrupting communication to the LE Server.

    Maybe try APP/TV skin from Kodi Repo and use your intro video with that skin and see what happens.

    I know it has that feature. I've never used it. Cheers.:)

  • I think this may be skin related.

    It isn't skin related it is intro video related.

    If I disable the intro video the update works fine with the same skin.

    The reason you have had no issues is because you do not use the intro video.

    Without changing skin, if I prevent the network from connecting until after the intro video has completed, the auto update works as expected.


    Again, without changing skin, if I go to LE settings and click on the auto setting this starts the update check again and the update works.

    So nothing to do with the skin, most probably to do with the fact that the update check is timing out while the intro is playing.

    Since we can't alter when the start-up video plays (it'd be a bit pointless playing any later than at start-up), the next simplest thing to do would be delay the update check but, as has already been mentioned that's a bit above my station and not on the list of priorities for kszaq.

    I had a similar situation years ago with an original G-Box that didn't have a 'wait for network' option and always missed the time update. Not being a dev myself, it took me weeks of trial and error to come up with a start-up script that waited a few seconds to take eth0 down and up again but, sadly I deleted that years back.

    I'll keep slugging away at it but if anyone can save my pain, I'd appreciate it. In the meantime, it's quicker for me to update the four boxes I have manually from one download than it is to wait for the auto-update to kick in so no real loss, it would just be nice to see the notification of a new update


    It makes no difference which skin is bein used, same result.

    Intro enabled = no notification / update OR Intro disabled = notification / update works

    Edited once, last by Poida ().

  • Hi!

    I have a little problem with installtointernal script.

    My X96 and X96 mini box original android system partition is 1,5 and 2GB, before I run the script i backup all android partition (dtb, boot, recovery, system) with dd command.

    Install to internal script must twice run, because after first run, starting LE from SD card, the system and partition can not be mounted and LE is not starting from NAND.

    After second installtointernal script the partitions resized and LE run from NAND perfect.

    My question is can i my backup restore to nand with dd command?

  • build is now available to download. Due to updated WiFi drivers - unlikely possibility of network loss - automatic update is now active only for C2 and LePotato builds as these boards don't have built-in WiFi.

    If no new WiFi issues are reported, I will enable automatic update for all boxes on Monday.

    Let us all test the drivers, auto-update enabled. I haven't faced any issues on all my S905(X) devices.

  • what is build name for x96 mini S905W and also link the device tree for S905W? Advance thanks