Posts by sincze

    Hi.


    I'am a happy MXQ 805 LE user, however some file playback was stuttering and had a CPU usage of 100%.


    So I upgraded to a new box: M8S PRO+-userdebug 7.1.1 NHG47L 20170919.150557.V0619


    As this thing did not have a reset button I did:

    - Download lates build kszaq 8.2.2.2 and installed to SD

    - Downloaded the tree file for my 2GB/16GB box and added that to the SD card.

    - Booted the system

    - Installed a terminal emulator Application

    - Issued the following commands

    $ su

    $ reboot update

    - The device rebooted directly into LibreElec ;-)
    - Installed plugin BACKUP to restore all settings from my 805 box including the advancedsettings.xml.


    Now If I playback a Movie or TV Series for some reason it takes almost 2 minutes to start. When it starts it playsback very nice..:

    Logfile: Mecool.zip


    Other movies or series play directly.(have to check if they use a different codec or so).

    I don't have this issue with the MXW 805 box.


    As I am struggeling for several hours now and don't see the issue on the forum. I don't know what to do :P.


    15:20 update: I've hadded 2 sources: 1 DS_SAMBA and 1 DS_NFS. It seems LE is struggeling with producing the network list of my NFS servers (i've multiple). After a long wait

    15:15:32.662 T:3437310880 ERROR: Unable to lookup host: ''

    15:19:20.246 T:3471831968 ERROR: Previous line repeats 1 times.


    Both servers show up and I am able to complete the source information. Now if i browse to the movie (via files). It plays directly. Both SAMBA and NFS. However if I try access via library I have the described 2 minute wait for most movies.

    Files

    • Mecool.zip

      (53.21 kB, downloaded 129 times, last: )

    I'm not sure that's entirely accurate. My Harmony remotes are IR and work perfectly well with CEC enabled or not.


    Unless your statement is that CEC HAS TO be disabled for any external IR receiver to work


    Haha yes, you got a point there.
    I just quoted something I found on the web hence the " ...".
    At the moment I have to agree with you CEC and Internal IR remote are working simultaniously.


    As the box is in a drawer the internal IR is no use to me so that is why I want to use an external IR receiver.
    It seemd ir-keytables is recognizing the external IR receiver already, however still no communications within KODI.
    If I try "irrecord" command I receive garbage characters, so at least it does see something. Now let's find out where it goes wrong and update the WIKI for other users.

    I will reply only to let you know that I am not familiar with that kind of receivers and have no idea what's needed to make it work - apart from a driver maybe?


    I hope someone else could help you here.


    Tnx. No worries. I will figure it out eventually .
    I would first like to thank you for all your hard work an responses to the people on the forum
    Just to pick your brains a little bit more:


    I already found "


    "


    According to my info I am moving in the right direction:

    Code
    grep '^N:' /proc/bus/input/devices
    
    
    N: Name="Logitech Unifying Device. Wireless PID:4024"
    N: Name="aml_keypad"
    N: [b]Name="Media Center Ed. eHome Infrared Remote Transceiver (1934:5168)"[/b]


    Indicating the device is recognized so driver should be okay.

    Code
    MXQ:~/.config # ir-keytable
    Found /sys/class/rc/rc0/ (/dev/input/event2) with:
            Driver mceusb, table rc-rc6-mce
            Supported protocols: unknown other lirc rc-5 jvc sony nec sanyo mce-kbd rc-6 sharp xmp
            Enabled protocols: lirc nec rc-6
            Name: Media Center Ed. eHome Infrared
            bus: 3, vendor/product: [b]1934:5168[/b], version: 0x0001
            Repeat delay = 1000 ms, repeat period = 125 ms


    ir-keytable indicates it is seing the device as rc0.

    Code
    dmesg
        
    [    [email protected]] lirc_dev: IR Remote Control driver registered, major 232
    [    [email protected]] rc rc0: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0
    [    [email protected]] input: lircd as /devices/virtual/input/input3


            
    It could be that the internal IR receiver is causing problems. Any idea how I can disable that one??


    Something like what is described here: http://forum.odroid.com/viewtopic.php?f=138&t=20415&p=145618#p145582
    Create a blacklist-meson-ir_set-gpio-ir-nr.conf for blacklisting meson-ir as well as defining the now used GPIO-number in directory .config/modprobe.d/


    That is the only think I can think of . The IR receiver is working fine on a windows machine.


    The only negative I could find about a certain HP receiver can be read here: but it is a chromebox not a LE AMLOGIC S805 .
    Chromebox - Official Kodi Wiki


    After replugging the device into the MXQ:

    Code
    [email protected]] usb 2-1: Product: eHome Infrared Transceiver
    [ [email protected]] usb 2-1: Manufacturer: FINTEK
    [ [email protected]] usb 2-1: SerialNumber: 88636562727801
    [ [email protected]] Registered IR keymap rc-rc6-mce
    [ [email protected]] input: Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) as /devices/lm0/usb2/2-1/2-1:1.0/rc/rc0/input4
    [ [email protected]] rc rc0: Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) as /devices/lm0/usb2/2-1/2-1:1.0/rc/rc0
    [ [email protected]] rc rc0: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0
    [ [email protected]] mceusb 2-1:1.0: Registered FINTEK eHome Infrared Transceiver with mce emulator interface version 2
    [ [email protected]] mceusb 2-1:1.0: 0 tx ports (0x0 cabled) and 2 rx sensors (0x1 active)
    [ [email protected]] input: lircd as /devices/virtual/input/input5

    Hi, I solved only one piece of the non working remote puzzle via: LibreELEC


    Q: My remote control does not work, what can I do?
    A: Try both MXQ and HD18Q releases. If this doesn't work, grab remote.conf file from Android firmware (it's available in /system/etc) and copy it to Configuration folder: /storage/.config over SSH or \\your_box_IP\Configuration using Windows shares. You may need to remap some buttons, though.


    I downloaded the firmware of my box via: MXQ "All Black" S805 Versions / HD18q / and Clones Directory - FreakTab.com.


    Extracted the remote.conf and placed it in the corresponding directory.
    /storage/.config.


    At least that gave me back the original remote control functionality.
    However as the box is inside a drawer IR has no use to me.


    I would like to use my MCE IR remote (via Harmony) that is attached via USB and the receiver is located near the TV. Any possibility to activate that IR remote as well??

    Hi, these are my first steps with LibreELEC.


    I received my MXQ all black device.
    Out of the box (ANDROID) all is working (also the original remote control)


    I wanted to start with LibreELEC
    I tried the "test" option first however the MXQ did not want to boot from my SD card... "LibreELEC-S805.MXQ.arm-7.0.2.5"
    Had the same SD (boot) issue with the Cubietruck. I solved that one with a different SD card..... but did not have another one.
    Problem MicroSD card was a 2GB Kingston.


    I reinstalled the Kingston SD card with the NAND image....
    With MXQ I used the toothpick method assuming I would go into boot mode, however the device instantly flashed the MXQ.
    I could not use the original remote now and needed a USB mouse to navigate me through the installation.


    I removed the SD card from the MXQ and rebooted. As a result Kodi came to live .


    CEC with the LG TV works.
    Only thing that does not work is the IR-REMOTE.
    I added a separate USB IR REMOTE (MCE) in the USB port.


    Unfortunately those remotes don't work now. I'm looking for the possibilitie to have 2 remotes working (1x CEC, 1x MCE via Harmony One)
    I've searched the forum and tried moving the lircd.conf.rpi keymap to the config directory. Maybe I'm still missing some files somewhere.


    LIRCD is running.


    IR USB Device is detected

    Code
    Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
    Bus 001 Device 003: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
    Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 003: ID 1934:5168 Feature Integration Technology Inc. (Fintek) F71610A or F71612A Consumer Infrared Receiver/Transceiver
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    The dmesg gives me the following. And yes the Logitech Keyboard is also working fine .



    Code
    MXQ:# ls /sys/class/rc
    rc0



    Code
    MXQ:/etc/lirc # dmesg | grep "rc0"
    [    [email protected]] input: Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) as /devices/lm0/usb2/2-1/2-1:1.0/rc/rc0/input2
    [    [email protected]] rc rc0: Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) as /devices/lm0/usb2/2-1/2-1:1.0/rc/rc0
    [    [email protected]] rc rc0: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0
    [[email protected]] input: Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) as /devices/lm0/usb2/2-1/2-1:1.0/rc/rc0/input4
    [[email protected]] rc rc0: Media Center Ed. eHome Infrared Remote Transceiver (1934:5168) as /devices/lm0/usb2/2-1/2-1:1.0/rc/rc0
    [[email protected]] rc rc0: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0


    So I assume I am missing a specific Keymap somewhere.

    Code
    MXQ:~/.config/modprobe.d # ir-keytable
    Found /sys/class/rc/rc0/ (/dev/input/event2) with:
            Driver mceusb, table rc-rc6-mce
            Supported protocols: unknown other lirc rc-5 jvc sony nec sanyo mce-kbd rc-6 sharp xmp
            Enabled protocols: lirc nec rc-6
            Name: Media Center Ed. eHome Infrared
            bus: 3, vendor/product: 1934:5168, version: 0x0001
            Repeat delay = 1000 ms, repeat period = 125 ms



    Any help would be appreciated as I really would like to use the IR remote as a backup because all keys are mapped correctly on that device.


    tnx,


    sincze