Touchsupport

  • hm... not fully more useful, I also tried estouchy (which had to be tweaked manually for the resolution, because with default settings it did not start at all with my touchscreen). But the problem reported is exactly the same. And this is true for every menu which has no bars to scroll up/down. I assume all the skins are not made for resistive touchscreens, but only for capacitive touchscreens.


    Anyway, a workaround is to reduce the main menu points and the configs can be done once via keyboard.

  • Well, I wouldn't know the difference between them. And maybe addon never really worked. But I'm sure someone would point that out.

    Or maybe there was some change in kodi handling input. Who knows...

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community) (limited no support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

  • Well, I can ask directly in the kodi forum and not here as I assume there the development takes place. What I saw is that the estouchy menu structure is vertical on the left side but with increased font size. All in all not that much different from estuary. For a touch device it would be much better to place the whole menu all over the screen (like the settings main menu), and not just like a menu on the left side (maybe I oversaw some tweak to allow that?). This is more efficient and easier to handle, especially for such resistive touchscreens. And adding small arrows to touch/ click on it for vertical and/ or horizontal scrolling or adding bars if more is covered than the screen area can contain. No need to discuss this in detail, but this was already the case for the older re-touched skin (not to mention that the keyboard does not work properly anymore once the skin is active...). So using estuary instead of estouchy is a better choice in case of a resistive touchscreen + reducing the number of main menu entries, and the rest works quite fine.


    btw - please see here Estouchy Skin and scrolling?? - this problem seems to be known, it is a mixture of kodi-specific and skin. But it does not seem to be fixed in Krypton, and from the forum discussion it is also unclear whether this change made it up to the main menu and not just into settings.

  • Kodi doesn't really care for touchscreen problems. But you can try :)

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community) (limited no support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

  • Hi all,


    It's a bit difficult to keep track of how to get touch to work (eGalax) in LE through 258 posts :)

    I tried but easily got lost in the different conversations.


    So this quick question: does LE 8.2.x support eGalax out of the box?

    Or alternatively, does anybody have a working 8.2.x image with eGalax support?


    PS: found out the hard way that compiling on Ubuntu18.04LTS does not work. Not being an expert I gave up ;)

    Edited once, last by RAspiDave ().

  • Hello,

    I am trying to install a Waveshare 5“ touchscreen with libreELEC 8.5.2 and Kodi 17.6, but up to now without success.


    The touchscreen works fine with the Raspbian-image from the Waveshare-hompage so it seems to be technically o.k. But as soon as Kodi is started from Raspbian, the touch function stopps to work.


    In libreELEC I didn’t install any of the drivers from the Wavescreen homepage as I don’t know which one is the right one and how to get access to the tar.gz file in libreELEC. Is this o.k. or has one of these drivers to be installed and if so, how can that be done in libreELEC?


    In config.txt I added

    max_usb_current=1

    hdmi_group=2

    hdmi_mode=87

    hdmi_cvt=800 480 60 0 0 0


    I copied the files ts.conf and ts_env.sh from ts.conf-waveshare and ts_env.sh-waveshare without any changes into the folder .kodi/userdata/addon_data/service.touchscreen.


    “evtest” shows no event related to the touchscreen. The Touchscreen-Addon doesn’t work, only the loading spinner appears.


    “systemctl status ts_uinput_touch –l” gives “unit ts_uinput_touch.service could not be found” which indicates, that something is wrong.


    “systemctl status service.touchscreen –l” gives the same as in post #192 also indicating that something is wrong with ts_uinput_touch.


    Changing the Product_PID in ts_env.sh from 0005 to 0001 gives no effect.


    Are there any ideas, what is wrong or what I could try to get the touchscreen to work?


    George