Librespot addon

  • Trying to get LibreSpot (9.0.111) working on a S912 box with latest CoreElec (CoreELEC-S912.arm-8.90.2).

    Everything is working fine except for the sound part.


    I can select LibreSpot from the list of devices in the spotify app, and on CoreElec I see a song should be playing.

    "Should be playing" because there is no audio coming out of my speakers :D


    I've tried messing around with the configuration, tried all 3 options in the configuration, none works.(I am using HDMI btw)
    Also tried entering the configuration manually because I read somewhere the picker didn't work (so just wrote AMLM8AUDIO,DEV=0 or CARD=AMLM8AUDIO,DEV=0) but there's still no audio coming from LibreSpot.


    And yes, I set the volume from the android app to max volume.


    Anyone got any suggestions for what could be going wrong? (AHVI is enabled in CoreElec settings)

  • Great work on the .111 update! Works like a charm!

    One question: by installing this .zip update, I'm prolly disconnected from the main repo, not? So I will not receive the new updates automagically?

    Need to reinstall from the main repo at the end of the week?

  • Great work on the .111 update! Works like a charm!

    One question: by installing this .zip update, I'm prolly disconnected from the main repo, not? So I will not receive the new updates automagically?

    Need to reinstall from the main repo at the end of the week?

    Version 111 is now available from the LibreELEC repository.

    Librespot will update automatically (unless auto-update off).

    @

  • I have no idea about sound with CoreELEC.

    CoreELEC devs may help you.

    Otherwise, you may switch output from ALSA to Kodi.

    @

  • Still nothing, I've tried refreshing and rebooting but sill can't find it.
    Should your changes also be present in amlogic branch ?

  • Librespot (or any other spotify app for that matter) doesn't show up as spotify connect device. This might have more to do with my version of Libreelec, since it is an alpha/pre-alpha ROCK64 version. But in the event, that I'm simply overlooking something obvious or that is a know issue, I thought I would try to get some help here anyway.


    What I want to do is to stream from my Spotify app on my laptop, which is connected to the same network as the ROCK64 (wired), that I want to stream to. I would have liked to test it on my phone app, but unfortunately I am one of the few people, who have a Windows Phone (don't ask why) and its spotify app, doesn't even have the option to connect to another device.


    As was described, I've created a log with the "journalctl -u service.librespot" command this is the result.


    Avahi is on and I've set it to "Wait for network before starting kodi" but to seemingly no avail.

  • There is something wrong with librespot on ROCK64: it core dumps.

    Not sure what it could be.

    I will come back to you when I have the time.

    @

  • Hello,


    i am trying to get librespot 8.2.111 working on my raspberry pi 3 with libreelec 8.2.5.

    Zeroconf is activated as well as wating for network in settings.

    Her is my log:

    Code
    1. -- Logs begin at Sat 2018-03-24 16:12:13 CET, end at Fri 2018-06-01 14:59:05 CEST. --
    2. Jun 01 14:58:20 LibreELEC systemd[1]: Started librespot.
    3. Jun 01 14:58:21 LibreELEC sh[456]: INFO:librespot: librespot 1da6210 (2018-05-22). Built on 2018-05-28. Build ID: jVVVnMwb
    4. Jun 01 14:58:21 LibreELEC sh[456]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.
    5. Jun 01 14:58:21 LibreELEC sh[456]: *** WARNING *** Please fix your application to use the native API of Avahi!
    6. Jun 01 14:58:21 LibreELEC sh[456]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>
    7. Jun 01 14:58:21 LibreELEC librespot[481]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.
    8. Jun 01 14:58:21 LibreELEC librespot[481]: *** WARNING *** Please fix your application to use the native API of Avahi!
    9. Jun 01 14:58:21 LibreELEC librespot[481]: *** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=librespot>

    I am not able to connect a device with the spotify android app.

    I would be happy if you could help me.

    Thanks in advance.

  • Just to make sure: are your Android device and your LibreELEC device on the same subnet?

    @

  • Not really sure what you mean.

    Both are in the same network.

    Pi is connected with LAN, the phone with WLAN.


    Edit: just installed Spotify again on my phone and its working :)

    Edited once, last by phillow ().

  • librespot plugin does not run satisfactorily on CoreELEC 8.90.3 (Wetek Play 2).


    I wrote the issues also in a thread at CoreELEC, but because it seems unclear if the issue is CoreELEC, Leia or librespot specific, I want to inform you as well.


    The issue depends on the used audio system:


    1) ALSA


    * If librespot is active playing, the Kodi GUI is not working anymore

    * If I stop the playing and try to use Kodi again, it crashes

    * last lines of kodi_crash.log:

    15:04:48.020 T:4064277360 INFO: CActiveAESink::OpenSink - initialize sink

    15:04:48.020 T:4064277360 DEBUG: CActiveAESink::OpenSink - trying to open device ALSA:default

    15:04:48.020 T:4064277360 INFO: CAESinkALSA::Initialize - Requested layout: FL, FR

    15:04:48.021 T:4064277360 INFO: CAESinkALSA::Initialize - set digital_codec 0

    15:04:48.021 T:4064277360 INFO: CAESinkALSA::Initialize - Attempting to open device "default"

    15:04:48.024 T:4064277360 INFO: CAESinkALSA - Unable to open device "default" for playback

    15:04:48.024 T:4064277360 ERROR: CAESinkALSA::Initialize - failed to initialize device "default"

    15:04:48.025 T:4064277360 DEBUG: CActiveAESink::OpenSink - trying to open device ALSA:default

    15:04:48.025 T:4064277360 INFO: CAESinkALSA::Initialize - Requested layout: FL, FR

    15:04:48.025 T:4064277360 INFO: CAESinkALSA::Initialize - set digital_codec 0

    15:04:48.025 T:4064277360 INFO: CAESinkALSA::Initialize - Attempting to open device "default"

    15:04:48.029 T:4064277360 INFO: CAESinkALSA - Unable to open device "default" for playback

    15:04:48.029 T:4064277360 ERROR: CAESinkALSA::Initialize - failed to initialize device "default"

    15:04:48.029 T:4064277360 ERROR: CActiveAESink::OpenSink - no sink was returned


    It seems Kodi is not able to get back the ALSA sink.


    2) Kodi


    I can switch between the use of librespot and Kodi without crashes. But sometimes (maybe after librespot was restarted) the audio output is stuttering.