Librespot addon

  • TL;DR: discovery mode doesn't work.


    Long answer: Because my LibreElec box is on a wired network which is routed to the Wi-Fi network, but apparently this is not sufficient for LibreSpot. I even configured Avahi in router mode on the router (necessary for Kore to find Kodi) but that's not enough for Spotify's discovery mode (I haven't investigated which kind of protocol it speaks).

    As far as I am aware, Spotify Connect uses Bonjour for device discovery - I would have thought that should be covered by the Avahi settings, unless you have any other options.

  • Hi awiouy,

    first of all thank you for this awesome addon, which make a great feature possible on my TV Box, that i converted from an Android to an libreelec Box.


    I had a problem, that the addon didnt work on startup (my phone didnt find the other device). I had to go to addons, librespot, configuration and just press ok, then it worked . Now I added sleep 5 in the start configuration file and i can find libreelec now right after boot, but it didnt play sound till i changed the output device to Kodi. Now it get find on boot and plays the music. Problem is, that it has a huge delay (3-4sec) after an input has made. Is there any way to fix this, so it will be perfect?


    Maybe it would be helpful, if there would be a small tutorial on the first post with an howto and what is needed for it to get it work (which services should be enabled).


    Thank you again for your awesome addon, and support

  • Why use login/password? Use discovery mode.

    If you want to use Kodi volume, use Kodi mode (set mode in addon settings)

    The name of the currently playing song is displayed on the screen in both modes, not in OSD though.

    Would it possible to integrate such support? So lyrics and last.fm addon will work with librespot?


    Also even when choosing Kodi as output device, the spectrum analyser/equilizer will not work :(


    Thx for this awesome addon

  • Hi

    I´m using the librespot addon on my Mecool M8s pro device. It is running fine.

    But my backup program (standard XBMC Backup) stucks at addons/service.librespot/lib

    Any hints to solve the problem ?

  • Ok. I asked there - but I guess its more a problem from the addon.


    I had the same problem on 2 different devices.

    Then i tried to disable librespot addon in the device settings.

    The result was a complete frozen device. Had to pull out the power switch.


    Powered up the device again.

    Now the addon is shown as disabled.


    Backup is running now without problems.


    And I have seen in postings - I´m not alone with that problem.

    I am only a user. But I think no addon should crash kodi.

    I guess it would be better if you will do a developer talk to robweber..

  • send me a log of the backup issue and i will have a look at it

  • sended logfile adress via PM


    I hope it may help


    edit : changed my backup / restore strategy and used in build libreelec backup instead of Kodi backup addon.

    This one worked without problems


    Looks like the Kodi backup addon has some problems with backing up files with enabled services

  • I used the discontinued Spotify web connect add-on before switching over to this, it's works like a charm :)


    However, in the old web connect, I could use analog out and hdmi audio independently. If Spotify is playing using my speakers connected to analog and I start a video, the music pauses even though Kodi is set to use hdmi.


    This is annoying, as I usually would for example watch some football with low volume on the TV while listening to music on the speakers.. :/

  • I used the discontinued Spotify web connect add-on before switching over to this, it's works like a charm :)


    However, in the old web connect, I could use analog out and hdmi audio independently. If Spotify is playing using my speakers connected to analog and I start a video, the music pauses even though Kodi is set to use hdmi.


    This is annoying, as I usually would for example watch some football with low volume on the TV while listening to music on the speakers.. :/

    Works as programmed. Kodi takes precedence over Librespot: if Kodi plays, Librespot stops.

  • Thanks :) I've added "Keep spotify playing" setting, that does not stop Spotify when playing a video:

    Keep spotify playing setting added · siz-/[email protected] · GitHub

    (don't know why it doesn't just show line changes, maybe due to the fact I used the upload tool on the site)


    Added an extra check to not restart the service when stopping a video, as "stop" would stop both due to the above implementation.


    I can submit a pull request if you deem the setting as useful, I use it a lot myself :)