Comskip with Tv headend

  • Hi Apollo, hur did you get rid off the error "Segmentation fault (core dumped)(49.00 fps), 1.00 sec(49.00 fps), 0%"


    You have to just use comskip without an ini file, so your post processor command would simply look like this:

    /storage/.kodi/addons/tools.comskip/bin/comskip %f

    If anyone figures out a way to get ini files working with this that would be awesome.

  • after copy whole comskip dir (/storage/.kodi/addons/tools.comskip) to:

    1. /storage/.kodi/userdata/addon_data/tool.comskip

    i also copied comskip ini to:

    1. /storage/.kodi/userdata/addon_data/tool.comskip/bin/comskip.ini

    now i can launch comskip near the ini. but i get the error:

    1. Segmentation fault (core dumped)

    Full output:

    is there something i can try?

  • The person who wrote the addon, shanemeagher, compiled it for the pi3 as a favor/request. I do not think he owned or used a pi3 so there was no debuging. My understanding is that ini files simply dont work, and the only alternative is to switch to using one of the TVheadend nightly builds that has it built in and working.

  • Apollos andy5macht,

    I've had a chance to do a little more on my comskip addon. It now has:

    - a comskip.ini file included

    - option to select from using the included comskip.ini, specify a path to an alternate, or using none

    - recent v0.82.003

    Here's builds for:

    - Generic/x86_64:

    - RPi2/arm:

    I got an RPi3 recently and the attached (RPi2/arm) seems to run for me although the RPi runs very hot.

    Realistically the comskip.ini needs to be adjusted for the channel as the generic one is hit and miss with the channels I use it with.

    chewitt  CvH

    Is it worth submitting to the repo if it'll be packaged with tvheadend in LE9.0? I probably don't have time to commit to maintaining it consistently to be honest but its seem functional at this point.



  • I am trying to set this up. I am confused. I'm a NOOB at best. I have a RPi3 and am running Libreelec

    I have installed tools-comskip-8-2-90-zip

    Set the following in tvheadend 4.2.3-20

    • Remove all unsafe characters from filename: YES
    • Replace whitespace in title with '-': YES
    • Post-processor command: /storage/.kodi/addons/tools.comskip/bin/comskip %f


    I think now if everything is correct I should now have an .edl file also when I record. Am I correct?

    I am not seeing that and commercials are not being skipped. What am I missing?

  • I'm at the same point as you. The best "setup instructions" I found so far were yours. :-)
    Did you manage to make it works ?

    Edited once, last by esenterre ().

  • Thanks for the addon update Shanemeagher! Running with the ini files now works great. I couldnt get the ini file to be used by default, but when modifying the post-processor command in TVH like shown below it worked fine.

    For you other folks trying to get this to work. Install the zip addon as normal, then in Tvheadend, inter the following in the post processor command line in the recordings tab:

    1. /storage/.kodi/addons/tools.comskip/bin/comskip.bin --ini=/storage/.kodi/userdata/addon_data/tools.comskip/ini/comskip.ini %f

    If you do some googling and want to use other ini files, just replace the existing ini file, or point to a different location of the ini in the command line above.

  • Searching for comskip info for a wetek play (imx6.arm) and this thread is the closest I've come. Any chance of an imx6 arm build? I had an old one that was working on an openelec installation but now it just fails with a missing library. CHeers - Merl

  • I'm a noob running LibreElec 8.2 with Tvheadend 4.2 on a AMLogic S905W box. Has anyone compiled Comskip for an AMLogic ARM box?

    Compiling is a bit over my head, I haven't even successfully SSH'd into my box yet (I can get in through Windows file explorer).


  • I've been playing around and managed to get comskip to work with my AMLogic S912 box.

    I'm not sure whether all of the following steps that I used are necessary as is was a case of try this and that until it worked but this is how I achieved it.

    1. SSH into the box and create the directory /storage/.kodi/userdata/addon_data/tools.comskip

    2. Install the Comskip addon from post #22 for RPi2/arm courtesy of shanemeagher.

    3. Fire up TVHeadend on your browser and navigate to Configuration, Recording.

    Choose your profile name of choice from the left hand window pane (probably Default profile unless you have created one for specific needs).

    Scroll down the options in the right hand pane until you get to Filename Options and check the boxes for Replace whitespace in title with '-': and Remove all unsafe characters from filename:. Also make sure that your chosen profile is Enabled.

    Scroll back up a little until you see the option Post-processor command:. In this field enter the text /storage/.kodi/addons/tools.comskip/bin/comskip.bin --ini=/storage/.kodi/userdata/addon_data/tools.comskip/ini/comskip.ini %f

    In the left hand pane, click the Save button.

    4. Reboot your box,

    5. Set-up a timer recording for a programme that will have adverts (note that if you ever stop a recording part way through then post processing will still be carried out).

    6. Wait for the recording to finish and then SSH into your box and navigate to your recordings folder. In my case it was /storage/recordings

    Navigate your way into the folder containing the recording, named after the show you just recorded.

    You will initially see 4 files but don't do anything until post processing is complete and you see the 5th, which is the .edl file.


    7. Open the video in Kodi and when the ads begin, the video will skip the ads and you may even see a small pop-up in the bottom right hand side of the Kodi screen with the word Commercial, to indicate that it has reached a point and is skipping it.

    Ensure that the .edl file always remains with the video file if you copy it elsewhere.

    The other .log and .txt files can be deleted unless you want them for further diagnosis.

    A big shout out to all that have contributed and given the answers by their own sheer efforts of trial and error.

    I'm using Build: 4.2.5 ~ LibreELEC Tvh-addon v8.2.113 (2017-12-21T20:30:12+0100) of TvHeadend.

    Update: I noticed when using this with a current X86/64 build based on Kodi 18 and although the addon would install and there were no errors, there was no post processing.

    I then tried an 18 based distro for S912 and it didn't work either, so for now it will only work on Krypton 17.6 builds for AMlogic/Intel.

    Edited 3 times, last by ozarks: Update ().

  • Hi

    I had another try with the instructions from ozarcs (thanks!)

    I'm on a wetek play box (arm7) so I just tried the pi3/arm version. I tried as per the instructions.

    Comments: creating the directory in step 1 is fine but since it is empty then comskip won't find an ini file there.

    I tested the post-processor line from the command line, replacing the non-existing ini file with the default one in the installation:

    1. /storage/.kodi/addons/tools.comskip/bin/comskip.bin \
    2. --ini=/storage/.kodi/addons/tools.comskip/defaults/ini/comskip.ini \
    3.   Modus2018-03-12.ts

    This runs, identifies the video file and its metadata, gives with a few error messages then dies:

    [mpeg2video @ 0x2c94fb0] Invalid frame dimensions 0x0.


    [mpeg2video @ 0x2c94ac0] gray decoding requested but not enabled at configuration time

    Illegal instruction (core dumped)

    I presume running from tvheadend is not going to make any difference.

    Any ideas?

  • What I found was that when the addon was installed, the folder that was created was automatically populated with the ini file.

    If I am reading things correct, your modification to comskip.ini references a specific file name, which I am guessing won't work unless you can predict the name of the file that will be recorded.

    There are also a couple of back slashes in there, which I'm not certain are allowed.

    One thing that I did change, which might not have any impact, but worth trying, is to use the default stream profile for Matroska, which is then also selected in the recording section to produce a .MKV file rather than a .TS.

    I take it that you are not using a 9.0 based LE release as the addon doesn't work with the latest releases and comskip is now baked into the latest TVheadend builds.

  • Thanks for your reply. You are correct I am not on 9.0.

    I presumed that tvheadend simply runs the post-processing command where %f refers to the file that was recorded. So I simply tested this on an old file. It reads the file in and correctly parses the metadata.

    Doing this should simulate what tvheadend does (unless there is some hidden magic, but I can't imagine what that would be). If I try to run it when pointing to a nonexistent ini file it just terminates immediately with an error message.

    (the backslashes are just the standard way to break a command over several lines btw - not important here since I ran it from the command line)

    I'll try with mkv...

    [EDIT: I see one thing I did wrong here: I installed before I created the folder! Will reinstall and test again!]