[8.2.2.3] LibreELEC 8.2 for S912

  • Hey,

    I have a new problem with the 5 Ghz Wlan after upgrading my t95z-plus to the android 7.1.1 from here.

    After the upgrade I can not get libreelec to use the 5 Ghz freq, booting from USB-Stick or internal. In Android both 2.4Ghz and 5Ghz are working fine.

    5Ghz in libreelec worked fine for month till I done this update. Used the q200 2g dtb as always.


    I tried with the stock Android 5 image too but no luck getting 5Ghz back in libreeelc. (In Android it works just fine.)


    The device uses the Ap4335 wifi chipset.


    Any idea what is going wrong?

  • Welcome to the club! :cry:

    Check this "stub" discussion on the matter... :sleeping:

    Yes, I also begin to think that there is no concrete solution for the remote in LE.

    But OK booting to Android before power off is only 20 seconds extra, so I can live with it.

    If somebody is having a fix anyway please let me know;)

  • Yes, I also begin to think that there is no concrete solution for the remote in LE.

    But OK booting to Android before power off is only 20 seconds extra, so I can live with it.

    If somebody is having a fix anyway please let me know;)

    Try enabling sleep mode to see if it works for your box. It doesn't work (properly) for all boxes, hence it isn't enabled by default. If it works for you you will basically have the same, as power off from Android is not really a power off either. I have never tried it myself so I can't tell you when the wake-up will fire off exactly. You should be a happy camper if using the remote is one of the ways.

    MECOOL KIII Pro (S912)

    Raspberry Pi 2 Model B, overclock mode: 'Pi2' (1000/500/500/2), gpu_mem_1024: '320'

  • Hi all

    for my personal understood.


    With this LibreELEC special release there is no 10-bit output at 1080 or 4K. It is limited to 8-bit. However, it's possible to get 8-bit, YCbCr 4:2:0 Rec.2020 HDR output on S912, correct ?


    With

    Code
    1. echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr

    it is possible to enable 10bit output on YCbCr 4:4:4, correct ?


    will it also add 10bit on other YCbCr (4:2:2, 4:2:0,..)?

    or should I enable it with

    Code
    1. echo '420,10bit' >> /sys/class/amhdmitx/amhdmitx0/attr

    Thanks in advance

    Minix Neo U9-H

  • Another thing

    DTS-HD HRA is not working, no sound.


    I test with kodi sample "DTS-HD HRA 5.1 (MKV @ 1080p/23.976 VC-1)" => NOK and another movies with TrueHD Atmos 7.1 => OK, DTS-HD MA 7.1 => OK, DTS-HD HRA 5.1=> NOK


    Log files


    version 8.2.0.1

    Minix Neo U9-H

  • Did you read the how to install? [HOWTO + FAQ] Install community builds on S905/S905X/S912 device


    from that


    . Before you install - choose a device tree


    Important: You cannot use device tree from Android firmware as in 99% cases it won't work.



    Please look at release thread for device trees folder link.

    • S905: First look for device tree with your box name in it. In case there is no such image, download generic one.
      • example: for a box with 2GB of RAM and 100Mbit Ethernet, you should download gxbb_p200_2G_100M.dtb
      • example: for boxes with Gigabit Ethernet download gxbb_p200_1Gbit.dtb
      • for boxes with Realtek WiFi download device tree with RealtekWiFi in name
    • S905X: You can leave a tree that is already present on SD card (fresh install only) or choose one according to your RAM amount. If internal memory of your box is not visible when trying to install to internal memory, try a device tree with _nand suffix.
    • S912: You need to choose device tree according to your Ethernet port speed and RAM amount

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass

    :)

  • Help ! I've booted from internal today for checking something in the android version of Kodi and while doing that android updated itself and since then it won't boot LE from the USB pendrive I've used until now. It boots straight to android.

    I'm using a Minix U9.


    What to do folks ?

  • 1. try booting using reset/recovery switch

    2. I'd try adding the device tree again

    3. try with another usb stick, (it could be the stick)

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass

    :)

  • My new S912 box, M8S Pro L, first build what I tried was @afl1's build, 8.90.4-K, works fine except some files and add-ons, after that I made a new SD-card with this build, 8.2.0.1, now all files works great, some files played with microstutters, all add-ons works fine but the remote doesn't work, on @afl1's build works great. On Android works great, I've tried to copy remote.conf to storage/Configfiles without success, no working at all.

    Thanks for your work.

  • My new S912 box, M8S Pro L, first build what I tried was @afl1's build, 8.90.4-K, works fine except some files and add-ons, after that I made a new SD-card with this build, 8.2.0.1, now all files works great, some files played with microstutters, all add-ons works fine but the remote doesn't work, on @afl1's build works great. On Android works great, I've tried to copy remote.conf to storage/Configfiles without success, no working at all.

    Thanks for your work.

    You put remote.conf in wrong folder. Put it in /storage/.config or simple in SD card root.

  • You put remote.conf in wrong folder. Put it in /storage/.config or simple in SD card root.

    Configfiles is the smb share name of the .config folder, isn't it?

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • Ok guys, I found something. I wrote Leia build on SD card, again, copied amremote folder after that back to Krypton build and copied amremote folder too, libreelec.conf and wetek.conf files are the same but on Leia build are another two files, remote.conf and remote.conf~, can I copy these files to Krypton's etc/amremote folder?