VPN Manager for OpenVPN

  • I got a message box pop up last night that OpenVPN is no longer supporting Nord VPN due to constant server changes..

    I use a Raspberry with Libreelec and Kodi.

    NordVPN is not on the list anymore and VPN is not active anymore. Is there a easy solution? Thanks.

  • System - Kodi 17.5 on RPi using LibreELEC with the Amber skin, UK based and using a USB keyboard to navigate.

    Issue - Loss of NordVPN with the latest update and configuration of User Defined Wizard to get the VPN back up again.

    Downloaded several .opvn files from NordVPN and moved them into the Kodi 'download' directory via SSH.

    Selected User Defined connection, entered Username and Password.

    Entered the wizard and got as far as selecting the directory to search/select the .opvn files but I am unable to navigate to the required download directory. One directory is available at the top of the screen (forgot the name but it appears to be a repository URL in the bottom left hand corner) but I cannot change or navigate away from it to select the required .opvn files.

    In the meantime I've managed to roll back to a previous image of Kodi, turned off VPN Manager's auto update and all is working again, for the time being at least.

    Any idea what I'm doing wrong?

    Edited once, last by DMac ().

  • If you want to continue to use NordVPN, then you can use the User Defined wizard to import the files - but you'll need to update them everytime they change something.

    Nope, read that and that's why I'm attempting to set up NordVPN using the User Defined Wizard to import the .opvn files!

  • You need to add the disk with the ovpn files as a source in the file manager...this is standard kodi operation and you can find out more for your platform/skin by googling it if you need more help

  • Again, thank you for pointing me in the right direction; it worked faultlessly. I now have NordVPN set up and working fine as a User Defined VPN.

  • There's nothing in the log to suggest why it's disconnecting. You could up the tracing by altering the verb setting to 4 or 5 in settings/debug. I'd guess it was a server side problem though given the other comments and the fact that the settings work on other

    How do i go about doing that?

    I have been trying switching servers and every one I try has the same issue. IP Vanish says the same thing as you (cant find the problem) but of course they lay it on the apps doorstep.

    Thanks again. I really appreciate the help!

  • You can set the verb by going to Settings/Debug, there's an option in the openvpn section. You then need to reset the provider files and reconnect.

    However, I've checked out their latest configs, and nothing has changed. If you want to progress support with them then you should use openvpn directly from the command line and skip the add-on. If you switch on debug, (also in Settings/Debug), you should see the command appear in the log. It'll be something like 'openvpn /storage/.kodi/addons/IPVanish/something.ovpn'. Type this into an ssh session (google it if you don't know how) and see if it stays connected. If not, ask their support what the issue is.

  • .... yes I'm using the latest kodi alpha nightly build of Leia... ok you are not interested, no issue. Can you please tell me where in the code you are loading the settings for the 1_vpn_addons setting? Where is the verification line?

    By no means the right way or a solution but if you are after a similar temporary work-around then a bodge to the filtering by amending the server.py just to force a disconnect on Netflix or whatever you need (around line 600, add the 'OR 'and restart the Pi):

    if filter == 0 or ("flix" in current_path):

    Better than nothing for the moment :)



  • Does a person have to use the "Add-on Filtering" for a connection?

    I only have a single add-on that I want to go through the VPN. Everything else is unnecessary. I put that one add-on in the first "Add-on Filter", but every so often, if that particular VPN is slow, or having issues, I switch to another VPN connection. But as soon as I go to use that add-on, the VPN goes right back to the first connection. It took me a while to realize what was going on. VPN Manager was doing exactly what I told it to do. :)

    I reviewed the documentation, and I don't see anything that say's that I have to setup a filter, but the way that I read it, I feel that in order to get an add-on to use the VPN, then I have to setup at filter. If I don't setup a filter, will the connection still go through the VPN, or do I have to specifically tell it to use a VPN?



  • No, set it up so that the VPN you want to use is the first connection and check that you're using connect and boot and the option to reconnect.

    Filtering is just if you want to use different (or no) VPNs by addon

  • No, set it up so that the VPN you want to use is the first connection and check that you're using connect and boot and the option to reconnect.

    Filtering is just if you want to use different (or no) VPNs by addon

    Thanks Zomboided. Much appreciated.


  • Hi Zomboided,

    I tried out OSMC on my RPi3 and I noticed that when I want to change to another VPN provider it takes a long time before the notification dialog box pops up showing that the change to another VPN provider is taking place after I made my selection. In LibreELEC it's almost instantaneous for the process to begin. Any way to speed up the OSMC process in changing providers?

    I suspect it takes longer to kill openvpn in OSMC than it does in LibreELEC.

    Thanks for any info that you can shed on this problem.

    Best regards,


  • I've seen the notification a bit slow to pop up on the mimic skin on a cycle, but on a change it's largely governed by how long it takes to stop things.

    The kill process will try and do a kill sigterm and if after 10 seconds (I think) it does a kill sigkill. You should be able to turn on debug and see what's taking the time.

    There might be an option in settings in the debug tab to always use -9, can't remember whether I surfaced that or not.

    I don't use OSMC so no idea about why there would be different behaviours.

  • Hi Zomboided,

    I found out what the problem was for the long delay when trying to change a VPN provider. It seems OSMC doesn't have the package psmisc installed by default (which contains the killall command). After installing it everything seems to be functioning as normal. Knock on wood, that is. ;). A message from VPN Manager suggested that killall wasn't installed in the Kodi log.

    Thanks for your help.



  • I have LibreElec on an Intel Compute stick.

    After importing the opvn file, I can get the VPN to connect, but there seem to be DNS leaks.

    Some suggest:

    script-security 2
    up /etc/openvpn/update-resolv-conf
    down /etc/openvpn/update-resolv-conf

    But that command doesn't seem to exist.

    I have tried other scripts, but there seems to be discrepancies with bash or ash (??)

    Another suggestion is to make dns-priority a negative number in the vpn config, so that it overrides any other DNS, but I don't know how to do that on LE.

    Does anyone know where the settings are stored outside of the gui?

    Or what can be done to safely mask DNS?