VPN Manager for OpenVPN

  • I have a question i went and download the zip from github, then install it, but when i go to the program add ons the manager is never there.. is only in services.. why?

    Because it's a service that runs all the time and not a program

  • Because it's a service that runs all the time and not a program

    In Estuary Skin and AppTV Skin it shows up under program add-ons for me.

    Am i misunderstanding something here ?

  • Well it's defined as multiple things in the addon.xml because it provides 3 different entry points. I see it as a service in mimic which is the first thing it's defined as, but I guess maybe other skins slice and dice things differently.

  • Just a heads up for NordVPN users - I'm removing support in v.4.2.0 because the way NordVPN have chosen to implement their service, requiring constant changes to the servers unless you use their apps. This is not really compatible with the way my add-on works, and I'm fed up dealing with the repercussions.


    If you want to continue to use NordVPN, then you can use the User Defined wizard to import the files - but you'll need to update them everytime they change something.


    I've uploaded the latest definitons, which existing users can pick up by revalidating their connections.


    Sometime during the week of the 20th November I'll put 4.2.0 on the repo. This will stop NordVPN from working and I'll not be looking at any more NordVPN problems.


    If you want to stay on 4.1.9, then you can use NordVPN to the end of the year, at which point I'll remove the definitions that are needed from GitHub.

  • Hi Zomboided,

    I use NordVPN via the UserDefinded method mainly because there are so many ovpn files. I'll never use 99.9% of them.


    NordVPN is a good service and their price is quite reasonable, but they're mainly geared towards Windows, Mac, tablet, and phone users via their software.


    If anyone can suggest another good VPN service at around the same price range as NordVPN then I would appreciate it. The downfall of PIA, at least for me, is that they don't have any Atlanta servers. Latency is important to me.


    Thanks for a great addon, buddy. I love the new table.py feature.


    Have a good one.

    Bob

  • Dear all,


    I have a problem by configuring the exclusions and etc. of Zomboided's VPN Add-on.


    Manually everything works fine, but when I'm going to click on one of the items in the same page of the exlusions then the entire Libreelec crashes and the Raspberry PI completely resets.


    Someone has an idea how to configure this things manually?


    Thank you.

  • This sort of problem existed on a beta level of LE some time back. I'm not interested in debugging problems on beta builds - report those issues to whoever made the beta build you're using. If you can recreate on the latest stable version (8.1.2?) then get a full log with debug switched on and I'll look at it.

  • Having problems recently with OpenVPN randomly disconnecting and reconnecting. Seems to have gotten worse in the past few days. Can I post the debug log here fos some advice on how to fix? Using IPVanish.


    Im still pretty new but happy to try and follow directions/helpful instructions.

  • Having problems recently with OpenVPN randomly disconnecting and reconnecting. Seems to have gotten worse in the past few days. Can I post the debug log here fos some advice on how to fix? Using IPVanish.

    I use IP Vanish and never have issues related to this add on.

    I have had issues with certain servers being OVERLOADED and i lose internet data even though connection is still validated as connected.

    I go online log in and every time this issue occurs i see online that the server my box is logged into is OVERLOADED.

    I have monitored the servers and i now use one that is generally not loaded most of the time.

    Only 2 servers in my City and both get constantly Overloaded at peak times.

    I change Servers and never have an issue.

    See my screenshot that i sent IP Vanish showing lack of Servers in my city.

    Check and monitor servers first and then see what happens.

    Edited 2 times, last by kostaman ().

  • Just converted my windows 10 nuc over... loving it so far. I'm a newb with LE - have seen all sorts of raspberry pi options for a remote desktop over VNC. What is the easiest method for a remote desktop over a nuc? Same add-ons? Same process? I dont have a VPN service account - just want to connect locally from another machine to administer it via kodi graphic interface. I've looked at zomboided's vpn solution but aborted once his instructions mentioned vpn provider accounts. Any guidance appreciated.

  • This sort of problem existed on a beta level of LE some time back. I'm not interested in debugging problems on beta builds - report those issues to whoever made the beta build you're using. If you can recreate on the latest stable version (8.1.2?) then get a full log with debug switched on and I'll look at it.

    Hi Zomboided,


    Thank you, yes I'm using the latest kodi alpha nightly build of Leia... ok you are not interested, no issue. Can you please tell me where in the code you are loading the settings for the 1_vpn_addons setting? Where is the verification line?


    Thank you for your help in advance,


    Luca

  • The add-on is at least 5000 lines of code, and there are multiple settings that all relate to the filtering. If you're wanting to do this you need to understand it all yourself - it's all on GitHub, and there are comments. Life is far to short to remind myself how it all works and then explain it all to someone else.

  • Sorry for the delayed follow up- new baby at home.

    Sure, trouble shooting link, including log gathering is in the first post.


    Here is the link for my logs - Ubuntu Pastebin


    I have been changing servers to try and circumvent the issue. Please let me know if you see anything I can do to solve this issue beyond moving servers.


    Thank you very much!

  • There's nothing in the log to suggest why it's disconnecting. You could up the tracing by altering the verb setting to 4 or 5 in settings/debug. I'd guess it was a server side problem though given the other comments and the fact that the settings work on other servers ok

  • The add-on is at least 5000 lines of code, and there are multiple settings that all relate to the filtering. If you're wanting to do this you need to understand it all yourself - it's all on GitHub, and there are comments. Life is far to short to remind myself how it all works and then explain it all to someone else.

    Hi, I found what was wrong, but it is something inside Kodi when you call the settings page... but ok. Another question: I also installed the latest stable version and when I enable my VPN and then suspend the system and wake it up again I can see that your add-on still thinks that the VPN is up and running ... how to overcome this situation? Do you have a notification from Kodi when it is sent to sleep?


    Thank you,


    Luca