VPN Manager for OpenVPN

  • This is now fixed. Pick up the latest update when you see it.

  • it was a good log, thanks. It looks like the basic call to authenticate with Nord is failing. I don't have an active Nord account, but I have an inactive one and just now I was able to go right through the step you're failing at (which is basically checking you have a valid account to be able to use the Nord API), and retrieve data via the API, before being disallowed to connect.


    So maybe there's a problem with your account? Maybe when you tried it the API wasn't available? Maybe it's down to the fact you're running OpenELEC from ~3 years ago. If your account is good, I'd upgrade to a stable LibreELEC and try again. Nord is one of the more popular providers, so if it wasn't working I'd expect to see more people opening bugs, especially given where it's failing.

    Just wanted to let you know that updating to LibreELEC worked flawlessly. Thanks for a nice add on and great support!

  • This is now fixed. Pick up the latest update when you see it.

    What would you recommend I do in the future whenever server list updates are available? Is it typically safe to complete the update?

  • Mike1605 I am aware that you have moved on…but just as a final follow up to my ExpressVPN Auth error that I was personally struggling to resolve.


    Well after an extensive review between working and non-working device files and their setup with support from zomboided: issue was tracked down (by zombided, thank you as issue had been quietly driving me nuts) to simple typo within my very long ExpressVPN password. (q rather than g) /shrug


    How did this happen, well in my defence (if i have any) it must be an age/eyesight issue as when looking at and carefully checking password in Kodi GUI on TV and remotely via ssh and even with copied files on PC using notepad to check information within addon settings file: I never once noticed my elementary mistake. :exclamation:


    Posted here for other VPN users to consider if/when they get Auth Error and they are SURE they are introducing everything correctly :idea:

    Nobody is infallible (incapable of making an error :blush:)

    RPi4, 16Gb SD, (Raspbian Buster & LibreELEC 9.2) Onkyo TX-SR608 AV Receiver, Philips 55PUS7304 4K TV

    KVIM2 Pro, eMMC 32GB (Android 7) 8Gb SD (Varied OS) LG 27UD69-W 4K Monitor, AudioEngine A2+ Speakers

  • Hello,


    I created an account here because I want to help fixing the ongoing issues with CyberGhost and VPN Manager.


    However I am not quite sure what the issue is. I know that CyberGhost changed a lot of URLs and only the countries with old address are working with VPN Manger by Zomboided.


    For example Austria: Because the old URLS 4-1-at.cg-dialup.net and 9-1-at.cg-dialup.net are still online VPN Manager is working (these URLs are also in the LOCATIONS.txt). When I change the URLs in the LOCATIONS.txt to 100-1-at.cg-dialup.net and 101-1-at.cg-dialup.net a connection is not possible although the link is working. Does it mean the Kodi VPN Manager is not supporting OpenVPN 2.3 or what exactly is the issue?


    cyberghostaustriadpj3p.jpg


    zomboided If you need a list of all new server addresses I can give it to you, that's no problem. But will it work again then? I can also give you my account credentials to take a look into the CyberGhost backend.


    EDIT: I attached the ovpn files for switzerland TCP and UDP. The LOCATIONS.txt lines should be these two ones:


    Switzerland (TCP),101-1-ch.cg-dialup.net,tcp,443,#REMOVE=1 #PINGSPEED=15 #PINGEXIT=90

    Switzerland (UDP),100-1-ch.cg-dialup.net,udp,443,#PINGSPEED=5 #PINGEXIT=60


    I hope it helps.

    Files

    Edited 2 times, last by daghy ().

  • Thanks for trying to help. Here are the issues:


    If i change to what you suggest, then it'll break for everyone else using the regular servers. I've been down that path, I'm not going to do that again.


    I could get a list of all the servers, but there are too many and it'll take too long.


    Cyberghost are using different servers for different accounts (I'm guessing), and expecting the user to define which device uses which set of servers. This is additional complexity that just has people telling me that connections don't work.


    I'm really not motivated to support Cyberghost whilst they're offering such a complex service. There's no right answer other than expecting their users to jump through the hoops they've put in place and use User Defined. So for now, the support is what it is, but I'm honestly close to pulling support entirely.

  • As far as I can tell they migrate to the 100-1 and 101-1 servers, at least my devices are connecting to these servers. Too bad tho but I can understand. :(


    But I still think it's worth the shot because as of now almost no countries are working anymore with VPN manager. If we can connect to 100-1 and 101-1 it will be a big deal I think and everything should work again.

  • From your screen shot, they've added support for openvpn 2.3 - when LE is on 2.4 and there's probably an even later version. VPN Mgr will call whatever version of openvpn is installed, but as the openvpn team add more parameters (and take stuff away) some ovpn files will stop working.


    Surely if you move your devices away from something that appears to be for legacy support and back to the "OpenVPN Europe" servers using their website, it should all work again?


    I've DEFINITELY no interest in supporting 2.3 opvn files (if that's indeed what this means) when the world (including LE) is not going that way.


    If for some reason you want to go backwards, or use the other servers mentioned, then just use User Defined. I'm really not sure why you'd want to do this though - it's really not clear to me from their website why they have all of these different servers.


    Did I mention I hate the way Cyberghost complicate things....

  • I have reached out to CyberGhost for a statement. I hope that every users are connecting to the new 100-1 and 101-1 servers and that they support OpenVPN 2.4. That's the best-case. If not I guess CyberGhost is not supported anymore by your addon sadly, which is totally understandable.

  • zomboided any plans to make this work with kodi 19?

    Or does anyone know how to get openvpn working with balbes150 builds?

    Actually that's only half the battle cos then I need to get iplayer working too ?(

    Thanks!

  • If I understood it correctly CyberGhost technicians will update the required files by themselves and try to get in touch with you zomboided . That's not what I asked for, they are obviously doing it proactively....

  • zomboided any plans to make this work with kodi 19?

    Or does anyone know how to get openvpn working with balbes150 builds?

    Actually that's only half the battle cos then I need to get iplayer working too ?(

    Thanks!

    Not yet. My motivation to tackle a python 3 rewrite until there’s a good stable beta build is very low