VPN Manager for OpenVPN

  • Hello Zomboidded,

    What I understand is, that CG changed her servers in december 2019 en now vpnmanager is not working.

    Example new server:


    vpmanger still connect to older server:


    then u get: Cannot resolve host address:4-1-ch-cg-dialup.net (beacuse old server?)

    Then the workaround should be replacing the older server with the new on in "LOCATIONS.txt" but vpnmanger ignore this and

    still try to connect to the older server.

    I this right?

    Now the latest version of vpnmanger is: 6.3.4 and this problem is from december 2019.

    The question is will be CG be supporterd again bij vpnmanger and when and is there a better workarround?

    Thanks in advance.

  • Go read the last page of this thread and the github issue I've referenced...pretty fed up with CyberGhost, might pull it and let people manage it using User Defined.

  • avennis:

    My workaround is from this website: I will try to translate it into English: CyberGhost in Kodi installieren und einrichten (LibreELEC) – Kodi-Tipps.de

    1) Start Libreelec and activate SAMBA. Normally SAMBA is activated. If SAMBA is activated you can see a map LIBREELEC in your own network. Open this map.

    2) then go to \\libreelec\Userdata\addon_data\service.vpn.manager\Downloads\CyberGhost

    3) there you find the data "Location.txt"

    4) open this data with a text-editor

    5) Then go to Switzerland

    6) Change everything to :

    Switzerland (TCP),97-1-ch.cg-dialup.net,tcp,443,#REMOVE=1 #PINGSPEED=15 #PINGEXIT=90

    Switzerland (UDP),87-1-ch.cg-dialup.net,udp,443,#PINGSPEED=5 #PINGEXIT=60

    7) save the data

    8) For me this workaround has worked

    HOWEVER, THE CONNECTION IS INTERRUPTING THE WHOLE TIME. YOU CANNOT USE IT LIKE THIS. SO ALSO COMPLAIN TO CYBERGHOST. I Have done it, but they do not give an answer anyway. :@ Actually I watch channels like Pro 7 with "ZEPPN TV"

    Edited once, last by Bergfex2 ().

  • Hi zomboided

    I have a vpn from a friend which is his own vpn.

    Reason why is because he is cheap compared to all the big names.

    He supplies a android app and also a a config file for openvpn.

    My question is can I put this config file into your addon somehow to make it work, or is it not that easy. Thanks


  • Use Userdefined vpn. from the manager settings

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass


  • Hi!

    Is there anyone who can be kind and help me?

    Attempts to get VPN Manager to work, but gets "update-systemd-resolved: line 33: syntax error: bad substitution".

    Looked up what the error code was, and it apparently has to do with sh and bash.

    Since I am a nooby on both Linux and Kodi, and also have a severe fatigue syndrome, so i have some trouble getting it to work.

    Uses LibreELEC 9.2.

    And have tried this:

    Have run "systemd-resolve --status" and got "-sh: systemd-resolve: not found".

    Then ran "systemctl enable systemd-resolved.service" and got "Failed to enable unit: Unit file systemd-resolved.service does not exist."

    Then I tried to run "git clone GitHub - jonathanio/update-systemd-resolved: Helper script for OpenVPN to directly update the DNS settings of a link through systemd-resolved via DBus.", but then "Git" is not installed.

    Everything else works, but if you look in the openvpn log, this error comes at the end of the run of .ovpn.

    Used verbosity = 4 when I tested first time.

    Used verbosity = 4 and debug when I tested second time.






  • You’re trying to run the referenced scripts when they don’t appear to be available or properly installed on you box.

    You could try removing the up and down lines from the ovpn script but the dns might not get updated properly. Try it and see

  • Thanks so much zomboided for your answer.

    If I remove everything from "dhcp-option DNSSEC allow-downgrade" and below, my .ovpn will work without problems.

    But I want the "Up and Down" feature to work, and it doesn't if I remove the "up and down lines from the ovpn script" that you recommend.

    How should I do to make it work?

    Have tried to follow your instructions in your Wiki for "VPN Manager", but as I said it is difficult to read long instructions because of. my "problem" that I have.

    Should I install Git and follow jonathanio's instructions on his github pages about "update-systemd-resolved"?

    After all, LibreELEC is not built up as a "regular" Linux dist is, with the usual paths.

    Must make it work so that DNS is updated from the VPN server that I connect to.

    Hope to get help from someone so I can make this work.



  • I know very little abouut Linux, I don't understand why you don't uninstall the manager addon, reboot, then install it again.

    also, why don't you read the wiki on a pc

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass


  • jotakswe You're saying it works without up and down, but that you want up and down to work. But you don't want to / can't put the effort in to learn Linux (or more accurately, just enough of it to solve your problem).

    LE is a pretty closed environment. Unless you're willing to learn a lot more than you know now, or understand the errors you're getting, you're not going to get very far. I certainly don't have the time or inclination to work through everything you're asking here - all of which is outside the scope of this add-on.

    OSMC might be a better option for you (if that's still maintained?) as that's a bit more of an open distribution than LE and may even have the packages you need already installed.

  • Hello,

    Great addon, I've used it for years with very little issues. Recently, I had a problem with my own router firmware software update which broke my own vpn for a few months. That is sorted now, my phone and laptop work with the vpn again but unfortunately vpn manager won't.

    I've always used the import wizard for my user defined vpn with minimum fuss but now it wont connect and is reporting errors. Any advice please?

    Please see screen shot.

    Thank you.


    I deleted the keep alive 60 15 line from the client.opvn file and it now works.

    Hopefully this won't cause issues?

    Edited once, last by Paul_: found work around ().

  • I force ping settings into the configs (controllable by one of the advanced options) to keep the connection active when there's no work flowing. What the error is telling you is that it clashes as it does exactly the same thing. If you see the connection drop occassionally then you might wanna work out which option turns off the ping (its on the wiki) and go with the keepalive option.

  • Hi Zomboided.

    i signed up to say thanks for this great addon - i am using in CoreELEC. Also i would like to report i have got it working on user defined with Surfshark VPN, and it is working well, with HD streaming smooth as butter!

    i can share the open.vpn files for Surfshark if you want to add it to the inbuilt connections at some point, although the user defined method is working fine, so for me i don't really need it built in, but may be nice for others...

    Thanks again!!

  • Hi there,

    Great addon, since moving to LibreELEC.

    I do have a question though - is there any possibility to run a custom script upon reconnect? Would be great to know how to configure it.

    Appreciate - as the search function did not return my desired result actually.