Posts by robmcc83

    To be honest my raspian install doesn't take long to shutdown either.

    I have a smart mirror running magic mirror software and alexa on a raspberry pi2.

    This all runs on raspian stretch and if I do a shutdown on this I get the little white raspian box saying stopping services etc then it all shuts down, probably 5 seconds max.

    Maybe you have a slow sd card or are maybe wanting things instant.

    Cheers

    I hate to be the bearer of bad news but unfortunately I don't have this problem on osmc either.


    I've just put osmc on a spare SD card added my library from my samba share and the audio has not got low volume over analogue.


    Now as a long time user of LibreELEC and having tried osmc when I first started out using the pi's I much preferred LibreELEC as osmc use to crash alot with a sad face on the screen.


    I would much prefer to get to the bottom of this using LibreELEC.


    I have put my LibreELEC sd card into a pi 2 which I have from another project I made, powered it on and tried that, the audio is also low volume over analogue using the pi 2 so I very much doubt any hardware is broke.


    2 other os's don't have this problem on my pi3


    The SD card with LibreELEC also produces low volume on a pi2


    This evidence all suggest LibreELEC is the one that is causing this problem.


    My last resort is to try a fresh install of LibreELEC just incase any settings have been changed that have caused this.

    That is the last thing I can try.


    Thanks

    You do autostart scripting to make your case work, right? If my guisettings.xml don't work, deactivate the autostart scripting for a test run.

    I don't use that script any more.

    It didn't always work, it was intermittent in regards to the power led not always working as it should.


    I wrote my own script for more normal behaviour.


    I use gpiozero from the raspberry pi tools from the le repository.


    But I do have to still add a line to the autostart.sh to run the python script.


    Ill give this a try when I have some free time tomorrow.


    Thanks

    so far ive only found one solution but it creates another problem.


    if i play a movie, press ok on remote then go to audio settings, there is a option called audio amplification.


    if i turn that up to around 20.0db the movies sound about the same volume as they would if plugged into either my phone or home computer.


    Perfect seems like it solved but it isnt.


    if i then decide to turn off the external speakers connected to the analogue (for example when the kids are in bed so its not to loud) and use hdmi so that it uses my internal tv speakers, the volume is then excessively loud.


    Going back to audio settings and turning the amplification back down to 0.0db is the only way to then sort this.


    So my conclusion is that libreelec is somehow sending different volume levels to both outputs, hdmi being perfect with default settings but analogue being very low.


    Like i say my conclusion comes based on the fact recalbox's volumes work as expected wether i choose analogue or hdmi.


    Im about ready to give up on this grrrrrrrrr


    Thanks

    I found the solution to edit analogue volume. :)

    Edit the file /STORAGE/.kodi/userdata/guisettings.xml.

    Change the XML content of "audio" (bottom of the file) like this to get max. analogue volume:

    Code
    1. <audio>
    2.     <mute>false</mute>
    3.     <fvolumelevel>1.000000</fvolumelevel>
    4. </audio>

    Hi,


    having a play with this setting and i discovered all this does is change the volume of the kodi interface.


    setting it to 1.000000 only adjusts the volume to 100% within the kodi gui, setting it to 0.950000 changes the kodi gui volume to 95%


    so if i use remote to turn kodi gui volume down to 50% and then look back at the guisettings.xml the audio setting now tells me its at 0.500000


    so my conclusion is that settings is just the generic volume setting within the kodi user interface.


    As this is already 100% and i still get low volume this unfortunately does not work for me either.


    Thanks

    Did you try the USB adapter in post #9 above ?

    As the pi already has a analogue out i do not see how this would solve my problem unless the analogue out was broken.


    As the analogue out works perfect with recalbox that proves the analogue out on my pi is not broken.


    Also my pi is in a mini snes case and one of them adapters sticking out the front would ruin the aesthetics of the case.


    Thanks

    Ok, so my audio is already on 2.0


    The audio cable is pushed in all the way.


    Still the audio output volume is low on LibreELEC.


    Like I say output volume over analogue works fine on recalbox and is just as loud as expected.

    It's almost like something somewhere is not 100% behind Kodi.


    Does Kodi GUI adjust volume just for Kodi or does it adjust the volume for the line out.


    For example running Kodi on my home computer, if I set my output to say 50% in the bottom right corner of the task bar then adjusted the volume within Kodi would it adjust the volume for the audio device or just the volume within Kodi interface.


    Reason I ask this is this is what I believe to be the problem, purely because it works fine on recalbox.


    But I don't have enough knowledge to dig into LibreELEC to find out.


    Thanks

    Go to "Settings -> System -> Audio -> Audio output device" and select "PI: HDMI and Analogue".

    Proved by myself. :)

    My pi is already on this setting.

    Ive tried analogue only and Pi: HDMI and analogue.


    Both have no difference in volume for the analogue output, I still get low volume using both settings.


    Also I believe this to be specific to LibreELEC.


    Reason why is because I have another memory card with recalbox. Using that SD card on the same pI, going to settings changing the output to analogue and setting the volume to 100% makes recalbox almost twice as loud as LibreELEC.

    Its just as loud on recalbox as it is plugged into my computer or phone, just how I would expect it to work.

    When using the hdmi cable directly to my TV the volume is fine through my TVs speakers.


    Its just the analogue out that appears to have low volume but when I say low volume it really is low! I have to turn it up to full volume for it to be ok to listen, if I plug the Logitech system into other devices I get approx double the volume.


    Thanks

    Hi all hoping someone can help me here.

    I have a rpi3 b and have recently started using a Logitech 2.1 speaker set with it as modern TVs seem to have poor sound these days.


    The Logitech speakers are a set I use to use with my pc and they are loud using the computer with them.


    But plugging them into my pi using LibreELEC 9.0.2 they seem to be really quiet.


    I can confirm this as when I thought to myself "I'm sure these were alot louder on my computer" I then took the cable out and plugged it into my phone, played the same video from my Nas on my phone and boom they were a hell of a lot louder.


    I've turned the volume upto 100% with Kodi GUI but they are still no where as loud as they are plugged into other devices.


    Any help would be great.

    Thanks

    Ive always had this problem even in version 8 of LibreELEC


    Wake up some mornings and my TV would be on, on the HDMI port the pi is connected to with LibreELEC.


    I solved it by changing a setting on my TV.


    I have a lg TV and when I enable hdmi CEC it automatically enables a setting called auto power sync.

    Disabling this feature stopped the pi from waking my TV from standby permanently.


    It's never done it since

    Ok so update on this quick.


    It only does this when I disabled overscan from the config


    If I put a hashtag back Infront of the disable_overscan it doesn't appear on boot anymore.


    Only problem is I have to disable overscan for the system to fill my TV screen otherwise I get black boarders.


    Thanks