VPN Manager for OpenVPN

  • Hi


    I having some trouble connecting with VPN manager for OpenVPN.

    I have a Raspberry Pi3, installed raspbian stretch-lite with a kodi install on top of it. Also installed OpenVPN

    I know I'm not running LibreElec but i think I'm here at the right place :) hope you can help me.


    First i tried PIA with credentials from my fathers account. It connected, but didnt gave me any streams.

    When i disconnected the streams are working.


    Second i tried my ExpressVPN but gave me a messege : expressVPN requires key and certificate files unique to you in order to authenticate. These are typically called client.key and client.crt or user.key and user.crt or can be embedded within .ovpn files


    Where can i find them?


    Thnx

    Edited once, last by Markengel ().

  • Well Just read all this ...............and thanks zomboided..............gonna sell my pi 3 cos Im subscribed to ivacy and although you dislike it ...............I actually get on fine with it except here on Libreelec which isnt worth having on a pi cos I cant use my VPN. Thanks for that mate ..................

  • same her it clear the login from pia linux 64 bit

    log

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    ASRock-j5005-j4105-,Q1900M +nvidia + pulse-eight.+ tv skysytar2HD Dvbs+vpn

  • tomtomclub, the solution for trespasser was at the top of the page. Or you can read the installation page on the wiki linked from the first post.


    cle static IP is something your vpn provider provides you. Or you can run your own server and use a dynamic dns service. Either way this is not the addon that will help you

  • I have the same problem as userj. I'm using a custom .ovpn file to connect to another machine running the openvpn server but there's a DNS leak, the contents of /etc/resolv.conf doesn't change when I connect to a VPN.


    This isn't a issue with the addon (Which is great, thanks), it also happens when I call openvpn from the command line.


    Under linux I would normally put

    Code
    script-security 2
    up /etc/openvpn/update-resolv-conf
    down /etc/openvpn/update-resolv-conf

    in the .ovpn file, this normally works perfectly, however there is no /etc/openvpn/update-resolv-conf, or the associated /sbin/resolvconf file in LibreELEC. I'm using Kszaq's builds, but I understand the other builds are the same in this respect.


    Is there another way of routing the DNS through the VPN, should these files be added to the distribution at compile time, or am I missing something obvious?


    I'm in China, so a DNS leak is a real issue, as it means requests for addresses such YouTube or Google just return nothing.

  • running up and down scripts is supported - this is documented on the GitHub wiki. You can put what you need in them. They'll need to be in the addon directory structure somewhere tho, not in /etc/openvpn

  • Thanks for the reply Zomboided, I've now read the GitHub wiki and seen the up script option under debug.


    Using the example script in the wiki hasn't yet fixed my problem, and doesn't update my /etc/resolv.conf. I'm not a iptables expert, but need to learn. As a temporary measure I've written an up-script that overwrites my ISP's DNS entry in /etc/resolv.conf


    Bash
    #!/bin/bash
    tail -n 3 /etc/resolv.conf > /etc/resolv.conf
    echo "nameserver 8.8.8.8" >> /etc/resolv.conf
    echo "nameserver 8.8.4.4" >> /etc/resolv.conf

    This works for me, but I'm sure there's a more elegant method I should be using.

    • Official Post
    Code
    Slice:~ # connmanctl services
    *AO Wired                ethernet_b827ebe1571e_cable

    ^ find the active service name, it's the "ethernet_mac_cable" string.


    Code
    connmanctl config ethernet_b827ebe1571e_cable --nameservers 8.8.8.8 8.8.4.4

    ^ set nameservers

    Code
    Slice:~ # cat /etc/resolv.conf 
    # Generated by Connection Manager
    nameserver 8.8.8.8
    nameserver 8.8.4.4

    ^ connman has updated the nameserver list for eth0

  • I spoke too soon, my nameservers are now as I want in resolv.conf, however, DNS requests are going through wlan0 rather than through tun0

    Is there a way to route DNS requests through tun0 as would happen using /etc/openvpn/update-resolv-conf?

  • laowhy Can't you prevent all traffic flowing through wlan0? - google "vpn kill switch" or similar, some people have been able to get this to work so that no traffic flows if the VPN goes down. You should also look at what your VPN provider is pushing when the connection happens - it may be that they're supplying a DNS to use which is somehow conflicting. Either way, you're probably gonna have better luck in an openvpn forum

  • @zomboided I'm not sure what I've done but it's now working as it should, and the output of the route command doesn't show the DNS entries going to wlan0. I've tried recreating the earlier condition and I can't!


    If the problem returns I'll post something to an openvpn forum as it was never an issue with your app. Thanks for the great addon.

  • Can I get a video tutorial of it?

    There's no need for a video, the instructions are on the first page


    VPN Manager for OpenVPN


    If you get problems, then post back. Note, this is not a vpn, it's a manager for a vpn you have signed up for

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass

    :)

  • I use this tool from the beginning but ,

    a problem that does not work out well, kickass provider works well if you disable vpn if you turn on vpn is not showing kickass provider

    please help what can i doe

    ASRock-j5005-j4105-,Q1900M +nvidia + pulse-eight.+ tv skysytar2HD Dvbs+vpn