[8.0.2] LibreELEC 8.0 builds for MX2/G18

  • This is LibreELEC 8.0 build for MX2/G18 devices (DroidTV MX, G-Box Midnight MX2) with Amlogic AML8726-MX SoC (Amlogic Meson6).


    It is based on current LibreELEC WeTek Play build and OpenELEC port for G18 by codesnake. It is using WeTek Play LibreELEC Add-ons repository so you should be able to install binary add-ons from official repository (including PVR clients etc.).


    Warning! This build requires a storage partition with LIBREELEC_DISK label. Please read the installation instructions!


    Known issues:
    - (disabled) HDMI CEC does not seem to work
    - there is no Docker support


    Fixed issues:
    - (fixed 2017-02-16) update from LibreELEC is broken (you won't be able to update from LibreELEC, you'll have to do the next update from recovery)
    - (fixed 2017-02-16) some remote buttons don't have any action assigned by default


    Installation instructions:
    Starting from version 8.0.0 this build requires a storage partition with LIBREELEC_DISK label. You can choose whether you keep using internal NAND memory or you create an external storage partition on SD card or USB drive. As MX2/G18 devices are getting older there is a number of reports with NAND flash wear-out symptoms. By allowing the usage of external storage we can make devices with broken NAND memory fully usable again.


    Updating exisiting installations:
    Run the following command on SSH before updating to 8.0.0 to set the label of your internal NAND storage partition. Then you can update from tar as usual.

    Code
    1. tune2fs -L LIBREELEC_DISK /dev/data


    New installations from recovery:
    You will need an ext3 formated SD card or USB drive with LIBREELEC_DISK label for the first boot. Then you can change the label of internal NAND storage partition as described above if you want to use it instead of the external storage. The rest of the installation process is the same as usual (install-openelec-xbmc-g-box-mx2).


    Storage:

    Since many people seem to have problems creating the storage partition with LIBREELEC_DISK label, I have created an empty storage image (storage.img.gz). Just download the image and use LibreELEC USB-SD Creator to write it to SD card or USB drive.


    Download (updated 2017-07-25):
    storage.img.gz (empty external storage image)
    LibreELEC-Amlogic_MX2.arm-8.0.2.tar (for updating exisiting installations)
    LibreELEC-Amlogic_MX2.arm-8.0.2.zip (for new installations from recovery)

    LibreELEC-Amlogic_MX2.arm-8.0.1.tar (for updating exisiting installations)
    LibreELEC-Amlogic_MX2.arm-8.0.1.zip (for new installations from recovery)
    LibreELEC-Amlogic_MX2.arm-8.0.0.tar (for updating exisiting installations)
    LibreELEC-Amlogic_MX2.arm-8.0.0.zip (for new installations from recovery)
    LibreELEC-Amlogic_MX2.arm-7.95.3.tar (for updating exisiting installations)
    LibreELEC-Amlogic_MX2.arm-7.95.3.zip (for new installations from recovery)


    Sources:
    I wanted to keep it as simple and clean as possible so for now everything needed is in projects/Amlogic_MX2/. You need to extract included .tar.gz to upstream LibreELEC sources and run PROJECT=Amlogic_MX2 ARCH=arm make amlpkg to build this.
    Amlogic_MX2-8.0.0.tar.gz
    Amlogic_MX2-7.95.3.tar.gz


    Supported devices:
    It is tested on DroidTV MX and G-Box Midnight MX2. Both have the same IR remote (see the pictures). If your device has different remote try connecting USB keyboard.

    Edited 4 times, last by KOPRajs ().

  • Hi,
    the build seems to work fine for me so far but I've just discovered that the update from LE is not working so you won't be able to update to the next version using the .tar method. I'm working on a fix.

  • I've uploaded a new version. Update from LibreELEC now should work as expected and remote buttons mapping is fixed. HDMI CEC seems to be broken and I'm not able to fix it so I've disabled it.

  • I cant seem to get this to work it loads np but as soon as I add my backup it reboots and hangs.Tried it on a gbox mx2 and a knockoff mx2 same thing.Now I noticed on my qbox I get the same results but if I use kodi 17 alpha it loads and works perfect maybe its the version of kodi that's causing the issue not sure
    [hr]
    this is the version that works for me


    kodi-17.0-Krypton_alpha3-armeabi-v7a.apk

    Edited once, last by piperider ().


  • Hello,
    I have an old Xtreamer Mk4 which is now dead as I tried to install an OE from zip file via built in recovery. It restarted after install process and now it freeze at boot with an OE splash picture...
    It had no any reset button but it's a 8726mx device.
    Is there any way to install this LibreElec build somehow?
    Hope is alive!


  • I cant seem to get this to work it loads np but as soon as I add my backup it reboots and hangs.Tried it on a gbox mx2 and a knockoff mx2 same thing.Now I noticed on my qbox I get the same results but if I use kodi 17 alpha it loads and works perfect maybe its the version of kodi that's causing the issue not sure
    [hr]
    this is the version that works for me


    kodi-17.0-Krypton_alpha3-armeabi-v7a.apk


    It ran once for me then after rebooting it hung up on the boot screen on my gbox mx2, tried reinstalling an older working version I had on previously and it does the same thing now. Really don't know what to attempt next.

  • Hi,
    I have tried several times to install version and always stuck on Welcome page :(
    Do you know how can I pass this phase ?
    Cheers

  • No way to run this from SD Card? I might need to try find a backup of my android firmware otherwise, I have an ehome/Allcam MP02 stick with a 8726 M3 and 1GB ram (Android 4.0), I'll do some hunting for the firmware.


    The board is branded Infinitec so I think I have a rebranded Infinitec PocketTV 1000, the board is also marked TB168_v2.0 rather than HD18 that I was expecting, the mystery continues. Mine is also supposedly 1.2ghz not 1ghz like the PocketTV 1000.


    Looks like mine is a F16ref which is a 8726 - M3 single core, I'm presuming there's no chance this would work or can be easily adapted?

    Edited once, last by michael123 ().

  • I just did a clean install of this on one of my MX2s laying around collecting dust, I can not change the skin, I can download them out of any repo however I can not switch from the default skin. Is it me?

  • I would do a clean install. I did that on one of my boxes and everything seems to be working fine so far. I have the matricom mx2 box


  • I cant seem to get this to work it loads np but as soon as I add my backup it reboots and hangs.Tried it on a gbox mx2 and a knockoff mx2 same thing.Now I noticed on my qbox I get the same results but if I use kodi 17 alpha it loads and works perfect maybe its the version of kodi that's causing the issue not sure
    [hr]
    this is the version that works for me


    kodi-17.0-Krypton_alpha3-armeabi-v7a.apk


    I'm not sure what are you talking about but the apk file you mention is for Android. This is a LibreELEC build. It has nothing to do with Android. Are you trying to restore your Android backup in LibreELEC? This will not work. You can try to export your media library from Kodi in Android and import it in LibreELEC if needed.
     


    I can't seem to find any info about your device. Is it really Amlogic 8726-MX device? If so are you sure there is no reset button? It seems to be hidden in AV jack on many devices. Anyway only G18 reference board based devices are supported by this build.
     


    It ran once for me then after rebooting it hung up on the boot screen on my gbox mx2, tried reinstalling an older working version I had on previously and it does the same thing now. Really don't know what to attempt next.


    Any error messages on the screen? Have you tried to do a factory reset or complete reinstall from recovery?
     


    Hi,
    I have tried several times to install version and always stuck on Welcome page :(
    Do you know how can I pass this phase ?
    Cheers


    What device do you have? You can try to plug in an USB keyboard if your remote does not work out of box?
     


    No way to run this from SD Card? I might need to try find a backup of my android firmware otherwise, I have an ehome/Allcam MP02 stick with a 8726 M3 and 1GB ram (Android 4.0), I'll do some hunting for the firmware.


    The board is branded Infinitec so I think I have a rebranded Infinitec PocketTV 1000, the board is also marked TB168_v2.0 rather than HD18 that I was expecting, the mystery continues. Mine is also supposedly 1.2ghz not 1ghz like the PocketTV 1000.


    Looks like mine is a F16ref which is a 8726 - M3 single core, I'm presuming there's no chance this would work or can be easily adapted?


    This build is tested to work only on G18REF based devices with Amlogic 8726-MX SoC. That is because it is based on original WeTek Play build. I'm not planning to make it work on F16REF with Amlogic 8726-M3 SoC, sorry.
     


    I just did a clean install of this on one of my MX2s laying around collecting dust, I can not change the skin, I can download them out of any repo however I can not switch from the default skin. Is it me?


    I've only tried to change to Confluence and it worked as expected. Are you using Krypton compatible skins?
     


    Can we update to this built from OE?


    Yes, it should work but I haven't tested this yet.
     


    I would do a clean install. I did that on one of my boxes and everything seems to be working fine so far. I have the matricom mx2 box


    Great to hear that it actually works for someone. Thanks for the report.

  • Installed this on my mx2 and it gets stuck on the welcome screen at first. If i power the box off and back on i get the matricom logo and a flash of code then a screen that says files corrupted. I've tried doing a clean reinstall and I've tried to downgrade and it won't boot from an SD if it's an older version. Help please

    Edited once, last by MR.E ().


  • Installed this on my mx2 and it gets stuck on the welcome screen at first. If i power the box off and back on i get the matricom logo and a flash of code then a screen that says files corrupted. I've tried doing a clean reinstall and I've tried to downgrade and it won't boot from an SD if it's an older version. Help please


    Can you post a screenshot? Or a copy of what exactly is written on the screen? What files are corrupted? Have you tried to reinstall from recovery?

  • Compatible whether tbs-linux-drivers?
    for tvheadend
    built-in dvb-t2 tuner mxl603 , g18ref devices Gi Fly T2.


    tnx


  • Compatible whether tbs-linux-drivers?
    for tvheadend
    built-in dvb-t2 tuner mxl603 , g18ref devices Gi Fly T2.


    tnx


    I can't test it on such device however it is unlikely that the internal tuner and the remote will work out-of-box, sorry.