[7.0.3.012l] LibreELEC 7.0 for S905/S905X


  • MiniMx 2g/16g S905 Non Branded Beelink
    LE Internal 7.0.3.012f


    kszaqI updated to f version NOT THE VERSION WITH TEMP DISABLED.
    Because i was reading #670 wkchick
    I have working Bluetooth and instant wifi hook up no toggling.


    I am not sure but i have done 35 Re-Boots and Power off/on with this Temp Sensor ENABLED Version and
    I cannot get a Freeze.


    It would be great for other members with s905 Chip boxes to try the standard "F" version in comparing results.


  • Haven't been posting much but have been reading the posts. 012f failed to boot on the 9th reboot, this is a major improvement as with past builds it never went above 3 reboots.


    I have on very rare occasions seen my box freeze even with the temp sensor disabled builds, such was the case when trying to flash F with sensors enabled, had to pull the plug for the update to kick in. So it could be my box just has issues, i have tinkered and even opened it.


  • Testing 12f (no temp disabled) on mini mx 1GB/8GB rom and seems to work fine after several reboot/power off..weird! what changed?
    Can confirm also BT/WiFi works fine.
    I'm gonna test longevity on the long run with this one build
    thanks Kszaq/KostaMan

    Edited once, last by stormrev ().


  • I am not sure but i have done 35 Re-Boots and Power off/on with this Temp Sensor ENABLED Version and
    I cannot get a Freeze.


    Now calm down Kostaman, heed these earlier words of yours . . .


    We've all fallen for that reoccurring devil bug appearing. I mistakenly flashed non temp disabled on my MiniMx 2g/16g and didn't realise for 2 days until it froze on bootup.


    Seriously though, something does seem to have changed.
    I presumed with the 8.0 builds it was something to do with the progression to kodi 17.0rc4. Not sure what might have changed with the 7.0 builds though. Perhaps a change in the boot order might have allowed us to get past the temp sensor initialisation :s
    Looking good anyhow :D

  • I have a Mini M8s 2/16 905x and I'm booting from Sd card the newest "f" version with temp sensor enabled.
    I have had no freezes, BT and wifi working fine.
    The box is connected to my TV Panasonic 58dx780 and 4K and HDR are working great, CEC too. The only thing that doesn't work are 3D isos, I mean they work when played in 2d mode but when I select 3D the screen goes black and stays that way until I press stop.

  • #1


    I have opened a new thread for this testing s905 chip boxes.
    Easier to keep it under control and compare results.


  • Been lurking for a while enjoying the software!


    Re Dolby Digital Plus I can confirm no sound with both a Beelink MiniMX III (S905 2g/16g) and my new Beeling MIniMX III II (S905X 2g/16g) from 7.0.3.011 up to and including 7.90 beta 3 with pass-through to my Yamaha RX-VX675 amp. It seems odd that only 'richdtv' and myself have reported it - anyone else?

  • Short question kszaq:
    Aren't you updating the version numbers? Although I updated to version 'f', it still states 'c'?

    Code
    LibreELEC:~ # cat .kodi/temp/kodi.log |grep 7.0.3
    01:04:43 T:4111888960  NOTICE: Running on LibreELEC (community) - Version: 7.0.3
    .012c, kernel: Linux unknown CPU family 64-bit version 3.14.29

    * s905x, 2/8GB, Coreelec 9.2.1
    * RPi3, LE 9.2.0, GPIO IR
    * Server, kodi-headless, MySQL, VDR, NFS-Server (& much more)


  • The ability to bitstream Atmos and DTS:X is what keeps me hooked on this development thread.


    Do you mean that LE sends Atmos and X (instead of TrueHD and HD-MA) to your AVR?
    I don't have a Atmos\X capable AVR (nor I plan to upgrade my 5.1 system in the near future) but it's good to know how LE works with those streams.


    BTW, I tested Atmos with an earlier Jarvis build and X with Krypton beta1.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • Been lurking for a while enjoying the software!


    Re Dolby Digital Plus I can confirm no sound with both a Beelink MiniMX III (S905 2g/16g) and my new Beeling MIniMX III II (S905X 2g/16g) from 7.0.3.011 up to and including 7.90 beta 3 with pass-through to my Yamaha RX-VX675 amp. It seems odd that only 'richdtv' and myself have reported it - anyone else?


    got sound (Dolby Digital) only when uncheck E-AC3 capable receiver in system/audio settings
    mini m8s II 2/8 but i'm still on 64 bit 012 version

  • Does anyone know which device tree to use for M8S+ S905. This one or something else?
    gxbb_p200_2G_m8s+_k3_pro.dtb


    Thanks. [emoji1]

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().

  • Been lurking for a while enjoying the software!


    Re Dolby Digital Plus I can confirm no sound with both a Beelink MiniMX III (S905 2g/16g) and my new Beeling MIniMX III II (S905X 2g/16g) from 7.0.3.011 up to and including 7.90 beta 3 with pass-through to my Yamaha RX-VX675 amp. It seems odd that only 'richdtv' and myself have reported it - anyone else?


    I can confirm both files play fine and my denon receiver shows on the display the audio type that is being streamed.


    I think from the first release of this build pass through has worked brilliantly for me. I was previously using a Pi 3 but lost the ability to bit stream Atmos and DTSX.


    The receiver shows the text DTS-HD MA, ATMOS, DTS:X MA depending on the audio stream that I wanted to support the ceiling speakers. I run a 5.1.2 setup so basically 5.1 with the additional two ceiling speakers.


    My device purchased is
    Nexbox A95X Amlogic S905X 2G DDR3 RAM 16G eMMC ROM Android 6.0 2.4G+5.0G Dual Band WiFi 4K 60fps Kodi 16.1 Bluetooth 4.0 HDR VP9 H.265 HEVC Android TV Box Mini PC


    Really think it's great. Picked it up for a steal before Christmas Holl's.


    On the settings I enable pass through and then all of the 5 options below are checked.


    Thanks


  • I tested the sample files with 32bit Jarvis 011, 012d, 012f and Krypton Beta1 and Beta4.
    All versions send DD+ to my Onkyo AVR. It takes a couple of seconds for the AVR to pick up the signal but otherwise the sound is fine.

    Running kszaq's LibreELEC 8.2.2.3 and adamg's LibreELEC 9.x 1.0.6 on Cooleme MB1 (S905X - 2GB/8GB)

  • Testing 12f (no temp disabled) on mini mx 1GB/8GB rom and seems to work fine after several reboot/power off..weird! what changed?
    Can confirm also BT/WiFi works fine.
    I'm gonna test longevity on the long run with this one build
    thanks Kszaq/KostaMan


    update: tested with temp sensor enabled 3 full-hd movies in a playlist, found it stuck on picture, frozen, after ~3 hrs.
    the box was still reachable via ssh. I had to restart kodi to recover since the gui was unresponsive :(

  • Installed 7.0.3.012f on H96 Plus 2GB 16GB Android 5.1 box using SD Card. No problems. Could not load any builds as it would freeze. Tried loading repos instead then the addons I wanted and no problems. Working like a charm. Thanks team.

  • OP updated with 7.0.3.012g build


    What changed from 7.0.3.012f:

    • more fixes to non-working Broadcom BT
    • added a patch from meijjaa to fix non-working AP6212A BT
    • media_build drivers updated to latest upstream version (2017-01-22)
    • added an udev rule for QCA WiFi to solve non-working WiFi on boot and not break it for others
    • last try of Kodi vq patch amendment


    The last point means that if there are still issues with Live TV that are not present in previous 012 series builds, I will give up and revert to stock Kodi Jarvis code.