[7.0.3.012l] LibreELEC 7.0 for S905/S905X

  • Report : Im on mxqpro4k 1g ram, originally android 6.0.1 build mxpq10005 kernel 3.14.29it01ubuntu (dont know more detailed info)


    Test with 012 with temp disabled on usb flash.
    I experienced random freeze on it, sometime it wont boot ( just reboot to droid itself), Will report more with non temp disabled...


    Ps: my box and usb is fine...
    trial other version on the same usb and box
    009 ok...just cant installtointernal.../dev/system not found..got lazy to read and running on usb now, no random freeze
    008 no analog audio output but no freeze

  • Sorry for the very newbie question, but I am not that familiar with Libreelec.


    I was running the alpha 7.90 alpha build for the S905, and I updated the retroarch addon provided by Jokerz and it worked perfectly. But I have a few problems with the alpha build.


    Now when I go back to this version and I run the same exact add-on I get this error: "error while loading shared libraries: libavcodec.so.57" is there a way I can install those libraries to this build of Libreelec or do I need to keep using the alpha build?


    thank you!

    Edited once, last by niabi ().

  • OK people am I missing something?


    I have just ordered a new box for someone and he will use it with USB external drives, no network in the mine sites :)


    Built and tested to sdcard, then to nand, all looks good, but when I then try to add a usb drive 1tb wd usb3 nothing , the unit has 2 slots and neither of them work, they DO work when using the supplied android image, but not on LE !!


    any ideas? yeah I also tried 4/32 usb 2 sticks as well

    3 NUC's, 3 Pi's, Android Beelink R38, Odroid C2, 2 original XboX's and now a Amlogic T95m S905 2/8


  • Built and tested to sdcard, then to nand, all looks good, but when I then try to add a usb drive 1tb wd usb3 nothing , the unit has 2 slots and neither of them work, they DO work when using the supplied android image, but not on LE !!


    Non Compatible Device Tree would be my first guess.

  • Non Compatible Device Tree would be my first guess.


    I used the same one I have all along, the generic gxbb_p200_2G_100M


    The unit is a Sunvell T95m 2/8 100 unit


    OK, used one of the 'x' versions as the blurb now says this is a S905X !! and it works


    Appreciated my man

    3 NUC's, 3 Pi's, Android Beelink R38, Odroid C2, 2 original XboX's and now a Amlogic T95m S905 2/8

    Edited once, last by silashack ().


  • Do the skins classify as Add-ons that need to be re-installed after updating from 64 to 32 bit?
    Everything seems to be working fine. I use the box only for movies, so I don't have any DVR add-ons. My weather updates fine and Library Watchdog seems to be working.


    No, skins don't have to be updated. Only binary addons, which means most of addons from LE repo.


    Also, does this release fix the issue where the audio is out of sync on some movies? I have to move it to -0.250ms every time and it's fine.


    The fix may be a side effect of a corrected buffering patch. ;)


    I was running the alpha 7.90 alpha build for the S905, and I updated the retroarch addon provided by Jokerz and it worked perfectly. But I have a few problems with the alpha build.


    Now when I go back to this version and I run the same exact add-on I get this error: "error while loading shared libraries: libavcodec.so.57" is there a way I can install those libraries to this build of Libreelec or do I need to keep using the alpha build?


    You cannot downgrade from LE 7.90/8 to 7. If you did this, that may be the reason for not working shared libraries.

    Edited once, last by kszaq ().

  • Thanks to DEcosse and kostaman my Android TV Box is now running LibreELEC from internal memory, I have now noticed that the refresh rate now works as 24fps content now plays in 24p mode, when on Android it would not switch to 24p.


    Thanks guys


  • . . . running LibreELEC from internal memory . . .


    So SD card / USB install wouldn't work for you?

    Edited once, last by Poida ().

  • report on non temp disable
    mxqpro4k s905 1gram
    work better than disabled temp sensor (strange, maybe my flashdisc is too old) , boot via usb ..booting longer than other version but it boot and very few freeze (non respond remote..delayed respond maybe). Most of the time it had to boot on cool boot, reboot via ssh and powercycle using remote boot to android.
    Trying to insstalltointernal via ssh but it wont install...on usb version now...android seems to be intact (droid 6.1)
    Anyone advice any procedure I should do to flash my nand ?


    I notice remote is (original remote and original remote.conf from android) has vew glitches
    vol up vol down error on 012, temp disabled and regular version
    simple fix is change 0x18 115 for vol+ 0x10 114for vol-


    And funny thing is...my lg tv remote can power on (only) thr mxq box using ok button, cheers


    Thanks Kszag

    Edited once, last by mxlibre ().

  • I have identified an issue that prevents some BT chips from working in 32-bit build. I have a fix for this, will do some tests and hopefully publish a new build quite soon.

  • Yeah it was running from SD cardf, but the SD card was slow so I use the SSH installtointernal command to run it from internal. It works perfect.


    What do you mean by "slow"? How is it shown?
    I have a SD card with a read/write speed of 90/45 MB/s, no friezes, all very smoothly :)

    Khadas VIM1, 2/8 GB & Nexbox A95X-B7N s905x, 2/16 GB

  • What do you mean by "slow"? How is it shown?
    I have a SD card with a read/write speed of 90/45 MB/s, no friezes, all very smoothly :)


    i think its an old SD card, it seemed slower to boot from SD than internal.
    [hr]

    The previous problem was because of wrong device tree or reset switch not working or any other else? How about WiFi and Bluetooth, are they also working?


    Thanks.


    Using LAN cable, but WIFI signal shows up, not tested bluetooth yet

  • Bluetooth and CEC work flawlessly on the Nexbox A95X s905x 2/16 GB (7.0.3.012a clean install).

    Khadas VIM1, 2/8 GB & Nexbox A95X-B7N s905x, 2/16 GB

  • Just upgraded my Nexbox A95X s905x 2/16 GB
    Upgrade from 7.0.3.11 went flawless (just like any previous updates) and never had any boot issues.
    Almost everything is working fine, just that DD7.1 audio is out of sync in, needed to adjust 0.275 to get it in sync.


  • Thanks for the reply, I did a fresh install on the SD (setting up the SD with Rufus), is that considered a downgrade?