RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Hi escalade, I've noticed es_systems.cfg is not looking for PSX images in "pbp" format:
    <extension>.cue .tok .m3u .ccd .exe</extension>


    Just to inform that I've added the format and it works great:


    <extension>.cue .tok .m3u .ccd .exe .pbp</extension>

    Edited once, last by jtadeia ().

  • I use psxrearmed on x64 just use the retroarch online updates to install cores. I also change quite a few cores around to suit my needs its a personal preference.

  • Are you able to mount shares ?


    If I run the command manually it works:


    mount -t cifs -o user=guest,pass= //192.168.0.15/Armazem/Emulators/RetroPie /storage/Armazem


    But if I create the mounting file, it doesn't work:


    LibreELEC:~/.config/system.d # cat storage-armazem.mount
    [Unit]
    Description=cifs mount script
    Requires=network-online.service
    After=network-online.service
    Before=kodi.service


    [Mount]
    What=//192.168.0.15/Armazem/Emulators/RetroPie
    Where=/storage/Armazem


    Options=user=guest,pass=
    Type=cifs


    [Install]
    WantedBy=multi-user.target


  • is it case-sensitive? storage-armazem.mount vs /storage/Armazem

  • is it case-sensitive? storage-armazem.mount vs /storage/Armazem


    jaykass, thanks again for your help. I'm almost embarrassed of this last question :)
    Renaming the file to storage-Armazem.mount didn't work, but creating the folder /storage/armazem worked great.


    Almost everything set now, all emulators running great from NAS.
    Next step will be to figure out how to work with the controls (DS4 and 8bitdo).


    Cheers..

  • jaykass, thanks again for your help. I'm almost embarrassed of this last question :)
    Renaming the file to storage-Armazem.mount didn't work, but creating the folder /storage/armazem worked great.


    Almost everything set now, all emulators running great from NAS.
    Next step will be to figure out how to work with the controls (DS4 and 8bitdo).


    Cheers..


    No worries. When I first setup my automounts I got stuck on an equally embarrassing/simple issue that took me a couple hours to figure out. :(

  • New build 20161003:


    - Vulkan support for Dolphin
    - Linux 4.7.6
    - Fixed launching FBA roms in Emulationstation
    - Added .pbp extension for PSX roms in Emulationstation
    - Updated to latest git of RetroArch

  • When updating to new build, will I lose any configurations?
    - emulationstation config files?
    - retroarch config files?
    - Shares?
    - Audio configurations?
    - symbolic links? (I have all my roms / gamelists / image covers in my NAS)


    Thanks escalade

  • jtadeia


    No.


    New build 20161004 incoming:


    - Linux 4.8
    - glupen64-libretro updated to 1cc75f9
    - dosbox-sdl updated to r4000
    - scraper updated to 1.1.10
    - SDL2 updated to 321fdcc from unofficial github mirror
    - mesa updated to 338d3c0

  • I'm having some troubles configuring my gamepads (Bluetooth).
    I'm using "8Bitdo_Pro_NES30_BT(POWER).cfg" and "8Bitdo_Classic_NES30_BT(START).cfg" which both have configuration files.
    One of the issues is that Classic NES30 is detecting two keys whenever I press "A" button, I found a workaround for this, it works fine if I remove all the mappings from /tmp/autoconfig/udev/8Bitdo_Classic_NES30_BT(START).cfg
    This means Retroarch is not using "only" the above file to map the gamepad keys.


    My question is, from where is retroarch primarily taking the button mapping configurations ?
    The following directories are empty, there is no cfg files here:
    input_remapping_directory = "~/.config/retroarch/remappings"
    "~/.config/retroarch/config/remaps"


    Also, would it be possible to install something like jstest script? To test/check the key numbers associated to joystick buttons?


    Thanks

    Edited once, last by jtadeia ().

  • First of all. Completely new to the Linux OS and I'm far enough out of college I've forgotten most stuff regarding programming. That being said, I'm having issues installing and using this. After downloading the .img file I can successfully get the image onto my flash drive (using Win32DiskImager under Windows 10). when I place the drive into my computer and set USB to boot I can even get the OS to run from the flash drive. However, I can't seem to get a successful install on the HD in the computer. After running the installer I reboot as it tells me to after removing the media. When it tries to load the OS from the HD I get the error:
    No DEFAULT or UI configuration directive found!
    If i then type KERNEL it starts to load then stops with:
    *** Error in mount_flash: mount_part: Unknown filesystem ***


    What do I need to do to install on a freshly built computer? (of older parts: Core2Duo, Gigabyte P35C-DS3R, 4 gigs ddr3 ram, 8800 GTS 512)


    Thanks.


  • Do you have enough space in the flash partition ? For troubleshooting this issue, you can try to install the latest official LibreElec/OpenElec and then upgrade to LE8 "Extended" (simple by moving the TAR file into "Update" folder).
    If you don't have enough space, the error will be clear when trying to update.

  • jtadeia


    Joystick autoconfiguration files are in /tmp/autoconfig as defined by joypad_autoconfig_dir in retroarch.cfg. The remapping directory is where your custom remappings from the menu will be saved. There is only what's defined in retroarch.cfg. Only one key is detected when pressing a button here, so you probably messed something up. I'll include jstest in the next update.


    TKESlinky


    Let me guess, Chromebox? There's been a whole bunch of people (just search for your error in this thread) with the exact same issue. They all had a Chromebox for some reason and the solution was always to resize the first partition. I'm guessing you had an older OpenELEC version installed that set up a 256MB /flash partition, which is no longer sufficient. You could also wipe your partition table and do a clean install that way.

  • escalade


    No to Chromebox. Box previously had Win7 on it. ~300GB HD was partitioned to ~200GB for system and ~100GB for storage. Originally used .img from 16/09/30 via USB. .img from 16/10/04 wouldn't install either (This one also wouldn't boot from USB stably. It kept freezing and creating graphic anomalies). Dropped HD into one of my Windows computers and Disk manager said 512MB primary and 292GB secondary partitions. Deleted both and did a quick format.
    Downloaded OpenELEC generic trying to get something working from HD. It installed, but wouldn't run. Kept giving error about unable to load Xorg and stated: Is your graphics card supported?
    Next, Downloaded and installed OpenELEC Generic Legacy. Everything went well except for a few times it froze.


    jtadeia


    Think I might have sorted out the error with Flash partition size via the above steps.
    I'd love to get LibreELEC running on it now, but not sure how to place the .tar in the Update folder. Was going to use copy command via ssh, but can't get any command to report back on disk layout. Can't copy if you don't know what the OS is labeling drives.


    OK, think I figured it out. Gonna try via SAMBA shares.


    Well, that didn't work either. Got an error that there wasn't enough space. Using Gparted now to increase the size of the system partition from 512MB to 1GB. Is this drive going bad??


    After the resize, dropping the LibreELEC.tar from 16/09/30 into the update folder and rebooting appears to have worked. It is functioning atm, but only time will tell on its stability. Thanks guys.

    Edited once, last by TKESlinky ().


  • I tried the last thing u tried, but my my "drive went bad", I think something happened to my boot files when I used gparted so it didn't boot libreelec.


    But it worked for you so I will give it a new try :)

    Chromebox Libreelec Kodi 17.6, Chromebox Libreelec Kodi 18.6, PC Windows 7 Kodi 17.6, PC Windows XP Kodi 15.2, Raspberry Pi 3 B+ RetroPie Kodi 16.1, Ugoos X2 Cube Coreelec Kodi 18.6

  • I don't quite understand why people are having this issue. Wiping the disk and installing clean should get you a 512MB /flash which should be enough.