RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Installed the latest generic image on my NUC (its an 8th gen i3). I get no sound in Kodi. Initially when i was messing around with it my audio choices were:

    Default,Default output device(pulseaudio)

    Built-in audio Digital stereo, hdmi(pulseaudio) <-- or something like that, I can't remember exactly now because currently it doesn't even let me go into the audio choice, its greyed out. When i was able to select an option neither one gave me gui sounds. Seems after attempting to play a video which didn't play audio it doesn't let me select anything anymore.

    No idea what else to provide info wise right now but here is my debug log after a fresh restart.

    External Content
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    So i decided to try to run a ROM in ES. It played with audio. Went back into Kodi and now the audio setting is no longer greyed out AND audio is working both in GUI and also in a movie. Reboot the NUC and no audio again and setting is greyed out.

    Edited once, last by pletopia ().

  • I've been toying with this on an XU4 and have a couple of issues.

    1. Firstly, out of curiosity, what is the difference between the builds? RetroELEC-OdroidXU3.arm-9.2-devel-20200312212432.img.gz didn't work for me at all (wouldn't boot, not output from HDMI port), though RetroELEC-OdroidXU3.arm-9.2-devel-20200309122419-251e0c5.img.gz works fine.

    2. More importantly, AutoFS doesn't seem to be working, as the /auto directory doesn't seem to exist! I got round this but manually mounting my NFS share, though I can't seem to edit /etc/fstab to add it permanently.

    3. On a similar note, I can't modify the emulationstation settings - when I open es_systems.cfg in nano, it says at the bottom [ File '/storage/.config/emulationstation/es_systems.cfg' is unwritable ]. I was under the impression that everything within /storage is not read only?

    Any help would be appreciated! :)

    Edited 2 times, last by tommitytom ().

  • I would like to mount stuff NOT to /auto but rather place my rom's folder stored on my NAS via NFS onto /storage/roms

    Can I do this?

    Also, first post about how to use AutoFS doesn't work.

    bedroom:~ # ls -l /auto/nfs/

    ls: /auto/nfs/ No such file or directory

  • New generic build uploaded:

    • 5.6.2 kernel
    • Latest Mesa git has performance improvements for Intel
    • Samba 4.12
    • Qt 5.15 beta2
    • Latest Lavalauncher git handles scaling (for 4k users)
    • Added 4k icon that switches between 1080p/4k with scaling
    • Sway and all components updated and polished
    • Improvements to Plymouth boot splash handling (now respects video= kernel command line option)
    • Latest Kodi Leia git
    • Pulseaudio fixes


    See if the latest solves your audio issue. As for AutoFS, I've changed it to /net which is the more common place to have it I will update the first post. You can configure it manually through /storage/.config/autofs, or set up your own NFS mounts through systemd or for example.


    1. I haven't kept track of the changes so couldn't tell you. Use what works for you, I'll update the XU4 image soon with my latest tree.

    2. AutoFS is in /net now. There's no fstab, use systemd through /storage/.config/system.d or

    3. es_settings.cfg is symlinked to /usr/share/emulationstation/es_settings.cfg, remove the symlink and copy it over if you want to make changes. This is done so I can maintain a configuration that works for everyone. If you change it then it's up to you to figure out why cores don't work anymore when they change name for example (happens from time to time).

  • escalade

    I don't know if you recall, a while back I was having a great deal of trouble installing your generic build on my pc (which I plan on replacing soon by the way thanks to your advice). Well on a whim yesterday I decided to try again and just wanted to let you know that whatever issue I was having with the install has been fixed. However I do have a question. Looking to add the ECWolf core, found it and downloaded on the retroarch website does it just need to be dropped in the retroarch cores folder as I have done? Have not gotten a chance to see if it works yet, just wanted to know if I was on the right track. Thanks for all your hard work with this.

  • Loaded this image on my NUC: RetroELEC-Generic.x86_64-9.2-devel-20200406011507.img.gz

    Still no audio on loading Kodi. Was gonna try the same thing I did with previous build of starting ES and then going back into Kodi as that works to enable audio in Kodi however ES starts and I get an error "Can't find any systems! ..." when it starts. Quits to a desktop and then loads up again with same error message.


    I tried this image now: RetroELEC-Generic.x86_64-9.2-devel-20200406103004.img.gz and still same thing. When you start up ES you get an error "Can't find any systems!...".

    Unfortunately I deleted my March build image so I can't go back to that X/

    Edited 2 times, last by pletopia ().

  • Logs please. You guys might need to set the default card, sink or maybe port in Pulseaudio.


    That's how Emulationstation behaves until you add ROMs :)

    New images uploaded for every target:

    • Mesa updated for the latest performance improvements.
    • Linux 5.7 from torvalds' tree has the new exFAT driver from Samsung and Zstd compression for F2FS.
    • Latest Sway git + more polish (now shows resolution in the top bar)
    • Qt apps should now look like the GTK default (Adwaita)
    • Added Discord support to RPCS3
    • WayVNC is included # systemctl start wayvnc to run it
    • Samba 4.12.1
    • Latest SDL2 git

    Firefox 75 now has VAAPI support (before X11 too!). At this point only works for H264, so you might consider adding the h26ify to enjoy HW accelerated youtube. Firefox 76 should enable it for all formats I think.

  • Will give this one a whirl. I'll add a rom of some sort. Previous builds I guess you added something under Amiga and I never saw that screen before.

    As for audio. Can you explain a bit more how to do that? Also I was reading through old posts regarding audio in this thread. I know at one point you had it configured to actually use ALSA for Kodi but pulse audio outside of it. I normally use ALSA on other builds but i've seen posts here that with some config you can actually do passthru audio via pulseaudio. That would be something I want to do also but I couldn't find a good post on how to accomplish this.

  • On the very first run on a new install there will be an under amiga just to get ES started (look at /usr/bin/ which is started by /usr/lib/systemd/system/es-firstrun.service). ES is somewhat user-unfriendly in matters of getting it up and running, but once it's set up it does a good job of actually launching games and presenting them in a clear way.

    Ok, I'll explain a bit about how I intended audio to work as it doesn't seem to automagically work for everyone like it should.

    Normally, Kodi is run either with sound output to either Pulseaudio or directly to ALSA. LibreELEC patches Kodi in order to use ALSA, but also keep Pulseaudio available as a choice in order to use Bluetooth speakers. When using ALSA, it's easy to pick an output from the list that appears in Kodi. When using Pulseaudio, Kodi doesn't have functionality to show available sinks, cards, ports etc.

    You can get it to behave like vanilla LibreELEC if you like, by setting the environment variable KODI_AE_SINK=ALSA+PULSE in /storage/.config/kodi.conf.

    Now why don't I just keep that as a default? Well, if you would like to use emulators then most likely you would need to tailor an asound.conf in order to get audio as well. In other words, some manual setup will be needed either way. On the plus side, once Pulseaudio is set up properly you will be able to have sound in Kodi without it locking the sound card. This way you can for example stream A2DP music from your phone and at the same time have GUI sounds in Kodi, or even watch a movie. Same goes when using emulators. I think the best solution is to have Pulseaudio working correctly.

    So... this might sound overcomplicated and you just want to have sound. I get it, the process could be a lot simpler. Basically, you need to tell Pulseaudio which output to use. Here's a small cheat sheet:

    List available "sinks" (audio outputs):

    # pactl list sinks short

    If you have several soundcards, you might need to set the default sink like so:

    # pactl set-default-sink alsa_output.pci-0000_00_1f.3.hdmi-stereo

    If you still don't have sound, it might be because your sound card have several ports (like HDMI1/HDMI2 etc) and Pulseaudio didn't detect the active one. List your cards profiles and ports like this:

    # pactl list cards

    Set a profile like this:

    # pactl set-card-profile alsa_card.pci-0000_00_1f.3 output:hdmi-surround-extra2+input:analog-stereo

    "extra2" is equivalent to HDMI3 on my system, you should be able to figure it out by using the above commands and some patience. If you provided me the logs, they would include all this information so I could tell you the exact command.

    Pulseaudio works out of the box on my NUC8, and also when booting the image in VMware on my laptops. I'm curious as to why the auto detection fails for you though.

  • Hello Escalade

    I like your RetroElec system. Great work !

    I try to use your last release for Rpi4 named RetroELEC-RPi4.arm-9.2-devel-20200409193626.img

    But everytime I got an error message in the first boot.

    The system start with the screen with this logo:


    is now booting

    But this error occure

    *** Error in mount_storage: mount_common: Could not mount UUID=789adbbc-1933... ***

    ### Starting debugging shell for boot step: mount_storage... type exit to quit ###


    There is no resize storage in the older release.

    I try 3 differents SDCARD.

    Always OK with release 20200313, But always in error with release 20200409

    Can you help me, or suppress the bug ?

    Best regards

  • Hi escalade,

    I would love to try RetroELEC. I am on x86 platform and currently running LE 9.2.2 with Tvheadend and hyperion and a backup script.


    Is it possible to install RertroELEC as dual boot OS on a USB stick to test if the restore of the current kodi config would work properly on RetroELEC?

    ->Boot RetroELEC from USB stick works, restore below backup not. ALSA sound not available, Tvheadend can‘t connect to server anymore and Hyperion doesn‘t work. Rest seems to be fine.

    thank you for your advice


    I did some research and believe I should be good to go, if I backup and rsync following paths into RetroELEC to get it working

    1) /storage/.kodi/addons

    2) /storage/.kodi/userdata

    3) /storage/.kodi/cdm

    4) /storage/.ssh

    5) /storage/.config

    6) /storage/hyperion

    I will give it a try this weekend, however would be glad if anyone could mention concerns...

    Edited 2 times, last by Bub4 ().

  • Hello Escalade, I tried building with your Docker and while the Docker part works fine it seems your repo on githut hasn't been updated in a while. Am I pointing to the right repo ?

  • Hi Again,

    I was searching through this thread and saw that the README could help me to properly upgrade from standard LibreELEC to RertroELEC without the loss of my current working config.

    But where can I find the README? There is no such file on the google download or the image itself.

    Would appreciate, if someone could point this out.

    I am a kind of scared to mess-up my current working config as it took me quite a while. Coming from Windows, I am a burned kid in terms of sudden crashed Kodi so I try to be careful here. :angel:


  • You can get it to behave like vanilla LibreELEC if you like, by setting the environment variable KODI_AE_SINK=ALSA+PULSE in /storage/.config/kodi.conf.

    This made Kodi find my HDMI as PulseAudio (along with default Pulseaudio device) and audio works in Kodi now using Pulseaudio.

    But I probably fiddled around too much in Retroarch / ES trying to get audio, what's the default audio output settings there?

    Also, after starting ES, Kodi defaults back to ALSA: Default (Intel PCH ALC283 Analog) and there's no Pulseaudio for HDMI any more until I reboot, then I can choose Pulseaudio HDMI again (doesn't seem to be there in Kodi.log but is there in Kodi.old.log). Any ideas on how I can fix that? Thank you in advance!

    Also, if I try to run Retroarch from Kodi menu, it starts RA for about a sec then crashes back to Kodi, see last attached logfile for further info

  • New images uploaded with some cool new stuff:

    • Squeekboard on-screen keyboard (generic only) systemctl enable --now squeekboard to enable
    • Google Noto Emoji fonts added
    • Sony LDAC, aptX, aptX HD, AAC codecs (A2DP Audio) support
    • Notifications with artist/title when streaming music over A2DP
    • Cava CLI visualization
    • RPCS3 git
    • Mesa git

    The RPi image should be fixed now for those who had issues.