S802/S812-Libreelec images for 7/8/9

  • Demetris

    There is a message "System failed to load kernel modules" at startup, wlan is not working.


    By the way, is this following showing a problem wit GPU3 ?

    [ [email protected]] temperature=110000 on trip point=3

    [ [email protected]] fixing high_freq=-1 to -22 at trip point 3,level=-1

    [ [email protected]] fixing low_freq=-1 to -22 at trip point 3,level=-1

    [ [email protected]] gpu[3].gpu_high_freq=-1,tmp_level[3].gpu_high_freq=-1

    [ [email protected]] cpu[3] core num==-1

    [ [email protected]] gpu[3] core num==-1

  • Thanks for all you hard work, Demetris.

    The top of my box reads:

    MX III

    4K (written in red)

    Boot Logo (not in order):


    8 Core

    Quad Core A9

    Mali 450

    This is a '2G/16G' box

    I am still using 'LibreELEC-S8X2.arm-8.0.1-MXIII-PLUS.img', compiled Apr 9, 2017. Everything works fine except wifi (which doesn't exist). I don't use it anyway.

    The reason is because any release greater than 8.0.1 runs very slow. Using the 'top' command, there's always at least one worker thread running an average of around 50%... this is WITHOUT kodi running. I have tried all of the 8.0.2xx versions as they are released, but keep having to go back to 8.0.1


    The info above was from memory. I'm actually running the latest now.

    I am also getting the boot 'waiting for job Load Kernel Modules' for about 4 minutes before booting. There is no logging info about this after booting.

    Here is a snippet of the 'top' command... remember, kodi is NOT running:


    691 root 20 0 0 0 0 S 51.3 0.0 22:23.92 kworker/0:1

    2832 root 20 0 2728 964 760 R 5.3 0.1 0:49.37 top

    926 root 20 0 0 0 0 S 0.3 0.0 0:05.47 kthread_di

    1 root 20 0 6060 3384 2652 S 0.0 0.2 0:03.78 systemd

    2 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kthreadd

    3 root 20 0 0 0 0 S 0.0 0.0 0:00.68 ksoftirqd/0

    5 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 kworker/0:0H

    6 root 20 0 0 0 0 S 0.0 0.0 0:00.51 kworker/u8:0

    7 root rt 0 0 0 0 S 0.0 0.0 0:00.00 migration/0

    8 root 20 0 0 0 0 S 0.0 0.0 0:01.56 rcu_preempt

    9 root 20 0 0 0 0 S 0.0 0.0 0:00.00 rcu_bh

    10 root 20 0 0 0 0 S 0.0 0.0 0:00.00 rcu_sched

    Would someone please help me on the above two problems, kernel not loading modules, and how to debug what 'kworker/0:1' is actually trying to do. The percent signs are not shown above but it's running at 51.3%.

    I'm mostly used to dealing with the rpi3 and odroid C2, with serial output, but can't seem to find my way around this S8X2.arm-8.2.RC3-MXIII-PLUS machine/build.

    Let me know is you, or anyone else needs more info.

    Thank you very much,

    Hal Williams

    Edited once, last by hwilliams ().

  • Demetris,

    I have this box and willing to test on dual boot but I was seeing multiple instructions. So do I need the DTB.img file or not for dual boot or do I only use the toothpick and the image burned to the USB. SORRY I see notes on a different method of dual boot but couldn't find definitive. My box is the M8.8 version S812 2gb/16gb

    Edited once, last by Pctravel ().

  • Demetris,

    I'm having the same problem across two devices with the last two updates.

    LibreELEC-S8X2.arm-8.2.RC4-M8.tar (and RC3) for the G-Box Q


    LibreELEC-S8X2.arm-8.2.RC4-M8S-PLUS.tar (and RC3) for the G-Box Q2

    I know the builds aren't built specifically for those boxes, but they're the same architecture and they've worked flawlessly up until the RC3 update. Anyway, the issue is that there is now no sound what-so-ever. As far as I can tell, the audio hardware is identical to the M8 as well. I'm not sure how to pull up the specs from the device though.

  • Hi everyone!

    Following my last attempts to install a ROM proposed in the first post on my box (MXIII-G 1G/8G - S812) but without success (no Ethernet connection), I had taken a look inside the dmesg of the last LibreElec working build (from wilros) and it seems that the Ethernet controller driver is the following:

    stmmac - user ID: 0x11, Synopsys ID: 0x37

    Demetris, do you think you could implement it in your MXIII-G build?

    Many thanks in advance!

  • Wanted to pop in again and say thank you, Demetris. I should have done it last time.

    I've been using your builds since you took over from Drieschel and I've never even had to make an account because everything has always worked so well.

    You're doing some great work and it's well appreciated.

  • I tried to install the new Demetrius image on my M8s with version M8.8 board. BCM 4335 chipset. The 1g images worked fine on my other identical box for libreelec internal install but for my other box only want to boot from sd to keep android but after trying a couple sd cards I received the following issues:

    1) Error in prepare_sysroot: mount_common: could not mount /flash/system starting debugging shell SH: can't access tty: job control turned off.

    2) with another image and card I saw the screen flash and then I get "File system corruption has been detected. I let it try to repair and it says:

    CP437: invalid argument

    FSCK.Fat 3.0.2b (2015-5-16)

    Open: Read only file system

    ezfsck 1.43.3 (04-sep-2016)

    Fsck.ext4: read-only file system while trying to open /dev/mmcblk0p2

    Disk write protected: use the -n option to do a read only

    Check of the device.

    Forced fsck failed. your system is broken

    This was the one I tried:


  • i think s802 boot loader cant work as s812 can so better get an s812 bootloader on it if you want to boot from sd.

    I did as i was getting that issues also but i could run installer from sd.

  • i think s802 boot loader cant work as s812 can so better get an s812 bootloader on it if you want to boot from sd.

    I did as i was getting that issues also but i could run installer from sd.

    clearly I'm too new. I'm missing something. How do I pull off the s812 boot Loader? I have two boxes of this m8s board v8-8. Bcm4335. I have one running libreelec from internal mxiii 1g tar update. Works perfect, all wifi and Bluetooth and smooth playback. My second box I want to maintain android as I use a few apps on that one but would like to run this same libreelec version from sd card. I have a droid sd card I use to reinstall mbox droid firmware whenever I load an image that fails. Is the boot loader I need in the android working box or libreelec? Or both and how do I get it? I have moved files with ftp/putty to libreelec box. I was using the image I used for my libreelec box with the libreelec sd tool but that isn't booting.

    Sorry for newbie issue, I feel like I'm close based on what I have loading from sd cards, right???

  • I am running a Minix X8H-PLUS with the latest from Demetris.

    I have noticed that if I use the power off system from within kodi, the power button will not turn on the box but rather I have to unplug and plug back in.

    Any thoughts?


  • I installed the 8.2-RC4 image on my M8 box Seams like things are working except for passthrough audio.

    When i activate passthrough GUI audio is fine but when I play a movie it hear a short high "screetch" sound and the nothing. Passthrough is via optical (SPDIF) cable. Can I do anything to help debug?

  • fquito and EBAL

    I'm currently using Demetris' S8X2 M8S-PLUS 8.0.2 on my G-Box Q2 and it's working flawlessly. I know it's a couple of versions behind, but the newer ones have problems playing back audio. Demetris take you're time. Like I said, it works fine as it is.

    Anyway, I don't have it running off an SD card. I flashed it onto the box directly. However I did at one point have it running from an SD by accident when I installed it wrong.


    If you want the SD boot:

    1. Download the LibreELEC installer from here: downloads – LibreELEC
    2. Download Demetris' M8S-PLUS image here: LibreELEC-S8X2.M8S-PLUS.arm-8.0.2.img.gz | by Demetris. for MXQ TV Box
    3. Select the file in the program and flash it onto the SD card you want to boot from
    4. Insert the SD card into the Q2 while unplugged
    5. Hold down the reset button inside the AV port hole (use a toothpick or something) while pluggin in the box. It should boot to the SD card then.

    If you want an internal boot there are a few extra steps:

    1. Since Demetris hasn't made zips for his packages, we have to find a work-around to start off with. Download LibreELEC-Amlogic.arm-M8SPlus-7.0.2-update.zip from here: MEGA
    2. Insert your SD card to your computer. Make sure its formatted to FAT32.
    3. Copy the zip you downloaded to the SD card
    4. Hold down the reset button inside the AV port hole (use a toothpick or something) and plug in the box. It should boot to the internal flash recovery.
    5. Insert the SD card into the Q2.
    6. In the recovery options, choose "apply update from EXT", then choose your SD card and then choose the zip file. It should then flash LibreELEC to the internal memory of your box
    7. Once the box boots into LibreELEC, set up the start-up options (IP, name, ect) MAKE SURE SSH IS ENABLED
    8. From here, if you want a newer version of LibreELEC, you can download Demetris' 8.0.2 update tar here: LibreELEC-S8X2.M8S-PLUS.arm-8.0.2.tar | by Demetris. for MXQ TV Box (or a newer version if you're reading this in the future. Just remember: .ZIP is for hard flashing, .IMG.GZ is for image writing software, and .TAR is for updating.)
    9. Either through SSH and Windows or SFTP and Filezilla, access the .update folder on your box
    10. Copy the tar file you downloaded to that folder.
    11. When it's done copying, restart your box and you should see it update to the new version

    Hope this helps. It's almost entirely from memory so it's possible I forgot something.