S802/S812-Libreelec images for 7/8/9

  • Hi, I just did clean install of the latest release (LibreELEC-MXIII_Plus.arm-LE9-Kodi_18.6) and fast forwarding of any video file either makes the system unresponsive until restart or freezes the video leaving audio playing in the background.

  • The box is MXIII-G (S812/2G RAM), up until now I've used "LibreELEC-S8X2.arm-8.2.3-MXIII-PLUS" with no issues. I've tried both updating from the older release, and doing a clean install to no avail.

  • Hi, I installed LE9 with Kodi Leia 18.6 for S82 and MXIII-PLUS on my MXIII box (tronsmart I think?). All seems to be fine, wifi and even bluetooth working, booted fine but... the wifi seems very slow. Is there something I can do ? before I was running an old openelec with kodi 16 and that was working fast.


  • Both releases are using exactly the same driver so i don't get how WiFi could be slower.

    Maybe your capacitors that feed the wifi with current are getting old and need replacement, maybe is your router, no one can actually say for sure.

  • ok thanks Demetris, I am actually troubleshooting it, you are probably right, it's probably the router... another question, I can't shutdown the box, well to be precise I can shutdown it but can't boot it again after, I have to manually unplug/replug it. I saw it's about uboot or something like that, do you have any idea what I can do for it to work as intended? Thanks a lot in advance

    Edit: I actually solved it on my S905 box (same issue) by flashing a bootloader.img. I will try to find the correct one for that box (MXIII 4k, splashscreen at boot shows tronsmart)

    Edit2: I found some firmware image on 4pda that seems to be fine for my box (not totally sure, as it is some kind of noname version of Tronsmart MXIII, showing MXIII 4k in front, I think from the specs that it is the good one). Can i extract the bootloader from firmware and flash it to my box ?

    Edited 3 times, last by bottedumal (March 25, 2020 at 9:11 PM).

  • I have actually made it so easy for you to find a compatible image/firmware that the next step is to come over and flash it for you.

    The secret hint is in the naming i gave the boxes in OP


    - S82/S82B/S82H/MXIII/S89/S89H

  • Honestly, I think you could eventually answer in such a condescendant way if you were really bringing some information I missed.

    But, for your information, my box doesn't exactly fit one of these, as it is, like I said, labelled MX3 4G.

    Opening the box, I found it is Netxeon M82 V4.0 S802 AP6330/2G/8G, which is some kind of noname hybrid box with same design and kinda same hardware, actually it actually seems to me some kind of MXIII plus with S802 chipset.

    I tried both your release, S82/S82B/S82H/MXIII/S89/S89H which would be the logic one according to box name and chipset is not booting (filesystem corruption has been detected blabla...) and MXIII-PLUS/MXIII-G/PROBOX2-EX-PLUS boots up, everything works fine, except the shutdown/startup.

    I actually also tried older of your firmwares, I actually spent hours trying lot of combinations, so it's always nice to read this kind of answer when you try many options to avoid bother dev with stupid questions. I even tried S82 release with MXIII-plus dts, but same filesystem corruption message.

    Which is why my last post was asking "Can i extract the bootloader from firmware and flash it to my box ?" which was maybe not so clear english, I'm sorry if it's the case, but not "what should I flash on my box".

    I actually got the bootloader.bin from a working android firmware (actually the 115k4 one which is the one actually flashed on my box with power on/off working), the only question I have was how to incorporate it in your latest MXIII-PLUS/MXIII-G/PROBOX2-EX-PLUS release running neat on my box.

    But anyway, I'm sorry to bother you if my questions still seems stupid, I'll leave the box as is or try to find back my old working openelec release. Thanks.

  • And how i was suppose to know what you did and what not when you didn't gave any info about your quirks.

    Last time i looked into my magic sphere, the S802 boxes would normally be bootable with any of the S82/S82B/S82H/MXIII/S89/S89H images.

    MXIII-PLUS/MXIII-G/PROBOX2-EX-PLUS is for S812 boxes.


    What i get from this?

    You don't flash the bootloader and you are stuck with S812 one so S802 images don't work.

    Either flash/wipe with usb and amlogic tool a proper image or stay with S812 bootloader and keep crossflashing S812 images.

    Note that I don't know if reverting to S802 bootloader will fix your issues or not, so do as your gut tells you to do.

  • hello

    i have an ott amlogic s802 m8c 

    Chipset AMLS802 quad-core cortex-A9 frequency :2.0G
    GPU Mali-450

    can you help me what firmware or image i can use ?

  • hello

    i have an ott amlogic s802 m8c 

    Chipset AMLS802 quad-core cortex-A9 frequency :2.0G
    GPU Mali-450

    can you help me what firmware or image i can use ?

    I'm using LibreELEC-S8X2.arm-8.2.3-MXIII-1G with something similar to you

  • Hello,

    I upgraded my mxIII plus 2G with LibreELEC-MXIII_Plus.arm-LE9-Kodi_18.6.tar

    Update went smoothly ! Great job !

    Everything seems fine, except eth0 mac address is 1E:00:00:00:00:00 (this is an issue having multiple boxes).

    I can't change eth0 mac address, i've tried with an udev rule and with a systemd service but i'm stuck with mac 1E:00:00:00:00:00

    Edit :

    Finaly, it works with systemd script ( see How to change duplicate MAC Address )

    Thank you for your great job.

    Edited once, last by beavis: solved (May 30, 2020 at 11:36 AM).

  • Tried the latest version on my MXIII-G Box with 812 and playing back a x265 video file stutters is there a setting I need to change for this? Im booting Libreelec from a SDcard and tried both streaming the video online and playing it from a usb stick.

    Booting the box to the normal internal OS and running Kodi from android plays the same file smooth without stuttering

    Also I tried to play a 20gb 3D film and that seemed to crash it as well :(

  • I run LE on my MX-III from internal emmc only. Android is completely gone but can easily be putback using amlogic usb burn tool if ever needed.

    However I do not do 'installtointernal'

    The way I did is by starting with Drieschel's build which gets intalled from sdcard to internal by default. And then upgrade it to Demtris' build using the standard LE upgrade procedure
    Drieschel's build is from this thread


    I'm trying to do this but drieschel's build are now gone in the provided thread. 404 not found.

    May I ask someone with a copy to please share the last drieschel's build for the same box as gujal?

    Someone replied that the command installtointernal will brick my box thus I will try gujal's way.

    Thanks in advance.

    Edited once, last by eixel0505 (July 3, 2020 at 4:37 PM).