Gamestarter: Retrogaming add-ons (RPi/Generic)

  • Hi there,

    God I hope someone can help me, I really tried for 2 days.

    My setup is a generic PC (AMD) with a fresh install of LibreElec 9.2, Gamestarter 3.0 (for RetroArch) and IAGL.

    I loaded RetroArch with the corresponding emulator used in IAGL. In IAGL settings, I've set the System Type to Gamestarter Addon, the RetroArch System Folder to "storage/.kodi/addons/game.retroarch". Now when I load a rom, it just crashes back to Kodi, whyyyyyy?? :cry:


    So sorry, I Just noticed it actually works for N64 games. It just doesn't work for NES ones. Is that weird? I was using FCEU, I thought it was kinda the best for NES.

  • Hi, sorry to post again. I wanted to inform that my problem was just the emulator for NES. Once I changed it from FCEU to Nestopia, everything was fine. Silly me. :blush:

    Great forum, good help and good job bite_your_idols. :thumbup:

  • Sorry to bother again but I need help with sound issues now. I know there is a lot of posting on many forum about it. I learned as much as I could and troubleshooted for days but so far I still have no sound.

    I’m on generic AMD PC onboard video output via HDMI to TV.

    First, everything fresh installed = no sound for any roms or cores (video is fine)

    Second, I’ve ssh to my PC, used aplay -l and found card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]

    Then went in Settings->Audio->Audio device in the retroarch GUI and I typed in "hw:0,3" without the "

    Third, I also tried fresh installs of older LibreElec / Retroarch combo, still no sound.

    Sound works just fine in kodi so I'm pretty sure the problem is in retroarch.

    Can anybody help me please?

  • Hi everyone,

    I installed your repo and installed RetroArch with LE 9.2 and a Rpi4. I finally got games to run, but get no sound output over hdmi (sound works in LibreElec). After look into the logs, I found the following line:

    ALSA lib /var/lib/jenkins/LE/build4/workspace/RPi4/build.LibreELEC-RPi4.arm-9.2.0/alsa-lib-1.1.9/src/pcm/pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM 0.1

    [ERROR] [ALSA]: Failed to initialize...

    [ERROR] Failed to initialize audio driver. Will continue without audio.

    With ssh, I also can't find the mentioned directory. Does somebody can give an advice what the problem is? Does I have to install ALSA manually?

    Maybe the following lines are a hint:

    LibreELEC:~ # aplay -l

    aplay: device_list:272: no soundcards found...

    LibreELEC:~ # aplay -L


    Discard all samples (playback) or generate zero samples (capture)

    Don't know there should be something like HDMI?!

    Thanks in advance.

    EDIT: I uninstalled the newest version and installed an older one from the repo. I installed all the cores (Because of the older addon version, not the newest cores?!) and now I have sound output in the games, but not in the menu. Is this some how a known bug?

    I also got still RA 1.81 and not 1.82 like mentioned in the github

    Edited once, last by eyk107 ().

  • For hdmi audio in RA add this to config.txt

    1. dtparam=audio=on

    For menu sound I don t think it ever worked

  • I've got this line allready in my config.

    Are there any other known bugs? Do you also have version 1.8.1 or 1.8.2 with the repo?

  • I've got this line allready in my config.

    Are there any other known bugs? Do you also have version 1.8.1 or 1.8.2 with the repo?

    Double check that line again then..

    This error:

    1. aplay: device_list:272: no soundcards found...

    you should only get without

    1. dtparam=audio=on

    I m on version="9.181.16"


    1. aplay -L

    should show something like this

  • I checked it again:

    No it looks right, but I didn't change anything. Maybe there went something wrong during the installation.

    One last question:

    I'm also on the version 9.181.16. In the github there is the commit "RA 1.8.2". But when I open RA, it shows 1.8.1 in the left corner?!

  • Is anyone able to help me please? I even went to buy a brand new video card Nvidia GT710 and I still don't have any sound in retroarch. What am I doing wrong?

  • I'm clearly doing something wrong. I just finished...

    installing LibreElec 9.2 generic (Done from scratch using the right files/USB boot from LIbreElec's website)

    done on Intel I3 system, Acer with onboard video/HDMI

    then installed zach morris IAGL's addon

    installed GameLauncher's Retroarch and added several cores

    then configured IAGL to launch external with GameLauncher with path to "storage/.kodi/addons/game.retroarch"

    added the associated cores in IAGL

    Still no sound in any games or cores, why? But in LibreElec, sound is ok.

  • I dont use it with an Intel processor so it is just a guess: did you try different audio divers in the retroarch audio config? Could you provide a log file?

  • no sound for me aswell now.

    Haven't been on gamestarter retroarch for a while, obviously a update of some sort has broke something.

    Mine was working perfectly fine when I first set it up but I had noticed it has updated a couple of times since I last played.

  • ok so I have fixed the sound issue but created so many more by uninstalling the add-on.

    So much doesn't work with the latest versions of this add-on.

    On fresh install of the retroarch add-on from the gamestarter repo, my ps3 controllers do not work. I remember this from the le9 earlier days, but only this time I just updated keypad config and it worked.

    Second issue, the add-on does not install all Lanka cores from the settings part of the add-on.

    I select download all Lakka cores from the settings menu of the retroarch addon from gamestarter and most cores are missing, tried several times and still not all there.

    Then after you get through all this you are faced with no sound.

    I can solve this by going to the retroarch.cfg file, finding audio_device "" and adding my sound card I want to use which I find by running ssh and typing aplay -L

    Then in between the "" i add the device information and all works good.

    It seems like a lot of stuff is outdated with this add-on now could this be right.

    When I first started using this add-on on le 8.2.x it worked perfect no need to alter anything.

    Since le9 it just appears I have to mess around with so much just to get it working.

    I'm all up for helping if I can be any help as I love this add-on for kodi, I'll just keep hold of all altered files for now in case anything goes wrong with my setup so I can just copy them back over to save going through all config files again :)

    By the way I'm using generic 9.2.0 le on a amd platform.

  • Since I updated to RPi4 now I have no RPi2. The problem is that if I want to update lakka cores in gamestarter repo I burn lakka image in an spare SD card and get all cores via ftp. I can still do that for RPi4 and for Generic (Using VM) but I can't do it for RPi2 anymore.

    So here is my question, how can I grab core binaries from lakka image for RPi2 without a RPi2??

    I tried extracting files from image file using 7zip but I get some corruption errors...

    I tried mounting SD card in a Linux VM but no luck...

    I tried to mount image file in Linux VM but no luck...

    I tried to compile Lakka 2.3.2 in Linux VM but I get some errors and It needs about 60Gb of free storage and a full day to compile...

    Any suggestions?


    Finally I could compile lakka 2.3.2 for Rpi2 so I get updated cores to push to gamestarter repo, but any suggestions are welcome for next times.

    Now I'm trying to compile RA 1.8.4 but it seems there are some changes I need to fix in, it can take a very long time...

  • Thanks for all your effort! Is there a changelog? Still new to it all and curious about new features.

    You can see RetroArch addon changelog here, there i no improvement apart from RetroArch version update.

    You can follow RetroArch team in their blog.

    You can read latest RetroArch 1.8.4 features in this post.