Thoradia Add-ons

  • I am using Sonarr, Radarr and Jackett from the thoradia repo. For some reason, after a while my CPU usage shoots really high, and ssh top shows that mono is using CPU. Disabling and reenabling sonarr and radarr fixes it, but its really annoying. Any fix?

  • I reset LibreELEC to defaults and installed the addon again and it works now. Not sure what happened to prevent it from working before.

  • I am using Sonarr, Radarr and Jackett from the thoradia repo. For some reason, after a while my CPU usage shoots really high, and ssh top shows that mono is using CPU. Disabling and reenabling sonarr and radarr fixes it, but its really annoying. Any fix?

    You do not provide enough information to assess what is going on.

    Check the logs (System/Logs in the web-ui), report the issue at Radarr/Sonarr, and come back here if the issue is specific to the add-ons.

    Keep it legal and carry on

  • You do not provide enough information to assess what is going on.

    Check the logs (System/Logs in the web-ui), report the issue at Radarr/Sonarr, and come back here if the issue is specific to the add-on

    Ill try and get some more info, but when i checked the logs, i didnt see anything unusual. Also, the problem does not really seem to be reproducible, happens randomly afaik. Anyway, ill wait and gather more information then report back.

  • Hi, thanks for your work.
    Unfortunately the Jackeet is coming out of the air and only comes back to normal when you reinstall the service.
    Another thing is how to run Jackett as a regular user and not root?

  • Hi, thanks for your work.
    Unfortunately the Jackeet is coming out of the air and only comes back to normal when you reinstall the service.
    Another thing is how to run Jackett as a regular user and not root?

    What do you mean by coming out of the air? Provide a log (journalctl -u service.jackett).


    I will see what I can do to run Jackett as a user different than root.

    Keep it legal and carry on

  • Unfortunately the Jackett is coming out of the air and only comes back to normal when you reinstall the service.

    Just found out that myself.

    Please, temporary disable auto-update in WebGUI right after service reinstall.


    Seems we've got Mono outdated: Jackett now requires MonoDB 5.8 since v0.9.6.

    Thoradia?

    Code
    1. LibreELEC:~ # mono /storage/.kodi/addons/service.jackett/Jackett/JackettConsole.exe
    2. 07-20 19:09:11 Info Starting Jackett 0.9.14.0
    3. 07-20 19:09:11 Info Environment version: 4.0.30319.42000 (/storage/.kodi/addons/tools.mono/lib/mono/4.5)
    4. 07-20 19:09:11 Info OS version: Unix 3.14.29.0 (64bit OS) (64bit process)
    5. 07-20 19:09:11 Info ThreadPool MaxThreads: 400 workerThreads, 200 completionPortThreads
    6. 07-20 19:09:11 Info App config/log directory: /storage/.config/Jackett
    7. 07-20 19:09:11 Info issue: ##############################################
    8. 07-20 19:09:11 Info mono version: 5.4.1.6 (tarball Sat Nov 11 04:32:02 GMT 2017)
    9. 07-20 19:09:11 Error A minimum Mono version of 5.8 is required. Please update to the latest version from http://www.mono-project.com/download/


    Vanilla v0.8.22 is currently useless for me, cause I require a proxy setting - it was implemented later.

    Also, Jackett indexers are now outdated - they seem to get updated during Jackett update only.

    Edited 5 times, last by i3laze ().

  • i3laze  
    You were right not to do the update, the service continues to run smoothly.


    thoradia

    The reason for wanting another user is this message on jackett

    Jackett is running with root privileges. You should run Jackett as an unprivileged user.


    If it does not affect any performance of the program, there is no need for a solution.


    Code
    1. thank you all
    Code
  • Hi!


    Jackett has also stopped working for me, due to mono being outdated.


    Will there be a mono update?

    Is it possible to downgrade Jackett to a previous version to get it to work?


    Thanks!

  • I am buidling Mono 5.12 for LibreELEC 8.2

    It should be available soon

    Keep it legal and carry on

  • I have updated Mono for LibreELEC 8.2

    Hi,


    I'm running LibreElec 8.2.3.1-C2, the new update of Mono is marked as "failed" (and now it seems Emby for Kodi isn't working anymore).


    Regards

  • Hi,


    I'm running LibreElec 8.2.3.1-C2, the new update of Mono is marked as "failed" (and now it seems Emby for Kodi isn't working anymore).


    Regards

    The updated Mono add-on is too big for github.

    I therefore pushed it with git lfs.

    This however changes the URL of the zip file.

    Which causes the error you experience.


    I have reverted the commit which adds Mono 5.12 to the Thoradia repository.

    This should fix failing installation of Mono.


    Updated Mono is available in the 8.2-mono branch at 8.2/device/arch/tools.mono/tools.mono-8.2.110.zip

    For example for Odroid_C2: tools.mono-8.2.110.zip

    Install it manually


    Thank you for bearing with me

    Keep it legal and carry on

  • Hello,


    i tried to install latest Mono version *110* using the ZIP file, but in Kodi Emby_For_Kodi didn't login anymore.


    Then, i tried to reinstall the previous Mono version *109* (from LibreELEC repository), but it seems Emby (or Mono?) keeps restarting itself in loop ;(.

    I attached the Emby log file, which shows errors.


    What can i do ? I'm now using back the Mono *109* but it's not working anymore.


    Do you still have your Mono version *109* somewhere maybe?


    Regards,

  • According to your log Emby starts and uses Mono 109 from LibreELEC.

    The log however shows that Emby fails to find directories in /media.


    Have you rebooted your system and checked the state of /media?

    Keep it legal and carry on