Official LE11 Test Images for Amlogic (Kodi-20)

  • chewitt i will try a build of yours. Can I cross update from this one?

    I will see what the codec info shows in tvheadend and try a few other ones.

    Are you interested in logfiles from tvheadend?

  • Cross-grade did not work from cvh version. But I installed it new.

    HD channels switch is better than on official - SD still does not work.

    HD resolution is 1280 x 720 and is decoded in hardware with: ff-h264_v4l2m2m-drm_prime, drm_prime

    SD resolution is720x576 and is decoded in hardware with: ff-mpeg2_v4l2m2m-drm_prime

    Booth @25 FPS

    Kodi Log

    SD channels / view in log are after

    INFO <general>: CDVDVideoCodecDRMPRIME::Open - using decoder V4L2 mem2mem MPEG2

    Does this makes any sense to you - or should I get any other information?

    EDIT: youtube works fine, regardless of the resolution

    Edited once, last by tavoc (April 18, 2021 at 7:18 PM).

  • Channel switching is all about support for flushing in the hardware decoder, which is partially implemented in ffmpeg in my images. I can make sense of the other infos. I'll look into the MPEG2 issue, but I don't code so I can't fix the driver (where the issue probably is) and will need to focus on seeing if simply disabling hardware decoding for SD resolutions is an okay workaround.

  • Christian,

    i've burned on SD your LE 9.95.2 and it runs quite fine on my Tanix tx5 pro (s905x)

    1- wifi works fine (despite on last CoreElec is not working)

    2- BT do not (who cares?)

    3- decoder PRIME works, but only via software

    4- samba (with windows 8.1 PC) is a nightmare (culprit kodi matrix)

    5- only few addons are compatible with kodi matrix

    6- (very noob question) i can't "see" any eMMC (so no reboot from internal availabile) (it maybe android 6 of my box?)

    7- THANKS A LOT for your hard work!

  • Awesome thx for the tip, will look into that build, yes it is essentially an X92 box.

    Where are the dtb files located?


    They are all in a sub directory on the image, other than with the other elec you shouldn't copy them around, but change a config file to point to the right dtb. In case you dont find the right one for your box it's worth trying the vim2, this works very well for my box. Sorry for my vague answers, I'm currently experimenting with manjaro on the box, but didn't start it in quite a while, as my new job keeps me quite busy nowadays...

  • Hello. My odroid C2 don't boot with official test images ( with microsd cards. Boot possibly only with usb flash.


    *** error in mount_flash: mount_common: could not mount LABEL=LIBREELEC ***
    ### Starting debugging shel for boot step: mount_flash... type exit to quit ###

    A similar issue has been resolved here.

    Is it possible to add a slot microsd to the device tree?

  • Hi.

    How can I turn off the pink color

    LibreELEC starts up in a pink glow, I know it was possible with SHH overriding some options, but I don't remember what file it is and which line should be edited ..

    can anyone help me, thank you

  • Hi friends... I have tried to install libreelec on mecool k5 (Amlogic S905X3) and I have not been able to achieve it. I have tried some img here and it does not start from sd or usb. Some help? Thanks a lot!!