Official LE Test Images for Amlogic (Kodi-20)

  • That sounds awesome! I have an 9.2. Installed to internal On my play 2. Any chance there will be a chance to upgrade it?

    The changes are in the nightly files now *but* like all LE10+ images it requries clean-install, there is no upgrade. To use the upstream u-boot on the box you need to first boot from the 'box' image then use emmctool to erase emmc (removing all traces of vendor u-boot) and then write the -wetek-play2.img.gz file to emmc. I strongly suggest you experiment with the 'box' image first before doing that, as while the LE11 codebase is quite usable on S905/S905X/S912 devices now, it's not as feature complete as the legacy one. If people do this and then want to go back, I do have a raw disk copy of the factory Android image on emmc which can be restored.

  • FEEDBACK for latest LibreELEC-AMLGX.arm-11.0-nightly-20220617-07254d4-box.img LibreELEC-AMLGX.arm-11.0-nightly-20220806-7a6f94e-box


    Video driver is broken for S912 (Yoka KB2 3/32, both q200 and q201 dtbs): video glitches, decoding errors and freezing.

    UI deadlocks randomly too.

    Edited once, last by forart ().

  • The changes are in the nightly files now *but* like all LE10+ images it requries clean-install, there is no upgrade. To use the upstream u-boot on the box you need to first boot from the 'box' image then use emmctool to erase emmc (removing all traces of vendor u-boot) and then write the -wetek-play2.img.gz file to emmc. I strongly suggest you experiment with the 'box' image first before doing that, as while the LE11 codebase is quite usable on S905/S905X/S912 devices now, it's not as feature complete as the legacy one. If people do this and then want to go back, I do have a raw disk copy of the factory Android image on emmc which can be restored.

    Thank you for the answer. Looking forward to try this next month!

  • Sorry, let me know how can I feedback better (log file ?).

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem.

    Full logs only. No modified logs.

    Do not post your logs directly into the forum,
    use Settings > LE Settings Addon > System > Paste system logs
    and post the link.

    DNB music-addicted finger drummer.

  • Hi. Is Optical Audio Port something that is already supported in mainline kernel? just asking because my box has one, I've never used before but I thought about turning some old speakers into airplay speakers but there's not audio output and I'm pretty bad with messing with ALSA on Linux. Thank you and sorry to bother.