Official LE Test Images for Amlogic (Kodi-20)

  • chewitt i will try a build of yours. Can I cross update from this one?


    I will see what the codec info shows in tvheadend and try a few other ones.

    Are you interested in logfiles from tvheadend?

    • Official Post

    You can cross-grade from Nightlies to my images. You cannot cross-grade from Oleg's images (balbes150) due to different boot config. I'm interested to know what resolutions and codecs are problematic. I'm not interested in TVH logs (someone else's problem).

  • Cross-grade did not work from cvh version. But I installed it new.


    HD channels switch is better than on official - SD still does not work.

    HD resolution is 1280 x 720 and is decoded in hardware with: ff-h264_v4l2m2m-drm_prime, drm_prime


    SD resolution is720x576 and is decoded in hardware with: ff-mpeg2_v4l2m2m-drm_prime

    Booth @25 FPS




    Kodi Log



    SD channels / view in log are after

    Code
    INFO <general>: CDVDVideoCodecDRMPRIME::Open - using decoder V4L2 mem2mem MPEG2



    Does this makes any sense to you - or should I get any other information?



    EDIT: youtube works fine, regardless of the resolution

    Edited once, last by tavoc ().

    • Official Post

    Channel switching is all about support for flushing in the hardware decoder, which is partially implemented in ffmpeg in my images. I can make sense of the other infos. I'll look into the MPEG2 issue, but I don't code so I can't fix the driver (where the issue probably is) and will need to focus on seeing if simply disabling hardware decoding for SD resolutions is an okay workaround.

  • i tested the 9.95.2 today, sadly the mpeg2 decoding does not work. As an improvement I can hear audio in SD channels.

    HD is still fine.

  • Christian,

    i've burned on SD your LE 9.95.2 and it runs quite fine on my Tanix tx5 pro (s905x)


    1- wifi works fine (despite on last CoreElec is not working)

    2- BT do not (who cares?)

    3- decoder PRIME works, but only via software

    4- samba (with windows 8.1 PC) is a nightmare (culprit kodi matrix)

    5- only few addons are compatible with kodi matrix

    6- (very noob question) i can't "see" any eMMC (so no reboot from internal availabile) (it maybe android 6 of my box?)

    7- THANKS A LOT for your hard work!

  • Hey all,


    Awesome work! I'm excited to test a build.


    What build would I use, for my S912 based H96pro+ ?


    Cheers,

    Ken

  • Awesome thx for the tip, will look into that build, yes it is essentially an X92 box.

    Where are the dtb files located?


    Thx!

  • Awesome thx for the tip, will look into that build, yes it is essentially an X92 box.

    Where are the dtb files located?


    Thx!

    They are all in a sub directory on the image, other than with the other elec you shouldn't copy them around, but change a config file to point to the right dtb. In case you dont find the right one for your box it's worth trying the vim2, this works very well for my box. Sorry for my vague answers, I'm currently experimenting with manjaro on the box, but didn't start it in quite a while, as my new job keeps me quite busy nowadays...

  • Hello. My odroid C2 don't boot with official test images (test.libreelec.tv) with microsd cards. Boot possibly only with usb flash.

    Error:

    Code
    *** error in mount_flash: mount_common: could not mount LABEL=LIBREELEC ***
    ### Starting debugging shel for boot step: mount_flash... type exit to quit ###

    A similar issue has been resolved here.

    Is it possible to add a slot microsd to the device tree?

    Odroid C2 2GB/Odroid N2 4GB/Rockpro64 4GB/Clone MXIII Plus 8-1.5GB

  • Greetings to the whole Forum.

    Sorry for the ignorance, but I can't find an image for mxq pro S905X, or I don't know which one to use

    Thank you very much

  • Hi friends... I have tried to install libreelec on mecool k5 (Amlogic S905X3) and I have not been able to achieve it. I have tried some img here and it does not start from sd or usb. Some help? Thanks a lot!!