[] LibreELEC 8.0 for S805

  • Update:
    The disp_cap_hack solved the missing options issue. I now have access to 50, 60, and 24hz in 1080p and more. I tried them, the 24hz mode works! But it is still doing the display change dance even though I have turned automatic refresh rate changing to OFF.
    For some reason starting and stopping and seeking within the video still tries to change the display rate, even though it isn't actually changing. For example, in this case going from 24hz to... 24hz again. If I toggle the options on and off for automatic rate change and reboot the box, it sometimes sticks. But other times it comes back, and its really annoying. Any ideas on that?
    Hardware is a red striped beelink MXQ.

  • Hi guys, first post here. I've got the latest build running on an S805 MXQ without issues it seems aside from the normal issues with refresh rate.

    I've been trying to get my Wired 360 controller to work now for a few days to no avail. Is there some stuff missing from the kernel or is it simply not loading a module.

    Thanks for any input. Great work btw, brought my old box back to life.

  • If the tuner is connected using S805 TS interface, you would need to get AML DVB kernel driver first (it is not open source) and then customise demod+tuner driver to work with AML TS interface. If it's a USB tuner, it should work OOB.

    I hope you enjoyed your holiday!

    Thank you for the quick answer. This seems to be bigger hurdle than I thought. Oh, well. I have just purchased 2 Xbox one USB tuners. I am going to replace the internal tuner with those. If that does not work. I can always use them in my Mythbuntu server as additional tuners, or maybe I just stick them up my... 8o (Getting bit frustrated here. With the time and money I have spend getting this box to work. I would probably have got working Wetek box, and then some. Lol.)

    I love your builds, and I am very grateful of your work. Keep them coming!

  • Hi,

    Firstly, thanks for the great work breathing new life into these boxes.

    My problem is, I have an MXQ-S805-v3.2 box which won't install LibreELEC. It just boots into Android. I've tried the MXQ, HD18Q and the m201d builds using an SD card.

    I have 2 other boxes which install fine, so it's not down to my error:

    An OTT s805-v1.2 installed with the latest HD18Q build on SD card and works great.

    An MXQ-S805-v3.1 installed with the latest m201d build on SD card which has the freezing issues.

    Any ideas?

  • My problem is, I have an MXQ-S805-v3.2 box which won't install LibreELEC. It just boots into Android.

    Any ideas?

    Do you mean you can't install to internal or the box won't boot LibreELEC from the SD? If latter then maybe a faulty reset button (so the toothpick method won't work)? You could try one of these instead.

    S805: MXQ S85 (red "MX"), 1/8 GB
    S905: MiniMXIII, 2/16 GB

  • Do you mean you can't install to internal or the box won't boot LibreELEC from the SD? If latter then maybe a faulty reset button (so the toothpick method won't work)? You could try one of these instead.

    Tried again with the 'toothpick' and got it working. My error :blush:. Thanks negt :thumbup:

    Edited once, last by atat71 ().

  • Does bluetooth audio work with this?
    My Beelink MXQ s805 worked with my BT headphones when I wanted to avoid the sound (waking up sleeping kids at home). Can't seem to find anything in any of the menus for this. If support for internal BT is missing, I also have a USB bt dongle I can use. Or is Bluetooth audio not supported at all?

    Never mind! I figured it out. I had to first turn ON bluetooth in a different menu in order for it to then pair with a device, and then I could go back into audio settings and change it to Pulse / BT, which worked great. But it's a rather silly three step process in different menus to make this work, rather than a simple toggle.
    Bottom line, it WORKS so I'm good for now. Thanks!

    Edited once, last by dishe: Figured it out ().

  • I seem to have issues with 2 Win 7 PCs being able to cast to my MK808Bplus running Other (Windows 10) PCs can cast to it, but if the win7 PC tries, it reports that device is not responding.


    Paste output ======== /flash/config.txt ============== ======== /flash/cmdline - Pastebin.com

    It looks like it crashes libreelec UPNP as after a win7 pc has tried to Play to it, the device disappears from my win10 pc "Cast to" section.

    The issue seems to be unique to the mk808bplus as the win7 pcs can cast to my s905x device, also running

    Would appreciate some help on this as it's for my father who is unwell. ( I can't convince him to update from Win 7!)

    Can anyone else try using “play to” from their windows 7 pc to this s805 build please?

  • Hello,

    I have MK808B Plus, can I update (using update folder) to this version from LibreELEC (internal memory version) ?


  • Hello

    I am have MXQ, since I moved from 7.0.33 build to 8 build when I use Tvheadend HTSP Client and leave it on MXQ will freeze and the only way to fix it is to power off and on the MXQ.

    Is there a way to fix this, I use Tvheadend all time,

    Thank you

  • Just wanted to shout out a giant

    THANK YOU to kszaq

    I just used this build to revive a crappy (Amlogic S805 based) OEM android box that I once purchased on a whim, and has effectively been gathering dust ever since (thanks to crappy chinese firmware, no Play store etc)

    I'll just write down here "Turbo-X Media Player Android Box" so that hopefully the google gods can help to bring more people to salvation.

    I haven't tested it extensively, but if I find any problems I'll get back to you.

    Now off to read the 28 pages of this thread, and to think about what to do with my newest (4th) member of my LibreELEC family...

  • Hi everyone and specially to kszaq !

    I'm trying to get CEC working but unlike my raspberry pi zero running raspbian and kodi, my mk808b plus doesn't have any input from the remote of the tv... In the Pi I get everytime a message of the Pulse 8 CEC connected, but on the mk808b I get nothing and in the options it says CEC is on.

    Someone can explain me how to debug this, as I see from the release I might have the U-boot incompatible, and I wished I knew how to change or upgrade the U-boot...


  • base_08 Most common reason is that mini HDMI cable supplied with MK808B+ does not have CEC pin transmitted. You have to use a different cable or a cheap adapter.

  • kszaq yes, I had the old cable for a long time and being a follower on your work since the times of openelec over the other forum, I already knew I had to buy a new cable, but the fact is that I can confirm that the very same cable I recently bought works with the raspberry pi zero. Can I check some command line or some log to further investigate? Long time ago I had to unbrick the mk808b plus with amlogic burn tools with another firmware I found... might be this the u-boot incompatibility?

    Thank you again!