[8.2.3.1] LibreELEC 8.0 for S805

  • LE 8.0/8.2 uses libcec 4.0.2, this patch is not a part of it. I can try to add the patch to next build if it applies cleanly.

    Sorry for disturbance, are there any plans to include new CEC library version that possibly could fix disconnects from Samsung TV for MK808B+?

  • Sorry for disturbance, are there any plans to include new CEC library version that possibly could fix disconnects from Samsung TV for MK808B+?

    LibreELEC 8.2 bbuild already have a patched libCEC and in current state there are no things that I can change to improve, meaning that with current kernel it won't get any better, sorry.


    I had no issues when using MK808B+ with my Samsung TV, perhaps you can try using a different cable or different mini HDMI adapter?

  • I had no issues when using MK808B+ with my Samsung TV, perhaps you can try using a different cable or different mini HDMI adapter?

    For me TV shows "disconnecting from AnyNET+" quite often. Usually it happens when I push navigation buttons on RC with high rate. I tried many cables. Should reboot OpenELEC and select Kodi in TV Tools to make it work again. I'll try to upgrade TV firmware (not sure that it is available, it is quite old model). Does it make sense to enable and grab CEC component log? Thanks anyway

  • I was using my MK808B+ with 2011, 2012 and 2013 models with no issues. Please try using a different HDMI cable. It is also possible that your MK808B+ is a bit faulty.


    Unfortunately there is no point in grabbing logs, I did a pretty intensive CEC debugging session back in 2016 and in current state it's the best what I can get.


    Please also look at the first post: I am not working on these builds any more (lack of time). The only update S805 devices will get is a bump to Kodi Leia (soonish).

  • Hi kszaq


    I have a Sveon SSL4420 device, that not looks like the standard S805 box. No SD, RCA output...


    I can enter in recovery mode using the update & backup tool, with a dummy update.zip but is not installing the LE bootloader.


    Any ideas? the device is just garbage with the current Android 4.4.2

  • In last libreelec release in my s805 don't work libreeelc repo and i can't install pvr addon.. how i can solve?

    Edit. I solve using a 4g connection in hotspot.

    Edited once, last by stopino ().

  • Hi, i have one problem with libre, i have china made android box S805 MXQ m201C , but i can install only for m201d with 512mb (in libre 345mb )..how i can install for more memmory?

  • Hello all,

    I know it is late in the game for these s805 boxes but they are new to me.


    I have been happily using kodibuntu on a small PC. Last week in my local Value Village (read: donated and resold store) I found an OTT MXQ in its original package and still in its original wrappings . I suspect somebody got it for Xmas or something and never used it. Either way $40 CDN and I was happily trotting home to try out my new toy..


    After deleting all the streaming crap that came preinstalled (wow time consuming !) butchering Kodi, I found it lackluster and naturally a few releases behind. So I started searching and reading and reading some more.


    Multiple revisions with major board changes ? Clones ? At least 6 manufacturers ?? Holy crap !


    Not wanting to take it apart yet, I installed and ran CPU-Z and a few other tools. Each one indicated a different amount of RAM, but all mentioned m201. I decided that I had bought the 512MB version and proceeded to download LibreELEC-S805.arm-8.2-8.2.3.1-m201d.img and stuff it on an SD card as per instructions.


    Yay ! it works like a charm [kszaq is a Wizard !]


    A little configuration later and I have it set up just like the PC in my living-room (happy camper).


    Now, still reading and searching I find a thread on freaktab that has MXQ s805 owners sharing photos of their hardware and roms/images that work or don't.


    4 screws later and I see that I have "S805-V1.2 20150520" on one side and "HD18Q_V1.2 2015/05/09" on the other. There IS a heatsink on the CPU and but I cannot read the Wi-Fi module numbers..


    WTF ?? 05 20 on one side and 05 09 on the other ?? How do I know which board ?


    For giggles I download LibreELEC-S805.arm-8.2-8.2.3.1-HD18Q.img and try it on an SD card.


    Damned if it doesn't boot up and run just fine as well ! !


    Wi-Fi works well with both images, things are just as snappy on both. The only differences I see are the reported RAM values and I cannot power back on with the HD18Q image while I could with the m201d image. I wonder what makes the power on difference ?


    I am sad to read that there will only be a Kodi bump and not further development on these boxes.


    kszaq Thank you for all the time and effort you have put into these images and helping people get the most out of their boxes.




    Long Story Short :


    OTT MXQ s805 "S805-V1.2 20150520" on one side and "HD18Q_V1.2 2015/05/09" on the other with heatsink.


    - LibreELEC-S805.arm-8.2-8.2.3.1-m201d.img works form SD card , wi-fi, remote, power on/off all perfect.


    - LibreELEC-S805.arm-8.2-8.2.3.1-HD18Q.img works from SD card, wi-fi & remote perfect, Power off only.

    Edited once, last by Digidog: Add summary to maybe help others. ().

  • kszaq


    What did you do to the HD18Q image to create the m201d image so it works with less RAM ?


    I ask because I am making a guess that it is hard coded to not look beyond 512MB and actually reports 384MB.


    If I could undo that hardcoding in the m201d image I could take advantage of the power on/off working and still see all of my RAM. Does that make any sense to you ? Do you have any suggestions bearing in mind I am not skilled or experienced enough to build my own image, but could probably SSH in and modify a file or two.



    As per above post #573, I have an OTT MXQ s805 "S805-V1.2 20150520" on solder side and "HD18Q_V1.2 2015/05/09" on component side.

  • So sad to see there won't be any more updates to this build, but very much appreciate everything we have already!

    I haven't been around here in a while, but I signed on hoping to find a solution to a problem. I have a remote outlet that the entertainment system is plugged into, and it was accidentally power cycled on/off a few times by a toddler holding the remote. Now Libreelec won't boot. It shows the Libreelec logo and loading screen, but seems to be stuck there. Its version 8.1, so I could really use an update anyway, but I'm guessing the power cycling corrupted something on my SD card (still have Android original firmware on NAND). Taking out the card I can still boot back into Android, so I think its just the card.

    If I put the SD card into my Windows10 computer, I can see two partitions, one of which Windows can read (which I think makes sense, as the other partition is linux right?). The files seem intact in the part I can read. I know I could probably reformat and start over, but I had gotten all my plugins *just so*, and it took me a long time to get it all the way I wanted. I'm hoping there's a way I can just replace the libreelec system, perhaps with the newer 8.2, and get it working while keeping my data intact. Might be a long shot, but hoping it is worth trying. Does anyone have any suggestions or advice?


  • If I put the SD card into my Windows10 computer, I can see two partitions, one of which Windows can read (which I think makes sense, as the other partition is linux right?). The files seem intact in the part I can read. I know I could probably reformat and start over, but I had gotten all my plugins *just so*, and it took me a long time to get it all the way I wanted. I'm hoping there's a way I can just replace the libreelec system, perhaps with the newer 8.2, and get it working while keeping my data intact. Might be a long shot, but hoping it is worth trying. Does anyone have any suggestions or advice?

    Try running a Linux Distro in live mode from a usb key. It will not harm your Windows install and it will allow you to access the other partition on your SD card and hopefully save your userdata folder so you can stuff it back later using the same method or with Windows over the network through LibreELEC's samba share of said folder(s). ... With a Win 10 machine you might need to find a Linux Distro that supports EUFI Booting.