[8.0.2e] LibreELEC 8.0 for S905/S905X

  • You can find firmwares (even some custom Android TV ones :) ) for S905 boxes here : S905 - FreakTab.com


    All you need to flash back Android is a male to male USB cable, and the "USB Burning Tool" from Amlogic.

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND


  • You can find firmwares (even some custom Android TV ones :) ) for S905 boxes here : S905 - FreakTab.com


    All you need to flash back Android is a male to male USB cable, and the "USB Burning Tool" from Amlogic.


    is there no way of pulling one off the box just in case I cant find one online?


    The OS i got from freaktab last time killed my old box

    Edited once, last by crsnwby ().


  • Can someone point me in the direction of backing up my box so I can install LIB directly on it and recover if needed.


    Ask Seller For the Update Image Link. Safest way to do it.


    Its a Tonbux Q Box S905 2GB/16GB


    Then do as Fredouye advised.


    All you need to flash back Android is a male to male USB cable, and the "USB Burning Tool" from Amlogic.

  • kszaq, thanks again for these builds. More coffee money on the way.
    I'm running a Beelink GT1 and a Beelink M18 with 8.0.1c and performance is excellent off an SD card. The only issue I have may or may not be LE related. I am having handshake issues between my receiver - Onkyo TX-NR3008 and Sony TV KDL 65W900B (1080P). This happens after using LE on either Beelink box and switching sources on the receiver to a different source ie. cable box. There is no audio but the picture is working. I can resolve this by pulling the HDMI cable out of the receiver and plugging it back in after a few seconds. The problem started a couple months ago.
    Any ideas on what might be causing this?

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.


  • Can someone point me in the direction of backing up my box so I can install LIB directly on it and recover if needed. Lots of different guides online but all seem to point to phones with a recovery available online but my box doesnt have one online I need to get it from the box itself.


    You can boot from SD/USB and just make a dd image of the boot, system, data and dtb partitions. The install script touches only those (save for some u-boot variables) and you should be able to restore your box to the exact same state as before the backup.


  • I'm rebuilding 8.0.1c now to fix multichannel PCM audio.


    Can you tell when your git is up-to-date and which tag I will need for building (64bit) '8.0.1c + fix'?
    Or provide a pointer to the changeset of the multichannel PCM audio fix relative to '8.0.1c' tag?
    Thanks a lot.
    PS: when I built from '8.0.1c' tag (I assume without fix) yesterday, I encountered kernel build issue:
    'hdmitx_device' not declared
    (in linux-2921a14/drivers/amlogic/hdmi/hdmi_tx_20/hdmi_tx_video.c line 623)
    I replaced 'hdmitx_device' with 'hdev' 2 times as follows:
    if (hdmi_output_rgb) {
    param->color = COLORSPACE_RGB444;
    hdev->para->cs =
    hdev->cur_video_param->color;
    }

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • Hey gents,


    Any other methods to downgrading to LibreELEC 7.0 apart from flashing Android and then re-flashing LibreELEC?


  • Hey gents,


    Any other methods to downgrading to LibreELEC 7.0 apart from flashing Android and then re-flashing LibreELEC?


    When running 'installtointernal', /dev/system and /dev/data are formatted, so I assume you can boot to a LE7 card and flash to internal.

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • Hi,


    Am I the only one who had to toggle wifi on and off on libreelec settings because of the wifi failure on boot?


    Any suggestions to overcome the issue?

  • When running 'installtointernal', /dev/system and /dev/data are formatted, so I assume you can boot to a LE7 card and flash to internal.


    Cheers for the suggestion. Will give it a whirl and report back.



    Edit: That did the trick. Thanks.

    Edited once, last by SEIKT ().


  • I have re-tagged 8.0.1c yesterday. Nonetheless you should not have this build issue, this is patched properly: Reapply: drivers/amlogic/hdmi: set video color parameter as well with… · kszaq/[email protected] · GitHub

  • I have re-tagged 8.0.1c yesterday. Nonetheless you should not have this build issue, this is patched properly: Reapply: drivers/amlogic/hdmi: set video color parameter as well with… · kszaq/[email protected] · GitHub


    thanks, let me double check new tag

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212 & Khadas VIM2 q200
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | LE 64bit | balbes 3in1 | gentoo

  • Quick question and forgive me if it's a dumb question but i couldn't find in the install/update thread (or i'm just blind)
    Can i update from 7.0.3.012j to 8.0.1c by just using the image tar in the update folder. Or should i make a new 8.0.1c sd card and install the new install way?


  • Quick question and forgive me if it's a dumb question but i couldn't find in the install/update thread (or i'm just blind)
    Can i update from 7.0.3.012j to 8.0.1c by just using the image tar in the update folder. Or should i make a new 8.0.1c sd card and install the new install way?


    Hi


    update/install is described here : thread-5556.html


    Basically, you just have to drop the .tar file and reboot :)

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • Some versions ago I introduces changes that might have enabled 192kHz PCM on S905X. :D


    I pulled the old version "C" with non-working multichannel audio, new one is at usual place.


    kszaq - 192kHz Multichannel PCM now seems to be working on my S905X, thanks! I don't actually have any of my multichannel audio files encoded at above 96kHz, but several of my stereo (2.0) audio files are at 192kHz (or 176kHz), so if I "force" the sampling rate in the Kodi menu to be 192kHz my stereo 192kHz files will play back but my amplifier reports 5.1 audio with the centre and back channels silent. When I have "optimum" or "best match" set in the Kodi menu I don't hear any playback on these files.


    However, similar to my S905 I don't have any automatic playback of stereo above 96kHz - only 5.0 or 5.1 audio. Also, there is no option to "force" 176kHz sampling rate which would be used for high bit rate SACD audio (again, mostly stereo).


    I tried to raise the issue with the devs on GitHub, but I got my wrist slapped for raising user issues! I suppose that was understandable, but there is little understanding generally of high bitrate audio. Most people are interested in 4k video and the various Dolby/DTS high bit rate audio rather than lossless PCM. Any devs on LibreELEC forums I could engage with? I think this is just a setting issue within the builds for Amlogic as the actual hardware seems to be capable. I have no such issues with LibreELEC on my ION2 generic board but that box is huge in comparison to these little wonders!

    Edited once, last by fat-tony ().

  • I'm sorry but I don't know how kernel audio driver works and I tinker only with the easiest part. I cannot help with resolving your issues.


    What I can tell is Amlogic audio driver is very, very messy and works only in some configurations. It needs fixing or a complete rewrite.


    There's still some hope that Kwiboo will find some time to work on driver or someone else with knowledge picks this up...



    I tried to raise the issue with the devs on GitHub, but I got my wrist slapped for raising user issues!


    Actually they were right, Pull Requests are to discuss development, not to raise issues. As far as I know there is no dev with deep audio driver knowledge except for Kwiboo and we have to wait for him.

    Edited once, last by kszaq ().

  • Thanks kszaq - I did say it was understandable that I got reprimanded, but you get nowhere if you don't ask :P


    It's a weirdie though as regards the audio driver all right. It just doesn't seem to work with the Kodi code when the audio stream is identified as two channels above 96kHz but seems ok when it's six or more channels. I'll download some test files and do some more digging!