[8.0.2e] LibreELEC 8.0 for S905/S905X

  • 8.0.0c in OP.


    Changelog:

    • Kodi updated to 82eaae9
    • fixed reading ethernet MAC address from eFuse and added reading from nand_env
    • minor improvement in copying user data in installtointernal script
    • experimental: better scaling of Mali cores for smoother GUI
    • experimental: backport Kodi PR11713: Search backwards for keyframe when resuming playback

  • Frame skips are fixed since beta6.


    Hi kszaq


    I've also seen a lot of "frame skips" using 8.0.0b, on a fresh install. Especially when seeking into a file.
    I'll post a proper bug report later today.

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • Hi kszaq


    I've also seen a lot of "frame skips" using 8.0.0b, on a fresh install. Especially when seeking into a file.
    I'll post a proper bug report later today.


    Same here. But I really think they were not present in Beta6 and reappeare in 8.0.0a. Would have to check this.


  • I've also seen a lot of "frame skips" using 8.0.0b, on a fresh install. Especially when seeking into a file.
    I'll post a proper bug report later today.


    There will always be skips when seeking because decoder needs to look for a key frame and settle down. After it's settled playback is smooth. I'm very sensitive to frame skips and I haven't seen them in playback since beta6 except for some very specific samples - but this is disclosed in "known issues".

    Edited once, last by kszaq ().


  • 8.0.0c in OP.


    Changelog:


    [*]experimental: backport Kodi PR11713: Search backwards for keyframe


    kszaq - You sir, are a mind reader! I was hoping this would show up when I saw it in the recent Kodi commits.


    The EDL patch continues to work as expected, have used it 7-8 times a day. The only issue I have had is an occasional freeze after the jump. However, I am having the same occasional freezes from time to time when seeking, resuming from pause and sometimes after frame rate change pauses. consequently, I do NOT think this is related to the EDL patch, but has something to do with seeking behavior in general.


    Edit: Upgraded to 8.0.0c and WOW! What a difference in the gui speed, like night and day. Feels almost as snappy as Jarvis was. Too soon to tell if the random freezing is fixed, but so far so good. Excellent upgrade.

    Tomato X96 s905x 2G/16G - 8.0.1i
    OTT MXQ s805 1G/8G - HD18Q.arm-7.0.3.2
    MythTV Backend w/HDhomerun PRIME

    Edited once, last by Jaaxx ().

  • Hi guys
    I have a question in regards to the installation. I have 2 OTT MXQ Pro boxes
    On one of them I followed the instructions listed and did the "update&backup" from main android OS to allow dual boot. Then I created the image on the SD Card and installed successfully. Although the GUI was slow and sometimes seemed unresponsive, is that normal or a limitation of the MXQ pro?


    Secondly and my main issue, the second MXQ pro I have has a different style OS. The first box has the iron man picture of Robert Downey jr while this second box has a metro windows 10 style OS and when I go to apps there is no "update&backup" app at all. So how can I update this box to allow booting from SD Card? I tried skipping this step and just using the SD Card but it would boot


    Thanks in advance

  • Hello Friend kszaq first of all thanks for your great work with this awesome builds just one question does this build have Minix U1 Analog Audio drivers in it ?


    Once again Thanks a Lot

    Edited once, last by kszaq ().

  • Just joined to voice my appreciation. I have a GooBang Doo "2017" KODI Box labeled as M8S-II (s905/2gb/8gb ROM/1Gbit/4K, etc etc) and was getting frustrated with the changes in pass-through from Jarvis to Krypton (I understand the reasons) but the box had a very cobbled together Android 5.1 (not 5.1.1) build on it. So I did some research and came across LibreElec and kszaq's 7.x thread. So I figured, what the heck, won't hurt to try.


    Let me say a few things as a developer myself:


    1) I have NEVER seen such a clean kernel boot log, I was impressed.
    2) Using the default image, everything worked out of the box for me. Saw eth0, wlan0, usb sticks, usb wireless keyboard and even my stock remote worked. What was most exciting was that CEC worked with the stock remote whereas before it would just alter the Android volume level (causing all sorts of problems audio-wise.) I was so impressed with this that I had to call my wife over to show her which of course, did not impress her like it did me :)
    3) The speed; I figured with just a bare minimum OS and KODI it'd be fast and light, I was shocked to see how much so. Krypton on the NAND consumes 41% memory whereas your build consumed 9% -- I realize it's not exactly apples-to-apples but was another scenario I called my wife over who by this time was getting annoyed with me and my geekdom.
    4) Playback from my NAS and Addons was flawless. I now have DTS + friends back again as well. Finally my wife was impressed as she watched an episode of Mayday and was shocked how fast it found and loaded the episode compared to what we're used to.


    So now that I have a working start, I have decided to give 8.x a whirl and see how that goes. I've been humming and hawing whether to try and backup my NAND but since it's a broken junkpile I'm leaning towards not.


    Basically, it worked better than my wildest dreams would have imagined.


    Anyways, I just joined to voice my appreciation and admiration. You have done a very good job Sir, color me very impressed. You've made me a very happy geek, husband and father (sure my kid will be impressed too when I show him.)

    GooBangDoo M8S-II S905 2GB/8GB/1Gbit (p200_2GB_1Gbit) - LibreELEC 8 (kszaq 8.2.2.1 aarch64)

    TVHeadend 4.3-792~gc1a5e43 / Emby 3.2.60.0 (OpenMediaVault 3.0.94)

  • thanks for the info kszaq, i'll do some more testing over the weekend. definitely understand about frame skips during seeking

  • Just try 8.0.0b and all work fine !!!
    My dts and dd ac3 works fine ;)
    I install the french langage "addon-kodi repository-look and feel ..."
    Really great job ;)
    On my s905 , with a 1080p video with dts 5.1 sound , only 4% processor ressource and a little 45% memory usage !!!