[8.0.2e] LibreELEC 8.0 for S905/S905X


  • On my wetek hub, the ir remote stopped working after I upgraded beta6 to 8.0.0a. Manually doing a



    Code
    remotecfg /flash/remote.conf


    fixed it.


    Same for me, need to run the above command after every power up or reboot though.


  • Same for me, need to run the above command after every power up or reboot though.


    I added the command to my autostart.sh.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test


  • Missed that one. I'll post 8.0.0b with this issue fixed in a few hours.


    Thanks for all the hard work on this.


    however I still have a problem building from source :( I get a problem while compiling peripheral.joystick


    here is the paste bin


    /elec/kazaqs/LibreELEC.tv/build.LibreELEC-S905.arm-8.0-devel/peripheral.joystick - Pastebin.com


    when I remove the dependency from /virtual/mediacenter everything compiles without a problem.


    I know its something stupid o my side, but past releases (prior to b5 I think) compiled without a problem on the same machine.
    I am running this command to compile


    make amlpkg PROJECT=S905 ARCH=arm



    any idea?


    Thanks!

  • I want to be sure, with .tar file i dont need put also dtb.img in update when iam on working beta6 (nand) ? :) Its only need with img.gz?


  • however I still have a problem building from source I get a problem while compiling peripheral.joystick


    Please pull the latest sources, this has been fixed in 8.0.0a.
    [hr]


    I want to be sure, with .tar file i dont need put also dtb.img in update when iam on working beta6 (nand) ? :) Its only need with img.gz?


    If upgrading from 7.0.3.012 or beta1-6 you don't need to put dtb.img both when using tar and img.gz. But you can. ;)

    Edited once, last by kszaq ().

  • Fantastic work, makes the Minix neo u1 an excellent box, just updated, wish I'd seen about the IR bug before I did lol, looking forward to the fix. Keep up the impressive work.

  • Hey kszaq! Thanks for your hard work! Tell me please do box need sd card to be inserted when running from nand? Can't get it to boot without sd...



    edit: Well for now it's not booting at all :cry: got those files on sd dtb20170220180255.img and recovery20170220180255.img
    How can I use these to boot box? ;)

    Edited once, last by Borygo77 ().

  • I was running beta5 (no issues) - upgraded to 8.0.0a and lost use of the stock remote. My box is Mini M8S II (S905X). USB mouse/keybaord work fine.


    I just updated to 8.0.0b and still no stock remote.


    Any ideas?

  • I get this when trying to compile it myself:

    Code
    Creating Amlogic ZIP update package
    cp: cannot stat '/home/koen/LibreELEC.tv-8.0/projects/S905/install/update-binary': No such file or directory
    Makefile:18: recipe for target 'amlpkg' failed

    Edited once, last by koenkooi ().

  • Hi kazaq,


    first at all thank you for your work and your great builds.


    Right now I'm using your 7.95.beta6 image with afl1 internal dvb driver implementation on my k1plus.


    Before I used 7.0.2.004.4 image.
    With this image CEC was working.
    When I switched the K1plus on, the TV was turning on.
    When I switched it off the TV was turning off.


    With your 7.95.beta6, CEC is only working partially.
    I am able to control the K1plus with the TV remote and I'm able to turn it off when I turn off the TV.


    Is there a way to fix this?
    (While playing around with CEC settings I noticed that when Kodi sends "active" at start it is only booting when I turn on TV first)



    Another question is, if it is possible to implement Miracast and Airplay into your builds.
    The original android images for K1plus are capable to use this functions.

    Edited once, last by tonitiger ().

  • I was wondering if it's possible to somehow upgrade to Kodi 18 with this build? Or alternatively, if you could make a build with Kodi 18 already installed?
    It's just that I'd love to try the Estuary MOD V2 skin, but apparently it's Leia-only. For who knows what reason...


  • I get this when trying to compile it myself:

    Code
    Creating Amlogic ZIP update package
    cp: cannot stat '/home/koen/LibreELEC.tv-8.0/projects/S905/install/update-binary': No such file or directory
    Makefile:18: recipe for target 'amlpkg' failed


    amlpkg is no longer supported, please use make image.