RPI4 - HDMI-CEC not working

  • On my QE65Q60 after command echo 'scan' | cec-client -s -d 1

    but not working :(

    Hi,


    did you tried some of the basic commands from here: Raspberry Pi: Power On / Off A TV Connected Via HDMI-CEC - Linux Uprising Blog

    like turn off/on the tv via HDMI-CEC from the PI? or switch the active source with this: 'as' ? I would go with some easy commands to see if the hdmi-cec is working correctly, out of this image for me it is interesting why the Vendor is not known...


    Second option to check. Install add-on Keymap Add-on:Keymap Editor - Official Kodi Wiki (i used this video

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.
    ) with this installed try to check if you remap a left button and push left on your remote, do you get something? (a number or something like in the video?) at the end you do not need to save Keymap :)


    For me I have a samsung tv remote with some pre defined buttons, like Netflix, Prime (i am not happy with it, but that's the way...) and unfortunately the button "Exit" in my old Samsung TV was the simple command to go back, navigate back, previous menu... now in this remote this is not working :D so i needed to remap it to button A(red)...


    Last but not least, i have a Samsung TV with this new Tizen OS (not better, but once again that's the way... :) ) , so in this newSamsung (pictures attached) look-a-like setup when i connect my PI over HDMI to the TV then the HDMI-CEC setup starts... and there is a predefined list of hardwares like blueray players, AVs, XBOX, PS4, soundbars, lot's of stuff... but PI only works for me if I select "PC"... no clue why, as said before this only in the newSamsung Tizen OS.

  • Hi Hlpbob07,

    primarily i Thank you for your Reply and kicking me :)

    Today i discovered maybe mistake with my Samsung QE65Q60 (TizenOS)

    First i disconnect all devices from TV and put only alone Raspberry4 (Libreelec Kodi). First put in HDMI1, after i tried via putty som command "

    echo 'scan' | cec-client -s -d 1". Immediately i become this:

    I see Vendor Samsung, but Samsung Remote controll not working..So i wrote this command:

    Code
    echo 'on 0.0.0.0' | cec-client -s -d 1

    nothing success, remote control not working...so after:

    Code
    echo 'as' | cec-client -s -d 1

    After this command my Samsung show:


    HDMI3 (No signal)...but why? I have Raspberry in HDMI1! Ok, no problem. I put Raspberry to HDMI3.

    After connecting to HDMI3 in Samsung i give Raspberry like "PC", now Samsung Remote control working Well without Addon Keymap Editor and other :)

    I was really happy...until if i connect other HDMI device (i have only Satelite reciever Amiko HD8150 - without CEC support).

    So i put this device to HDMI1, or 2, or 4 it doesn't matter, beceause Raspberry Kodi in HDMI3 stop working :( S*IT !!!

    There is Problem. If raspberry is alone in HDMI3 and on Samsung like "PC", CEC working well with Samsung remote control (but only in HDMI3 port on TV)

    If i put my Satelite reciever Amiko HD8150 to HDMI1, 2, 4 and with other HDMI cable, CEC in Raspberry stop working and after command:

    Code
    echo 'scan' | cec-client -s -d 1

    i see this:

    I have all other device disconnect from TV and leave Raspberry 4 alone in HDMI3. If problem on TV? Or Raspberry ?

    Why I have such problems ?!! I'm really unhappy :(

  • Hi, vencakratky,


    first, if you have your TV on already adding on command does not bring you a visible feedback if it really works. Try standby or pow (also described in the link). Secondly have you ever tried to connect all your devices (HDMI port # i think does not matter, but who knows nowadays :) ) and scan them? if they are visible try on and standby and pow or any other visible feedback commands volup and see if they respond. Do not forget maybe you need to add the device # as stated in some examples. If you go one page before, there is a snapshot of my other setup, I have an older samsung tv, connected thru a Receiver and then RPi 2. the Pi sees all 3 devices. So if your Amiko is CEC compatible and the HDMI cable is good, Pi4 should see and control as well.

    Also there are options (i am not sure if you touched that before) inside Kodi when you go Settings/System/Input/Peripherals there you can edit your libCEC which can also affect your setup (+ you have the samsung tv, but honestly i do not see much of an "edit" in TizenOS there)


    I believe CEC is not so straightforward as sometimes it is described, i needed to 4 times install from NOOBs when I was finally found the almost right solution (since my remote is not 100% perfect :D ) and I am still waiting for my new cable from Amazon...

  • I could swear my Rpi4 CEC problems started right after i upgraded the USB3 controller ROM and some other ROM (bootloader?) .. not sure why those would affect CEC.. i tried changing HDMI cables, couldn't get a picture with some cables.. i got it to work once, but then after changing HDMI inputs and back CEC was gone again.. i hope mine will be fixed with 9.2.1 as others have reported here..

    my CEC is also no longer working. I also remember updating the ROMs. Might be a connection between this.

  • Cec issue - all works fine, but when I turn off my tv a and then turn it on cec stops working after few seconds. Same situation after changing source on tv and switch back to Libreelec.


    HW - rpi4, Sony Bravia.

  • If it helps, for me the problem was also the cable.


    With this B00ODTCAYS (Amazon ASIN), no CEC,


    but with this one, B014I8TZXW, bingo. CEC working.


    Thanks to Team Kodi and LE crew.

  • Just wanted to note - i was having the same problems after I got an RPi4 to replace an old RPi3B. They were both plugged into a Samsung LCD TV circa 2015 or so, and cec just wouldn't work with the RPi 4. I tried unplugging the TV for an hour, replugging power and the RPi4, but no joy.


    In light of the cable advice above, I purchased an array of different quality (black) cables - including ones rated for 8k video and HDMI 2.1 etc., but switching out the cables didn't make a difference. When I ran cec-client -s -d 1 I could see the RPi4 was talking to the TV and able to see other connected devices, but the cec driver just wouldn't load completely, and so cec remained unusable.


    FIX: I also had a firestickHD connected to one of the three HDMI ports. We never use it, so I didn't think to unplug it. I finally got around to unplugging that and then unplugging power to the TV, then powering up the TV with only the RPi 4 installed... and cec on the RPi4 immediately worked. I went back and tried the white Raspberry Pi official micro-HDMI cable and it worked fine too. I then reinstalled the FirestickHD and now everything is working together.


    So, before you purchase a new cable, try unplugging all devices connected to any HDMI port on the TV (and probably any intermediate devices, like a stereo receiver), then unplug power to everything you're going to connect back up, and then power the TV, plug the RPi4 into your desired HDMI port, and then power the Pi. You should be good to go, but test it first, and replug all the other HDMI devices only after cec is working.

  • My solution was to disable the PQLS feature in the HDMI settings on my Pioneer VSX-924K AVR (which is between my Pi and my LG UJ63 TV). It seems to have fixed my EAC-3 (DD+) problems as well, so this fix was certainly beneficial for me! 🤩

    Edited once, last by ppallo ().

  • I had mine working for a long time and it still works if the pi 4 is the only thing plugged into the (samsung) TV, but now I have a soundbar in the ARC hdmi port, and can't get it to work. Plugging in a game console breaks it too.


    Would love to have both sound and a remote.


    Having a good cable is necessary but it's not sufficient and unplugging your TV for 10 minutes does work sometimes, but it's less than ideal.

    How do we figure this out?

    You can ssh into my pi4 if you want to

  • Hi

    I have such a strange problem. When I run RPI4, Kodi connects to TV CEC, but it doesn't work well.

    Only basic functions work.

    The solution to my problem is:

    - turn off the TV for a while,

    - disconnect the HDMI for a while,

    - change anything in CEC settings in Kodi (Settings-> System-> input). After reloading Pulse Eight everything works fine until RPI4 is restarted.


    The problem only occurs on the MASTER branch. I tried different versions of libcec and p8-platform but couldn't find a solution. My TV is 8 years old Panasonic.

    I came back to LE9.2 because everything is OK there.

  • Sorry for waking an old(ish) thread. The cable can definitely be the cause for CEC not working. Even a regular full size HDMI to micro HDMI (i.e. not using an adapter) can cause CEC to not work. I had three different micro to full size cables laying around and CEC only works with one of them.


    I've been using one that didn't work, I have just thought that CEC was broken with LibreELEC and the Pi4 and haven't bothered to do proper troubleshooting, but now I can use my TV remote instead of a bluetooth keyboard or app!

  • Hi all!


    The problem is still present using RPi4 8GB and TV Samsung UE55NU8055.


    The HDMI cable is connected to the first RPi4's port, next to the USB-C power input.


    CEC is working only if the RPi4 is the only device connected to TV (so I can assume the HDMI cable is ok). If I add another CEC enabled device (Xiaomi Mi Box S in my case), CEC stops working on RPI4. If Mi-Box is on stand by with CEC enabled, CEC doesn't working on RPi4. If I disable CEC on Xiaomi or I unplug the power cord, CEC starts working again on RPi4.


    I'm using a RPi3 for more than three years in exactly the same setup and I never experienced this problem. I suppose this issue is a software problem related to the RPi4 and/or LibreELEC/Kodi.


    It would be nice to have this issue solved somehow, it has been a while since this problem was reported by a lot of users.

    Edited 2 times, last by racko ().

  • No, it doesn't. 😁

    huh, it actually does work with my Samsung NU8000 remote CEC on the microHDMI port near charging port. It didn't a year ago when I first tried it :) glad they fixed this, it would make it useless for me.

  • It's working also with my my Samsung TV as long as I don't have another CEC enabled device connected to the TV in the same time. Which I have.

  • It's sort of running now after fourth attempt doing the exact same thing. Now I'm having issues with LONG, easily 30s stalling when moving between SMB folders. None such issue with LE9 on my old RPi2.

  • I finally got my Raspberry Pi 4 (8gb) model with LE9 working on a Sceptre 65". Putting the microHDMI into the port next to the power and in HDMI 1 of the TV, as well as adding hdmi_force_hotplug=1 and hdmi_drive=2 in my config.txt. Not sure how many of those were necessary but it does finally connect to CEC at start.


    My only problem now is that the performance is pretty lackluster. It locks up every so often and nothing happens, although the TV menus are fine still. There is also some screen tearing going on. Changing it to 1080p / 60hz from 4k seems to making it a bit smoother but there is still some vicious lag and freezing.


    None of this exists on my Raspberry Pi 3.