RPI4 - HDMI-CEC not working

  • Good afternoon,


    TV Model: Samsung UE55es8000

    Raspberry pi model 4b

    libreelec - tried all versions available


    Please note that HDMI-CEC doesnt work on PI4 with my tv. its been working fine with pi2 and pi3b's but not with pi4. Everything else works flawlessly but not hdmi-cec as a result, cannot use the tv remote with pi.4


    I've tried changing cables, ports, reset, different versions of libreelec - nothing works.


    I'd appreciate if someone could help me.


    Cheers

    MJ

  • Iridium

    Approved the thread.
  • I doubt very much this will help but watch this:


    Thanks but this is very basic requirment for hdmi-cec to work, if this wasnt on it wouldnt have worked for rpi3 or anything else but it does. just rpi4 isnt working

  • Did you unplug the TV for 15 minutes and turn it back on ?


    Hey - I know it sounds silly but if you read the YouTube comments, you'll see it fixed the problem for a lot of people.


    Just possibly, the Samsung TV "remembers" the older RPi's CEC settings and by turning CEC OFF & ON or unplugging the TV for 15 to 30 minutes, the CEC settings get refreshed for the newer RPi 4 (only a wild guess).

    Edited 4 times, last by blueribb ().

  • CEC works on my earlier Pi's, and I've never had CEC connection issues with my samsung, beside buggy stuff that can be fixed or worked out.

    My micro hdmi cable is old though, so I will look into buying a new one in the coming weeks.

  • CEC works on my earlier Pi's, and I've never had CEC connection issues with my samsung, beside buggy stuff that can be fixed or worked out.

    My micro hdmi cable is old though, so I will look into buying a new one in the coming weeks.

    I've done all these test and can confirm hdmi-cec doesnt work (atleast) for samsung tv but worked for earlier rpi's.

    Edited once, last by Mj1857 ().

  • ok - cec-not working so far on panasonic or samsung tvs on RPI4 which previously worked on all pi's.


    If any developer watching this thread, please help?

  • Hello all,


    LG tv same problem.

    RPI 2 & 3 - CEC works for years, RPI4 not working.

    Thanks for fix.


    Edit:

    Sorry, I was to fast with posting.

    After googling in some other forums, I have found, that for CEC to work, HDMI must be plugged to the port next to the usb-c/charging port. Moving the HDMI cable from the other HDMI port to this one helped and now the CEC is working as well.

    Might be a good tip for someone new as me :)

    Edited once, last by pokosoft: problem solved for me ().

  • Glad it worked for you by changing port but unfortunately it does work for me no matter which port its plugged into.

  • I've figured it out!

    At least for my situation - it was the damn microHDMI adapter - tried with a microHDMI cable and it works fine!

    Maybe try a different cable...

    TV Panasonic TX55CS620E

    RP 4GB